Jump to content
UltiMaker Community of 3D Printing Experts

Cura 4.4.x Erster Extruder immer T0


ecs
 Share

Recommended Posts

Posted (edited) · Cura 4.4.x Erster Extruder immer T0

Hallo

Ich habe das Problem das Cura den ersten Weg Materialvorlauf)  immer mit T0 druckt.

Egal ob ich mit Extruder T0 oder T1 slice.  Der Skirt wird dann  richtig gedruckt. Aber bei kleinen Teilen

ist noch Filament von T0 in der Düse, und es kommt zu einen ungewollten Farbverlauf imSkirt und dem ersten Layer.

Wenn ich mit T0 slice fällt das Problem logischerweise nicht auf.

Kennt jemand eine Lösung um auch diesenMaterialvorlauf mit T1 zu drucken ?

Danke für eure Hilfe

LG

Christian

 

 

 

Startsequenz  G-Code

;Generated with Cura_SteamEngine 4.4.1
T0  -   Hier ist immer T0 auch wenn ich mit T1 Slice
M140 S60
M105
M190 S60
M104 S210
M105
M109 S210
M82 ;absolute extrusion mode
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
G92 E0
G1 F200 E3
G92 E0
G1 X5.0 Y5.0 F7200; Link Position für das Aufheizen
G1 Z3.0; Z-Achse senken vor dem Aufheizen
G1 Z0; Duese senken fuer das Material abstreifen
G1 Z0.2; Duese etwas anheben fuer Material Vorlauf
G1 X100 E20 F600; Material Vorlauf ausfuehren
G1 Y5.2
G1 X5
G1 E19
G92 E0
T1  - Ab Hier geht es mit dem geslicten Extruder los. T0 oder T1
G92 E0
G1 F2400 E-3

Edited by ecs
  • Link to post
    Share on other sites

    Posted · Cura 4.4.x Erster Extruder immer T0

    Hallo

     

    Was ist wenn du einfach in deinen Startcode T1 reinschreibst.

    Bzw. vielleicht gibt es einen Platzhalter

     

    Vielleicht funktioniert der {extruder_nr}

    T{extruder_nr}

     

    On 2/6/2020 at 2:00 PM, ecs said:

    T0  -   Hier ist immer T0 auch wenn ich mit T1 Slice

     

    Ich habe gerade mit Cura 3.6 getestet da steht nicht immer T0. Habe alles auf T1 geändert dann stand da auch T1.

    Hast du den Skirt deaktiviert? Für den jeweiligen anderen Extruder.

    (Ich kann nicht mit Cura 4.4 testen da mein Dual Profil noch nicht umgeschrieben ist)

    Ich gehe davon aus das du kein UM drucker hast oder?

     

    Gruß

  • Link to post
    Share on other sites

    Posted · Cura 4.4.x Erster Extruder immer T0

    Ich Habe einen Geeetech A20M ( 2 Extruder eine Düse).

    T0 und T1 habe ich im Startcode der Extruder eingetragen.

    Einstellungen: left Extr. = T1 (weiß)     right Extr.=T0 (rot)

    stelle ich nun T1 bei left Extruder für Wand auf "weiß", wird auch bei right Extruder T0 auf "weiß" umgestellt.

    Also ist für Cura T0 und T1 gleich ein Extruder.

    Es ist für mich unverständlich und nicht Nachvollziehbar.

    T0 T1 T2 .... sind Werkzeugdeffinitionen. Also darf T0 nicht gleich T1 sein.

    Mein Gedankenfehler, oder Bug in Cura ?

    Kannst Du bitte bei der Version 3.6 testen ob es auch so ist ?

    Danke

     

    T0T1.png

  • Link to post
    Share on other sites

    Posted · Cura 4.4.x Erster Extruder immer T0
    3 hours ago, ecs said:

    stelle ich nun T1 bei left Extruder für Wand auf "weiß", wird auch bei right Extruder T0 auf "weiß" umgestellt.

    Also ist für Cura T0 und T1 gleich ein Extruder.

     

    Nein, es ist genau andersherum. Hier wird ausgewählt, mit welchem Extruder die "wall lines" gedruckt werden. Da kann es nur eine globale Einstellung geben. Das erkennt man an dem kleinen Kettensymbol.

    In diesem Beispiel können die Wandlinien entweder in weiß oder in rot gedruckt werden, aber doch nicht beides....?

     

    On 2/6/2020 at 2:00 PM, ecs said:

    Kennt jemand eine Lösung um auch diesenMaterialvorlauf mit T1 zu drucken ?

     

    Das "T0" vor dem Startskript hat mich auch schon gestört, Cura trägt dort immer ein, was es als "inital extruder" erkannt hat. Falls Skirt oder Brim nicht explizit ausgeschaltet wurde, sollte das immer die {adhesion_extruder_nr} sein.

    Also sollte es eigentlich helfen, als "Adhesion extruder" auch den T1 auszuwählen.

     

    Das Startskript von oben enthält offenbar keine explizite Tool-Auswahl (T0 oder T1) und auch keine Temperatur-Befehle - das wurde doch davor und danach von Cura implizit dazu generiert, oder nicht?

    Wenn nur mit einem bestimmten Extruder gedruckt werden soll, kann der andere in Cura deaktiviert werden. Ich habe es noch nicht ausprobiert, aber damit müsste das deaktivierte Tool eigentlich auch komplett aus dem generierten gcode verschwinden.

     

    Wenn alles nichts hilft, würde ich an den Anfang des Startskriptes noch eine Zeile setzen mit:

    T{adhesion_extruder_nr}

     

     

    3 hours ago, ecs said:

    Geeetech A20M ( 2 Extruder eine Düse)

     

    Wie hast Du dafür das "Temperaturproblem" im Dual-Druck gelöst? Cura selbst bietet ja bisher noch keine Unterstützung für so eine "shared-heater" Installation. Setzt Du dann einfach in Cura alle Temperaturen auf den gleichen Wert, oder ist der Geeetech schlau genug, das jeweils passend für den aktiven Extruder selbst zu regeln?

     

     

    On 2/6/2020 at 2:00 PM, ecs said:

    bei kleinen Teilen

    ist noch Filament von T0 in der Düse, und es kommt zu einen ungewollten Farbverlauf

     

    Nur aus Neugier:

    Wie funktioniert das denn im späteren Verlauf, wenn zwischen den Extrudern gewechselt wird? Ist dann der "Materialvorlauf" länger als die 20mm aus dem Startskript, oder gibt es einfach einen sehr großen Purge-/Prime-Tower, oder wie funktioniert das?

    Macht der Drucker den Farbwechsel automatisch beim Werkzeugwechsel, oder sind dafür auch Skripte in Cura hinterlegt?

     

  • Link to post
    Share on other sites

    Posted · Cura 4.4.x Erster Extruder immer T0
    2 hours ago, tinkergnome said:

    Nein, es ist genau andersherum. Hier wird ausgewählt, mit welchem Extruder die "wall lines" gedruckt werden.

    Habe es mit allen Ootionen versucht, es wird immer auf beiden Extrudern das gleiche aktiviert !

    Das war nur als Beispiel zur Veranschulichung gedacht.

    -- Es ist einfach so das wenn ich auf Extr 0 Material von Extr. left aktiviere auch auf Extr1 Extr. left aktiviert wird.

    Das ist unverständlich, da left und Right als  T0 und T1 behandelt werden.

     

    2 hours ago, tinkergnome said:

    Das "T0" vor dem Startskript hat mich auch schon gestört,

    Danke für den Tipp, werde es heute Versuchen

     

     

    2 hours ago, tinkergnome said:

    Wie hast Du dafür das "Temperaturproblem" im Dual-Druck gelöst?

    Extr.left und Extr. Right können mit versch. Temp. betrieben werden.

    Geeetech ist ein Chinese, also nichts mit schlau  ;-( nein kann er nicht.

     

     

    2 hours ago, tinkergnome said:
    2 hours ago, tinkergnome said:

     

    Wie funktioniert das denn im späteren Verlauf, wenn zwischen den Extrudern gewechselt wird?

    Ich mache die Farbübergänge mit einem Tool von Geeetech. Bei einem Farbverlauf ist ein Purge-/Prime-Tower nicht nötig.

    Bei Farbwechsel ohne Verlauf wird ein Purge-/Prime-Tower gemacht.  Und bei Wkz wechsel T0 T1 kommt es zu diesen Effekt das beide Extr.  left oder right sind. Also mit T0 wird gedruckt (left Extr.) Wenn nun auf T1 gewechselt wird ist lt. Cura wieder left Extr. aktiviert. Seltsam aber so ist es. Jede CNC hat eine klare deffinition des Werkzeuges über T1 .. T255. In Cura sind alle T gleich ?

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
         
         
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
         
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
         
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.
         

         
        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 10 replies
      • UltiMaker Cura 5.3.0-Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
         
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 16 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...