Jump to content
monomax

probleme ER04

Recommended Posts

Posted · probleme ER04

Bonjour a tous.

 

J'ai depuis quelque jour un problème avec ma machine, l'erreur ER04 s'affiche et surtout bloque tout.

dans un premier temps enlever et remettre les cavaliers sur la carte mère suffisé a faire disparaître l'erreur.

Mais maintenant, plus rien a faire... la machine reste bloquer a cause d'une sécurité que je n'utilise même pas (qqun l'utilise?)

 

J'ai démonter la carte mère pour un inspection, et je ne vois rien d'anormal, en revanche en démontant j'ai pu voir q'une petite rondelle M3 en inox se baladé sur la carte...

 

Je pense essayé de supprimer cette sécurité directement dans le firmware, mais bon sa se complique un peu, difficile de lire correctement marlin pour faire les choses bien...

 

Quelqu'un a t'il déjà supprimer cette sécurité?

 

Merci.

 

Share this post


Link to post
Share on other sites
Posted · probleme ER04

Salut,

 

Peut être le composant qui interface les cavalier et le microcontrôleur qui pose pb.  (U7   NE555)
Dans ce cas là une modif de firmware ne sera pas suffisante car ce composant coupe aussi l'alimentation de la buse et des moteurs...
l'idéal si tu veux supprimer cette protection inutile c'est de faire une modif hardware.  Je peux te donner la procédure si tu es suffisamment bien équipé pour modifier la carte.

 



 

Share this post


Link to post
Share on other sites
Posted · probleme ER04

En équipement je n'ai qu'un fer a soudé standard (40 et 80w) et un multimètre.

 

En revanche j'ai soudé directement les broche des cavalier sous la carte, et sa a suffit a faire disparaître l'erreur, mais je sais pas pour combien de temps.

Mais déjà cela signifie que la puce U7 Ne555 va bien 😉

 

Si l'erreur réparait, je relancerais se poste pour suivre tes conseilles.

 

par curiosité en quoi consiste la procédure?

 

 

Share this post


Link to post
Share on other sites
Posted · probleme ER04

l'idée c'est d'enlever U7 (ou au moins couper la 3ème broche)     enlever et court-circuiter T3   et enfin mettre à la masse  R109

Share this post


Link to post
Share on other sites
Posted · probleme ER04

 

Merci pour tes explications.

 

Mon bug est revenu...

je vais donc opérer la carte .

 

Mais petites questions avant.

 

J'ai fais un shema avec les modifs à faire

 

-pour court-circuiter T3, est-ce bien comme sa?

 

-et relier r109 à la masse, est-ce bien le bon coté?

 

Ps: ma carte est une 2.1.4

supression safety err.jpg

Share this post


Link to post
Share on other sites
Posted · probleme ER04

Salut.   
non ce n’est pas ça.   J’essaie de te faire la correction demain.

Share this post


Link to post
Share on other sites
Posted · probleme ER04

salut,

 

Voici le schéma de la modif.

 

couper la broche 3 (avec une pointe fine de cutter) et la dessouder
enlever le transistor et le court-circuiter
relier R109 à la borne de C32 qui est une masse

 

 

 

modif u7.jpg

Share this post


Link to post
Share on other sites
Posted · probleme ER04

J'ai fait comme ton schéma et miracle tout fonctionne, l'erreur a disparu🤗.

 

Un grand merci à toi pour ton aide.👍

 

En espérant ne plus avoir de problème 😉.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...