Jump to content
Ultimaker Community of 3D Printing Experts

Help! CR-10s Pro Doesn't Auto Level!


Recommended Posts

Posted (edited) · Help! CR-10s Pro Doesn't Auto Level!

When I slice my object in cura with this start gcode (I have tried the original and other versions too).

M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
M220 S100 ;Reset Feedrate
M221 S100 ;Reset Flowrate

G28 ;Home
G29
M413 S1;Power Loss Recovery
M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height
M140 S50 ;Start heating bed
M190 S50 ;Wait for bed to reach temp before proceeding
M104 S{material_print_temperature} ;Start heating extruder
M109 S{material_print_temperature} ;Wait for extruder to reach temp before proceeding

G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.70 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.70 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.70 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.50 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up

It probes, but the printer doesn't compensate for the bowed bed. What should I do? For now the printer with manual leveling works 90%. I feel that I am wasting the auto leveling system.

 

Edited by HenryK
  • Link to post
    Share on other sites
    Posted (edited) · Help! CR-10s Pro Doesn't Auto Level!

    I too have just recently bought a CR10s Pro, specifically for the ABL, and have had zero issues outside of the "triangle" patttern extruder purge at the start of each print.

     

    1st question i have - the g-code you're using looks very different to the one I have, what version of Cura are you running ?

    2nd - what printer config did you use ? i.e; have you used the stock printer config or did you custom it ? 

    3rd - which version of firmware are you using ?

    4th - Have you tried manually running the bed leveling ( which then stores the resulting "bed map" ) and then tried to print as normal ? - this is only a possible work around and diagnostic, not a fix. 

     

    Hopefully with more info, we can track down the issue 😉

     

     

    Edited by Longtoke
  • Link to post
    Share on other sites
    Posted · Help! CR-10s Pro Doesn't Auto Level!

    1: I am running the newest version of cura, this is my customized gcode, but the original code is no different ABL wise.

     

    2: The only thing I have changed is the build plate, I am using this one here.

     

    3: I am running firmware 1.7 something, (I can't check now because I am printing, and I will edit this post with the proper firmware) and I haven't tried updating it, I am afraid I will mess up because all I have is a mac.

     

    4: Yes, and it works fine, but I feel that I should be utilizing the ABL. Or maybe if it ain't broke don't fix it. 😁

     

    Hope this helps!

  • Link to post
    Share on other sites
    Posted (edited) · Help! CR-10s Pro Doesn't Auto Level!

    ok, first thing I can see is you're using both the M420 command and the G29 command.They are similar commands, you should be using one or the other, not both ideally.

     

    As far as the M420 command goes, I've found it to be the cause of a glitch with the purge resulting in a triangle pattern extrusion in addition to the edge side line purge on job start. Still working on why/how this happens so for the moment i'd recommend using the G29 instead. From what i understand witth g-code and marlin ( very limited i freely admit ) G29 is an all in one function where as M420 is more manipulable. Just having a poorly educated guess here, but using both M420 and G29 could be causing a conflict ?......either way, it's an avenue to explore. 

     

    Next I note you're using a magnetic bed, does this mean you are using an induction based bed leveling sensor ? 

     

    As to firmware version, i'm using the same 1.70 that comes installed as stock, shouldn't be an issue there unless you've managed to somehow receive a printer with a glitched version of the firmware. I would recommend a reflash of the same firmware, but only as a last resort. As to how to do this using a mac, I have no clue sorry 😞 

     

    Finally, regards your Cura version, have you tried using an earlier version of Cura. Creality ships their printers with Cura Version 2.xxx, so that's another thing to test to help pin the issue down.  

     

    See how goes, I will gladly explore it further, but hopefully a more knowledgeable forum user can weigh in and further clarify. 

     

    another question - are you printing via USB from Cura or from the micro SD slot. Reason i ask is in testing the direct connect today, it does limit the level of control you have on your printer, and that leads me to think it might be an issue related to the direct connect. You could also do some diagnostic by direct connecting via the g-code console. I.E; plug it in and give it about 30 seconds for Cura to realize whats going on then use the g-code console to send a G29 and then try the M420 the same way. It may help pin the issue down. 

    Edited by Longtoke
    additional question
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...