Jump to content
Ultimaker Community of 3D Printing Experts

Cura prepending unwanted Gcode to output file


Recommended Posts

Posted · Cura prepending unwanted Gcode to output file

I have a single hotend, dual extruder Artemis using Cura 4.8.0.  I also have other printers and am trying to get the tool change macros on each printer correct so that one Gcode file works for any printer.

 

The problem is that Cura is prepending a T0 tool selection to my gcode file, and this is causing problems with getting filaments loaded correctly based on the temperature of the hot end.  Here is the GCode, and the portion above "BKM START G-CODE" is what is prepended by Cura.  How can I disable this?

 

;FLAVOR:RepRap
;TIME:2228
;Filament used: 5.60737m, 0m
;Layer height: 0.2
;MINX:-28.37
;MINY:-42.584
;MINZ:0.3
;MAXX:28.37
;MAXY:47.872
;MAXZ:23.1
;Generated with Cura_SteamEngine 4.8.0
T0
M190 S60
M104 S205
M109 S205
M82 ;absolute extrusion mode
;BKM START G-CODE
M203 Z14000	; max feedrate
G28 		; Home

 

This is identical to this topic:

 

 

  • Link to post
    Share on other sites
    Posted · Cura prepending unwanted Gcode to output file

    "...so that one Gcode file works for any printer."

    Good luck with that one.  I guess I can understand why you wouldn't want to have to do 15 slices of a model for 15 different printers just because you don't know which printer will be available to use for the job.  I'm not a dual extruder guy but I've spent some time fooling with virtual multi-extruder machines in Cura.

    If the one printer has a two-into-one hot end that shares a heater, then it likely won't work as a conventional dual extruder machine.  I guess there would be conditions and settings combinations where it would work, and there would be others where the "shared heater" setting would cause problems ("standby temp" comes to mind).  I would also anticipate that those gcode files would be troublesome for a single extruder printer.

     

    In addition, extruders can have their own custom start and end gcodes as well.  In "Printer Settings" (a plugin that must be installed in the Marketplace) there is a setting for "Always write active tool".  Maybe you can play with that and see if it helps.  Another thing you could try would be to disable extruder "T1" when you generate a gcode file for a single extruder machine.

     

    "Ambidextrous means it won't work either way." - Me

    "Universal means you'll need a Harley tool and a cutting torch." - Me Too

     

     

     

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...