Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
will_57

Broken electronics

Recommended Posts

It appears that I have broken some (or all) of my printer's electronics. I just installed the dual extruder upgrade, and I made the mistake of installing the stepper driver incorrectly, where I was off by one pin. When I powered on the printer, it must have short circuited, since the power supply shut itself off after a few seconds. Also, the electronics fan was running at a noticeably slower speed. When I opened up the electronics, I saw the mistake I made and moved the stepper driver to the correct position. I powered the printer on again, and the fan ran at normal speed for a few seconds, util it slowed down suddenly. However, the printer did not short circuit itself, so I connected the USB cable to my computer. The printer did not connect, so I followed the instructions on the wiki and tried disconnecting the Arduino from the main electronics board and connecting it to three different computers, but none of them recognized the Arduino. This leads me to believe that the Arduino is broken, but I suppose it's possible that the main electronics board was damaged as well. So, my questions are, is there any way to know if my electronics board was damaged? Additionally, do I have to purchase the Arduino through Ultimaker? I can get what looks like the same part http://www.amazon.com/SainSmart-Board-Arduino-Robot-Duemilanove/dp/B00761NDCI/ref=sr_1_2?ie=UTF8&qid=1389222842&sr=8-2&keywords=arduino+2560 for about 1/3 of the price, but I don't know if the one in the Ultimaker store comes pre-installed with firmware that I wouldn't easily be able to install myself.

Thanks!

William

 

Share this post


Link to post
Share on other sites

You can install the firmware directly from Cura, so that's not an issue. The comment on that item you linked to says that it's not actually an ATmega2560, so, if true, you might want to avoid that. But any legit Arduino should work. You might consider getting one from one of the official resellers as listed here:

http://arduino.cc/en/Main/Buy

 

Share this post


Link to post
Share on other sites

It appears that I have broken some (or all) of my printer's electronics. I just installed the dual extruder upgrade, and I made the mistake of installing the stepper driver incorrectly, where I was off by one pin. When I powered on the printer, it must have short circuited, since the power supply shut itself off after a few seconds. Also, the electronics fan was running at a noticeably slower speed. When I opened up the electronics, I saw the mistake I made and moved the stepper driver to the correct position. I powered the printer on again, and the fan ran at normal speed for a few seconds, util it slowed down suddenly. However, the printer did not short circuit itself, so I connected the USB cable to my computer. The printer did not connect, so I followed the instructions on the wiki and tried disconnecting the Arduino from the main electronics board and connecting it to three different computers, but none of them recognized the Arduino. This leads me to believe that the Arduino is broken, but I suppose it's possible that the main electronics board was damaged as well. So, my questions are, is there any way to know if my electronics board was damaged? Additionally, do I have to purchase the Arduino through Ultimaker? I can get what looks like the same part here for about 1/3 of the price, but I don't know if the one in the Ultimaker store comes pre-installed with firmware that I wouldn't easily be able to install myself.

Thanks!

William

 

The same happened to me. My Arduino survived, but had to replace two stepper drivers. To check wheter those still work, you would however need a working arduino (or similar from ebay or amazon). You can then use a simple pinboard, some jumper wires, a 12v battery and some lines of code to see if your stepper drivers survived. You would have to upload the code to the board to turn the stepper motor via the stepper driver. Watch some youtube videos on "polulu a4988 bipolar stepper driver with arduiono" if you like.

 

Share this post


Link to post
Share on other sites

First of all know that the power supply that comes with the UM has a fail safe of some sort. Once it trips, you need to reset it by unplugging it from the wall and letting it full discharge. This is probably not an issue for you.

You can check for "bad" components because usually they get very hot.

There is one part I would check - it's the regulator that lowers the 19V to 12V. It's the part that gets the hottest even when things are working fine and it's the part that is supposed to be tilted away from the PCB into the airflow. It has 3 pins. When powered up one pin should be 19V, one 0V, and one 12V.

If the arduino got damaged this kind of implies that 19V got into the 5V line. So any 5V part on the PCB could be damaged. That's - well - most of the chips. Sorry to say. All the non-chips should be fine (resistors, capacitors, etc).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!