Jump to content

USB-Connection in Cura 4.10


Kopaka

Recommended Posts

Posted · USB-Connection in Cura 4.10

Sorry if this question is allready asked....☺️

I updated from Cura 14.7 to 4.10.

But in that version, my pc don´  t find my Anet A8.

Nor I don´t find any option to change or test or somethingelse

to look for the USB-Connection.

I tried out Cura 3.7 (or so) and that shows my printer is connected at Port 5.....

I hope I´  m here at the right site/place to get some help.

 

Thank you,all

  • Link to post
    Share on other sites

    Posted · USB-Connection in Cura 4.10

    Unless you have the means and time to debug Cura and your printer, you may be out of luck. Ultimaker does not actively develop the code for printing via USB, since current Ultimaker 3d printers do not support printing over USB. So if it does not work with your printer, Ultimaker are not going to put development time towards a solution, unless someone else does the problem finding and fixing work in such a way that it does not further cripple other printers.

     

    Your alternatives include printing via SD cards, using a program like Printrun to send the gcode that Cura created to the printer, or installing OctoPrint and the OctoPrint Connection plugin and have an integrated workflow in Cura.

    • Like 1
    Link to post
    Share on other sites

    Posted · USB-Connection in Cura 4.10

    AHoeben is the expert on this but there may be a couple of things you can try.

     

    I use the USB connection for controlling printing from the SD card in the printer (rather than sending gcode files over the USB from Cura which I've found to be glitchy).  I haven't had a problem with USB communication through Cura updates from 4.6 through 4.10.  I have used Cura USB Printing for troubleshooting posts like this one and Cura has no problem finding my Ender 3 Pro.  I have my own app for printing and it uses the Cura port driver.

     

    There are a few things you can try to troubleshoot.  I believe I understand at least a little of what USB Printing is doing to find a printer and I'll try to explain.

    With Cura open - click on Marketplace in the upper right.  It can take a minute to load.

    Click on Installed and scroll down to USB Printing and make sure it's checked.

    Since USB Printing hasn't been updated in about 3 years it would be wise to make sure the only device plugged in to a USB port is the printer.  I would use the same physical USB port that you know has worked in the past.

     

    When Cura starts it checks the operating system list for a port with a serial connection (in Windows it checks Device Manager).  If it finds one listed it opens the port and it runs through the different possible baud rates and asks for a temperature check each time.  When it gets a response it understands it populates the Monitor screen.  If there are no satisfactory ports then the routine stops.  5 seconds later it checks again in case you have plugged in a printer.

    Since it checks the operating system for a port the port must be configured as USB-Serial to be noticed.  That means the correct driver must be installed.  With the printer connected to the computer then Device Manager would say something like:  USB-SERIAL CH340 (COM5).  Some drivers install on only a single physical USB port and connecting to any other USB port on the computer is not noticed (that happens in Win7).  Other drivers adapt themselves to whatever USB port the printer is connected to.

    Understand that the Monitor in Cura can take up to a minute to populate so don't give up on it after only a few seconds.  When you installed 4.10 you should have allowed the port driver to install as well (I think it's the Arduino driver in the installation dialog).

     

    I run Windows so you would have to figure out what works in Linux or on a MAC.  I hope this gives you a start on things you can check.  The USB Printing utility in 4.10 should be identical to the one you had working in previous versions.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.8 beta released
        Another Cura release has arrived and in this 5.8 beta release, the focus is on improving Z seams, as well as completing support for the full Method series of printers by introducing a profile for the UltiMaker Method.
          • Like
        • 0 replies
      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 27 replies
    ×
    ×
    • Create New...