Jump to content
UltiMaker Community of 3D Printing Experts

[Solved] Printing Temperature Initial Layer not working


bassamanator
 Share

Recommended Posts

Posted (edited) · [Solved] Printing Temperature Initial Layer not working

No matter what I do, I can't get the first layer to print at the specified temperature, 270C in this case. If I set Printing Temperature to 270C, it prints at 270C throughout the print. I've also tried setting Initial Printing Temperature to 270C at the same time also and that doesn't work either.

 

What gives? Using Cura 4.10.1.

 

Thanks!

 

image.png.194d63808e57b35243f40848311e58fb.png

 

Start G-code

; Script based on an original created by tjjfvi (https://github.com/tjjfvi)
; An up-to-date version of the tjjfvi's original script can be found
; here:  https://csi.t6.fyi/
; Note - This script will only work in Cura V4.2 and above!
; --- Global Settings
; layer_height = {layer_height}
; smooth_spiralized_contours = {smooth_spiralized_contours}
; magic_mesh_surface_mode = {magic_mesh_surface_mode}
; machine_extruder_count = {machine_extruder_count}
; --- Single Extruder Settings
; speed_z_hop = {speed_z_hop}
; retraction_amount = {retraction_amount}
; retraction_hop = {retraction_hop}
; retraction_hop_enabled = {retraction_hop_enabled}
; retraction_enable = {retraction_enable}
; retraction_speed = {retraction_speed}
; retraction_retract_speed = {retraction_retract_speed}
; retraction_prime_speed = {retraction_prime_speed}
; speed_travel = {speed_travel}

G21 ;metric values
G90 ;absolute positioning
M82 ;set extruder to absolute mode
M107 ;start with the fan off
;*** Start preheating ***
M140 S{material_bed_temperature} ; start preheating the bed WITHOUT wait to what is set in Cura
M104 S{material_print_temperature} T0 ; start preheating hotend WITHOUT wait to what is set in Cura
G28 X0 Y0 ;move X/Y to min endstops
M190 S{material_bed_temperature} ; start heating the bed to what is set in Cura and WAIT
M109 S{material_print_temperature} T0 ; start heating hotend to what is set in Cura and WAIT
;*** End preheating ***
M300 S1000 P500 ; BEEP heating done
G28 Z0 ;move Z to min endstops
M420 S1 ; Enable leveling
M420 Z5.0 ; Set leveling fading height to 5 mm
G1 Z15.0 F{speed_travel} ;move the platform down 15mm
G92 E0 ;zero the extruded length
G1 F200 E3 ;extrude 3mm of feed stock
G92 E0 ;zero the extruded length again
G1 F{speed_travel}
G0 Y20 F{speed_travel}
M900 K0.05
M117 Printing...
G5

 

Edited by bassamanator
  • Link to post
    Share on other sites

    Posted · [Solved] Printing Temperature Initial Layer not working
    1 hour ago, bassamanator said:

    I can't get the first layer to print at the specified temperature, 270C in this case.

     

    Different placeholders in the start script are required to achieve this.

     

    Try to replace:

     

    {material_bed_temperature}  ==> {material_bed_temperature_layer_0}

    {material_print_temperature} ==> {material_print_temperature_layer_0}

     

    or {material_print_temperature_layer_0, 0} if this is a printer with more than one extruder.

     

     

     

    • Like 1
    Link to post
    Share on other sites

    Posted · [Solved] Printing Temperature Initial Layer not working
    10 hours ago, tinkergnome said:

    Try to replace:

    {material_print_temperature} ==> {material_print_temperature_layer_0}

    What about the rest of the layers? How would I change the startup gcode so that it changes the temperature for layers 2 on wards to the default print temperature?

  • Link to post
    Share on other sites

    • bassamanator changed the title to [Solved] Printing Temperature Initial Layer not working

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
         
         
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
         
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
         
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.
         

         
        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 10 replies
      • UltiMaker Cura 5.3.0-Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
         
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 16 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...