Jump to content
UltiMaker Community of 3D Printing Experts

Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11


Recommended Posts

Posted · Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11

Now it's my turn to report that the upgrade to 5.2.18 and Cura 4.11 caused my UM 3E to fail. At my first attempted print, it complained about leveling not working properly. I restarted the same print and it printed without problem for perhaps 7 of the 10 hour gradual infill print. I was not present when the print failed with a filament volcano crater and the plate and extruder stuck at the failure point.


It could of course be HW fault but this printer has worked flawlessly for almost 4 years and failed directly after the wire internet FW upgrade. My impression is that booting 5.2.18 after the failure took a long time. I changed to the current testing FW wire internet download, which completed without error message. I then found the update file to 5.2.11 and applied it via USB without error message. It now boots in a more familiar fashion. I do not have screen garbling.


After browsing this forum, I realize that this is a long-standing problem, which means that I think I should try to find a known well-functioning FW version before wasting more time.


Am I correct to believe that 4.3.3 is the latest well-functioning FW version?


I didn't think to make a note of the FW version before going to 5.2.18, so my first step is to try to figure out what version I was upgrading from. If I remember correctly, my previous FW did a 3-point auto-leveling procedure. I don't recall it making the clicking sounds that it now makes during boot. Is this information enough for telling whether it was on FW version 4.x or 5.x?


In various threads in this forum I have found the USB update file for 5.2.11 and 5.2.18, and recovery image 4.3.3, 5.2.16 and 5.2.18. I was able to figure out the download link for the 5.2.16 update file from the 5.2.18 update and 5.2.16 recovery links. I am aware of the unofficial restoration procedure.


Is there a USB update file for 4.3.3? Could you please link to it?







  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11

    The USB updates before 5.1.8 had 2 files and are incompatible with newer firmware, if you do update then do be aware that resizing of partitions happens at some point making it a lot harder to downgrade.

    So here is the recovery image of 4.3.3  UM3_recovery-

    unbricking guide by gr5

    I've been using my UM3 with 5.2.x and now 5.3.0 firmware with no problems for quite a while but I hadn't installed the 5.2.18 until a few days ago; So I would consider it quite the downgrade, that said feel free to experiment.

    Edited by robinmdh
  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11

    Thank you Robin,


    Is it possible to receive the 5.3.0 USB update image by file as a private message? If I recover to 4.3.3 I will probably never dare to upgrade its FW again, so I might just as well give Ultimaker one final chance to get it right.

  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11

    Thank you again Robin,


    I'll fiddle with this the next few days and report back.


    Could you please check which FW release introduced the 4-point auto-leveling?




  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11

    Hi Robin,


    The print that previously failed now completes without problem using 5.2.30 USB install and Cura 4.11. I attach a photo of the failed print in case it gives you any input to what might have caused the problem. Below are the steps that led me to the current state:


    I was running on Windows 7 Pro, Cura 4.11.0 which had worked with Cura 4.10.0. In my download folder I also found 4.9.1, 4.8.0, 4.4.1, and 3.1.0.


    I had just upgraded the FW to 5.2.18 via LAN cable internet. I don't know which version it was on before this. I had no problems prior to this.


    On the PC I uninstalled all Cura and removed the obvious folders. Then I installed 4.10.0 and 4.11.0 (on my Win7 Pro).


    The UM3E FW was changed via LAN cable internet to whatever test version was also published at the time I reported the problem. From there I upgraded to 5.2.11 via USB. When starting the printer I was prompted to update to 5.2.30 on the screen, which I by mistake started off as a LAN cable internet update. I finally installed 5.2.30 via USB.


    This is the configuration that succeeded with the yet only print I have done after the problem.


    There is no indication of a hardware or filament feed issue. The printer makes no disturbing sounds that could relate to wear or damage. Where I live we hardly ever have electricity issues and nothing indicates there was one during the failed print.


    If we assume that problems with UM3E are not random, and judging by other posts, I would guess that somewhere along the line UM made some change in a particular Cura or FW version that they forgot to include in the dependency check. That would explain why some users are hit and not others. My hypothesis is that the upgrade version "steps" matter and the reason I provide details about my version history. But, that's just a wild guess.


    Best regards



  • Link to post
    Share on other sites

    Posted · Ultimaker 3 Extended problem after upgrade to 5.2.18 and Cura 4.11

    I forgot: I also did a factory reset and XY calibration after installing 5.2.30.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.3 stable released
        In this stable release, Cura 5.3 achieves yet another huge leap forward in 3D printing thanks to material interlocking! As well as introducing an expanded recommended print settings menu and lots of print quality improvements. Not to mention, a whole bunch of new printer profiles for non-UltiMaker printers!
          • Thanks
          • Like
        • 24 replies
      • Here it is. The new UltiMaker S7
        The UltiMaker S7 is built on the success of the UltiMaker S5 and its design decisions were heavily based on feedback from customers.
        So what’s new?
        The obvious change is the S7’s height. It now includes an integrated Air Manager. This filters the exhaust air of every print and also improves build temperature stability. To further enclose the build chamber the S7 only has one magnetically latched door.
        The build stack has also been completely redesigned. A PEI-coated flexible steel build plate makes a big difference to productivity. Not only do you not need tools to pop a printed part off. But we also don’t recommend using or adhesion structures for UltiMaker materials (except PC, because...it’s PC). Along with that, 4 pins and 25 magnets make it easy to replace the flex plate perfectly – even with one hand.
        The re-engineered print head has an inductive sensor which reduces noise when probing the build plate. This effectively makes it much harder to not achieve a perfect first layer, improving overall print success. We also reversed the front fan direction (fewer plastic hairs, less maintenance), made the print core door magnets stronger, and add a sensor that helps avoid flooding.

        The UltiMaker S7 also includes quality of life improvements:
        Reliable bed tilt compensation (no more thumbscrews) 2.4 and 5 GHz Wi-Fi A 1080p camera (mounted higher for a better view) Compatibility with 280+ Marketplace materials Compatibility with S5 project files (no reslicing needed) And a whole lot more  
        Curious to see the S7 in action?
        We’re hosting a free tech demo on February 7.
        It will be live and you can ask any questions to our CTO, Miguel Calvo.
        Register here for the Webinar
          • Like
        • 18 replies
      • UltiMaker Cura Alpha 🎄 Tree Support Spotlight 🎄
        Are you a fan of tree support, but dislike the removal process and the amount of filament it uses? Then we would like to invite you to try this special release of UltiMaker Cura. Brought to you by our special community contributor @thomasrahm
        We generated a special version of Cura 5.2 called 5.3.0 Alpha + Xmas. The only changes we introduced compared to UltiMaker Cura 5.2.1 are those which are needed for the new supports. So keep in mind, this is not a sneak peek for Cura 5.3 (there are some really cool new features coming up) but a spotlight release highlighting this new version of tree supports.  
          • Like
        • 22 replies
    • Create New...