Jump to content
Ultimaker Community of 3D Printing Experts

UM2 w/Duet2 Wifi Homing Issues


Recommended Posts

Posted · UM2 w/Duet2 Wifi Homing Issues

I've got homing issues for my Ultimaker 2 (with Duet 2 Wifi board). Here's what it does when I hit Home All in the dashboard:

  • Z axis homes first hitting the end switch (no issues there)
  • Next Y axis homes (hitting the switch, no issues)
  • Finally X axis, where it hits the end switch. From there I can hear the stepper motor grinding. Where the printer ultimately gets stuck.

Ideas for fixing my homing issues?

 

I've posted my config and homing files in the zip below. It's the holidays, so I'm casting a wide net to see if anyone online can help.

 

Note: I also think I read a while back in another thread (I can't recall where) that the homing order is supposed to be Y->X->Z. So if you know how to fix the order (mine is Z->Y->X), that would be really helpful.

config.zip

  • Link to post
    Share on other sites

    Posted · UM2 w/Duet2 Wifi Homing Issues
    • Just to be sure: these config files are for RRF 2.x or earlier - correct?
    • The homing order on Ultimaker printers is: z-axis first and x/y afterwards (simultaneously) - which seems to be the case
    • All endstops are configured as "active low" - which is correct (assuming RRF 2.x - the syntax of M574 is different for later versions)
    • The content of "homeall.g" seems to be correct (IMHO)
    • I think the current status of the endstops is to be seen on one of the duet web control pages (*) - you can check them manually one be one (trigger them by hand)
      (*) Settings -> Machine properties
    • My best guess is a problem with the cabling

    BTW: it seems you've mounted a Bondtech DDG feeder - good choice 🙂

     

  • Link to post
    Share on other sites

    Posted (edited) · UM2 w/Duet2 Wifi Homing Issues
    3 hours ago, tinkergnome said:
    • Just to be sure: these config files are for RRF 2.x or earlier - correct?
    • The homing order on Ultimaker printers is: z-axis first and x/y afterwards (simultaneously) - which seems to be the case
    • All endstops are configured as "active low" - which is correct (assuming RRF 2.x - the syntax of M574 is different for later versions)
    • The content of "homeall.g" seems to be correct (IMHO)
    • I think the current status of the endstops is to be seen on one of the duet web control pages (*) - you can check them manually one be one (trigger them by hand)
      (*) Settings -> Machine properties
    • My best guess is a problem with the cabling

    BTW: it seems you've mounted a Bondtech DDG feeder - good choice 🙂

     

    Thanks. ^.^ Yes, those files were franken-steined from older sys files I found online for Duet 3D to use for Ultimaker 2. Changing some of the values to suit my setup (like the extruder).

     

    I ended up researching different parts of the code in the config and homing files. While tinkering with the RRF config tool to try to match the values I saw in the code I saw in the frankensteined files. I ended up figuring out what needed changing in the end.

     

    I just got a clean homing sequence an hour ago with a new set of sys files. Free of grinding noises and quiet. Well, as quiet as any 3DP with silent steppers I suppose. I tested the individual axes to double check it. No issues, thank goodness. The order now is X & Y then Z for home all. Which works for me.

     

    I do appreciate the post. Thank you, and happy holidays! ^.^

    Edited by rad_spider
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...