Jump to content
Ultimaker Community of 3D Printing Experts

Cura's adding material that shouldn't exist


Recommended Posts

Posted · Cura's adding material that shouldn't exist

Hello, new here and have finally had it with this print. At layer 6 and 8 are where the problems are. Layer 8 generates 2 triangles a square and a rectangle out of the blue. I've tried re editing the file and this and that but it still adds those shapes. 

 

Second issue is with infill. I can't get any infill to show up in the hinges or in the lid with the latch piece. Last time I made something similar, infill worked and random shapes didn't pop up. Any help would be appreciated ty!

 

Using sketchup and cura 5.0

 

File and pic attatched.

cura.jpg

Box V2.stl Box V2.1.obj

  • Link to post
    Share on other sites

    Posted (edited) · Cura's adding material that shouldn't exist

    Matter of fact, I cannot get any infill to show up on any of my models now. That spiralize setting is off btw.

     

    Update.

     

    Got infill back when I went back to cura 4.13.0 although I'm still getting those shapes.

    CE3PRO_Box V2.1.3mf

    cura.jpg

    Edited by tokin247
  • Link to post
    Share on other sites

    Posted · Cura's adding material that shouldn't exist

    This is from MS 3D Builder and it is the "U" shaped hole in the middle wall.  You can see that something isn't right.  SketchUp is notorious for things like this.  You need to take a close look at your model to make sure the surfaces aren't flipped inside-out, and other errors.

    image.thumb.png.7f5f9f66100f6ca62012c66d32bbf1c1.png

     

    After repairing the file at an on-line service I get this...it's still wrong, but at least it's different.

    image.thumb.png.35d26abe7ec197e37ae06983f3222b04.png

     

    This needs to be fixed in SketchUp.

    The good news is that the Infill is there.  Are you sure you have "Infill" turned on in the linetype settings?  You can see it in the above image (but I use the sidebar GUI so my screen might be different).

  • Link to post
    Share on other sites

    Posted · Cura's adding material that shouldn't exist

    You are 100% right on this one. It was a problem in sketchup. Between the bottom layer and the bottom layer of the "compartments" was set to a gap of 1.5mm. I increased the gap to 1.55mm, exported again and bam it works, no more weird shapes. Also tried going shorter to 1mm and it worked normally again. I can't understand for the life of me why it's upset with 1.5 but hey.

     

    As for my problem with no infill. I've narrowed that down to version 5.0 of cura. Like I said I went back to version 4.13.0 and then infill works.

     

    What version of cura do you use? Also thank you for your help, I appreciate it!

     

    I added the fixed version if anyone wants.

    CE3PRO_Box V2.1.obj

  • Link to post
    Share on other sites

    Posted (edited) · Cura's adding material that shouldn't exist

    I moved to 5.0.  I wasn't much of a fan of the Arachne beta's but the full implementation of the variable line width in 5.0 is much better.  The dialog boxes and controls are funky though.  If it's because of simple unfamiliarity of the developers with QT6 then that problem will go away.  It may be that QT6 just isn't complete enough (or something) to allow controls as most people are used to.

     

    If you open one of those "no infill" gcode files in a text editor like Notepad and search for TYPE:FILL does it find the sections of the infill code or is it missing from the gcode file as well.

     

    This is your new model is MS 3D Builder.  That "U" shaped hole still has issues.  There are extra "infinitely thin" surfaces that intrude across the hole.  Because the triangles that make up those error surfaces extend to the floor I still get the extra material on the floor as well.  

    image.thumb.png.b802ccb82432b313b775b47b089fc37c.png

     

    The 3mf file below has a model that I cleaned up (Me_box) in MS 3D Builder, and your model.  Look at the differences in the Prepare screen both in regular view and in X-Ray view and then slice and inspect the preview.

     

    GV_repair_BoxV2.1.3mf

    Edited by GregValiant
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 12 replies
    ×
    ×
    • Create New...