Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Pause at Layer Height Mutiny

Context: Sovol SV04 printer 

 

https://sovol3d.com/products/sv04

 

I am trying to embed a magnet in a 3d print,

 

So logically, I use the "pause at print height" (pause at layer height specifically) 


I run the print, (this is the mutiny part) it pauses, I embed the magnets, then NOTHING. I don't have an option to resume print. (after reading thru forums) I decide to turn of the printer, and as it restarts it resumes the print, yet it starts printing 5 mm above the print. Basically, its just extruding on thin air above the print (guessing during the shut down the steppers lost their position) 

 

I then immerse myself in forums learning g code, and searching for a solution.

 

I  found a post from Greg Valiant (this guys a god)  mentioning a glitch where certain circuit boards don't read the following commands; M117, M1, and M0. The best way to test this is add a M117 command to the gcode and see what happens. 

 

So I did the M117, and nothing, it didn't read the command. I'm guessing I have one of those glitchy boards.

 

I done my due diligence and tried other potential fixes. 

 

Using other Gcode commands, and combinations of Gcode. 

 

M0

M25

M226(RepRap)

M601(RepRap)

 

Even trying the change filament command. Redo Layer, and Don't Redo layer. Stepper times. 

 

Yet nothing, they all fail to effectively pause.

 

I am at a loss. Does anyone have any advice on how to do this?

 

I have read some people will create their own custom stop print Gcode, and start print gcode. They will take the gcode, and split it at the desired layer into 2 separate g codes. So that the print will "finish" at a certain layer, you embed your magnets and then you just start "another" print, at a specified z elevation. Which effectively will "pause" a print to embed magnets, then "resume" it? Does anyone know how to do this? Would this disable the steppers in between prints?

 

Or any other ideas on how to fix this?

 

 

  • Link to post
    Share on other sites

    Posted (edited) · Pause at Layer Height Mutiny

    We just went through this with an Ender 3 Pro that had the problem.  A workaround seems to have gotten the job done.  It is described in THIS THREAD .

     

    NOTE:  When using the M25 command it's possible that you might have to "Pause" the print on the LCD (even though the printer is in pause mode) in order to bring up the "Resume" command. 

    So that sequence would be...

    The file is printing and comes to the pause section.  It parks the head and the M25 causes the printer to pause.

    You put the magnet in.

    On the LCD find the menu with the "pause" command and click on "Pause" and then move to the Resume command and click on it.

    The G4 method always works but you lose control of the printer because G4 is a timed event.  You don't get to choose when the printer restarts.

     

    Edited by GregValiant
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 13 replies
    ×
    ×
    • Create New...