Jump to content

Change speed at Z not working


ender3max

Recommended Posts

Posted · Change speed at Z not working

I want to print my model at 100 mm/s from the 67th layer to the 178th layer, and print the rest at the model at 50mm/s. I have created two scripts to increase and decrease the speeds using the Change at Z Plugin. But when I look at the speed colour scheme there I see there is no change to the speed. Do you know what is causing this and how can I fix it?

image.png

image (1).png

image (2).png

  • Link to post
    Share on other sites

    Posted · Change speed at Z not working

    The top of that model isn't very big so you might be bouncing up against the "Minimum Layer Time".  The default is 10 seconds but if you lower it too much you won't get sufficient cooling and the top of the model may suffer deformation.

     

    I recall that "ChangeAtZ" did not play well with Z-Hops enabled.  The Z moving up and down confused it.  If you have enabled Z-hop turn it off and see if it makes a difference.

     

    If you open the Gcode file in a text editor you will see "F" numbers in some of the lines.  They indicate the feedrate in mm/minute.  50mm/sec would be F3000 and 100mm/sec would be F6000.  If you look around layer 150 you may see numbers like F2476 or something else that wasn't one of your settings.  That would indicate that Cura made an adjustment to slow the layer down so it would take longer than the "Minimum Layer Time".

    • Like 1
    Link to post
    Share on other sites

    Posted · Change speed at Z not working

    Thank you for the reply. The gcode just uses F3000, so I don't think minimum layer time is interfering, and I don't use z hop so that can't be the problem either. Is there another way to do what I want as change at z has some issues for me?

  • Link to post
    Share on other sites

    Posted · Change speed at Z not working

    The Gcode postprocessing is not performed until you save the gcode, so it is not showing on the preview tab.

     

    The plugin does not affect all the F-values in the gcode after the change, but inserts a single M220 gcode command to instruct the printer to "multiply" the F-values internally:

    https://marlinfw.org/docs/gcode/M220.html

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...