Jump to content
UltiMaker Community of 3D Printing Experts

Prime Tower/Ooze Shield issue Cura5.2.1


madurani
 Share

Go to solution Solved by madurani,

Recommended Posts

Posted (edited) · Prime Tower/Ooze Shield issue Cura5.2.1

Hello All,

 

I have printer with 4-IN-1-OUT Mixing Color hotend and use a Cura slider tool. Problem appear when I use mode "Dual extrusion". 

Prime tower still use extruder 1 on printing first layer of tower although isn't use in model. I don't know find in cura slicer any setting for it(a managing of which extruders will be use in firs layer).

 For example: I want print model where are use only extruder 3(white) and 4(blue). Cura begin build tower with extruder 1(black) and continue with using extruder 1 in some shield around tower and in Ooze Shield around model. Where is posible disable this strange behavior of cura?

 

The first extruder shouldn't be used, because this color isn't in model.

 

image.thumb.png.0adb43bc2b4b017f24f0b4973df48635.png

 

First layer:

image.thumb.png.a111d7865717bd52a0f26c24fc2cf18b.png

 

Edited by madurani
  • Link to post
    Share on other sites

    • madurani changed the title to Prime Tower/Ooze Shield issue Cura5.2.1
    Posted · Prime Tower/Ooze Shield issue Cura5.2.1

    Very temporary solution in my case when I want only disable/replace extruder1 with extruder3 was modify gcode
    output file from Cura. I replaced it with sed command  extruder1(T0) with extruder3(T2) and were fixed:

     

    grep T0 CFFFP_color2.gcode|wc -l 
    6
    
    sed -i 's/T0/T2/g' CFFFP_color2_sed.gcode
    grep T0 CFFFP_color2.gcode|wc -l
    0

    When I print file via OctoPrint

  • Link to post
    Share on other sites

    Posted (edited) · Prime Tower/Ooze Shield issue Cura5.2.1

    I responded on Github and I'll rehash it here.

    This looks like a bug to me as it doesn't matter if T0 is disabled or unused.  When the Prime Tower is enabled Cura switches to T0.  With the Prime Tower disabled it seems to work as it should with no references to T0.

     

    I see you have a workaround.  The same thing can be done within Cura using Search and Replace post-processor:
    Search = T0\n
    Replace = T3\n
    Use regular expressions = checked

    The "\n" is a newline character and they are required as shown.

     

    Whether it's done in Cura or Octoprint - it's a poor workaround as the movement code at the Prime Tower is still there and it isn't needed (or wanted).

    Edited by GregValiant
  • Link to post
    Share on other sites

    • 2 weeks later...
    • Solution
    Posted (edited) · Prime Tower/Ooze Shield issue Cura5.2.1

    I switched from Cura to Prusa Slicer😃, there aren't any problems with tower and multi color printing. 

    Edited by madurani
  • Link to post
    Share on other sites

    Posted · Prime Tower/Ooze Shield issue Cura5.2.1

    I've been fooling around with Dual extrusion and the problem definitely exists.  If I start with extruder 1 there are 5 tool changes.  If I start with extruder 2 there are 68 tool changes.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 14 replies
    ×
    ×
    • Create New...