Jump to content

Cura 5.2.1 - strange last layer

Go to solution Solved by GregValiant,

Recommended Posts

Posted (edited) · Cura 5.2.1 - strange last layer

After slicing a rather simple object, I am surprised to see a few discontinuities in the top layer (see snapshot 1).
The last but one layer is normal (snapshot 2).


Maybe the printing will be fine, but I am curious to know what causes this anomaly and possibily which Cura option (or other tool) I could use to solve this.


Note: I also see a few small gaps in the internal face; seen the location they might be linked with inaccurate fusion of objects in MS-Windows 3D builder. (snapshot 3)
Fortunately, these are probably too small to affect the printing.


Thank you in advance for your advices.

snapshot 1.gif

snapshot 2.gif

snapshot 3.gif

Boucle fermée v1.stl

Edited by Flying_Roger
add stl model
  • Link to post
    Share on other sites

    Posted (edited) · Cura 5.2.1 - strange last layer

    The model isn't as simple as you believe.  The top of the model isn't flat.  In addition, there are steps on the sides and the model has errors.

    This is a view in MS 3D Builder.  You can see a step in the top surface (and it isn't the only one).

    At 0.02mm it isn't much, but depending on your combination of Layer Height + Initial Layer Height, Cura can notice.




    The model on the right is yours.  The model on the left has been altered to be 6mm tall with a flat top.



    So alter the model to make it correct or just change the Initial Layer Height until the anomalies disappear.



    Before clearing the build plate I decided to flip this over and check the bottom.  Here is the slice with the model "upside down".  The bottom isn't flat either.



    Edited by GregValiant
  • Link to post
    Share on other sites

    • 2 weeks later...
    Posted (edited) · Cura 5.2.1 - strange last layer

    Thank you very much for your help and sorry for late reply. I missed your message.
    Indeed, when zooming very deeply in MS-3Dbuilder, I can see the tiny step.
    This anomaly probably appeared due to fusionning several objects with too approximate positioning.
    Usually, I get rid of such steps by slicing, but maybe I missed this one.
    I sliced very close to the top and bottom and the problem is indeed solved.
    Note that it had no impact at all on the printed object, probably because the step was smaller than the 0.2mm layer printing.
    Here is my new STL file. It still triggers an error message when loading in MS-3Dbuilder, but this happens very often, even if I let this program fix the problem and save again the model in STL format without doing anything else.

    Small holes are still visible in the CURA 5.2.1 preview.
    They seem to be spurious and not actually impacting the 3D printing.
    I tried different apps (meshmixer, meshlab,...) "fix small holes" actions, but to no avail.
    Zooming deeply, I can see that this is also linked so a tiny surface anomaly (fusion unaccuracy).
    I wonder how to fix that. Maybe using Blender?

    sanpshot 4.gif

    Boucle fermée v4 (recoupé pour lisser les faces).stl

    Edited by Flying_Roger
  • Link to post
    Share on other sites

    Posted · Cura 5.2.1 - strange last layer

    They are in the model in Fusion.  I think it's the way you modeled it.



    This is the plan view in Cura (in X-Ray).  You can see steps in the part in my red circles.  When Cura slices this it sees those steps and the toolpath is adjusted.  Cura will print the model you have so the model needs to be correct.

    I have Fusion but I haven't spent much time with it.  In Inventor the lines of different sketches can be constrained to one another or "0.00" dimensions entered to insure that line ends meet.  In the case of these line ends it looks like they could have been made tangent to the arcs.  That would have worked as well.


    In regards to the radius, if the use of the part dictates that the two radii are different and not concentric then that's fine, but you can see that the cross section is thicker in the middle of the arcs than it is at either end.  That can cause Cura to add infill when you were expecting walls all around.  You can also see that the different radii cause the line ends to be staggered rather than right opposite of one another.

  • Link to post
    Share on other sites

    Posted (edited) · Cura 5.2.1 - strange last layer

    Actually, I do not use the "Fusion" applications, I installed it initially, but found it too heavy for my usage. I simply use the "fusion" function in MS-3D builder. "Inventor" is a commercial app, not suitable for my small (personal) prints...

    I need indeed to improve the accuracy when joining simple geometric elements to build a model.
    The problem is when I have to rotate some elements to build a more complex shape.
    I know that I should rather use tools like blender in such case, but it takes ages before really mastering this complex and not so intuitive tool. I dream of a tool capable, in a few clicks, of solidifying a model and simplifying the mesh without altering the shape.

    Though, it is hard for me to understand why the model has small holdes after several elements have been fusionned.
    I had expected that a small step would not result in such gaps, but this could be a MS-3D builder issue.

    Note that when it is just a single "pixel" missing, it has no impact on the printing, but I fear that problems can arise when a series of small gaps are aligned, assuming that these gaps are really modelled by Cura in the gcode file. I will investigate my gcode files using other applications to make sure that the problem is not simply a "Cura preview" issue, with no impact on the gcode. I noted indeed that the Cura addon checking the mesh says "model is watertight" despite these gaps.

    UPDATE: I see in the gcode as well as by replaying slowly in the Cura preview that the white squares are a way for Cura to mark the point where the extruder jumps from one location to another. So there is probably no gap there. Could you please confirm that?


    Edited by Flying_Roger
  • Link to post
    Share on other sites

    • Solution
    Posted · Cura 5.2.1 - strange last layer

    The white spots do indeed mark the beginning of extrusions.  It is the location of the Z seam of an outer surface.


    The operation of removing part of one mesh by using a second mesh as a tool is a "Subtraction".

    The merging of one mesh to another mesh is a "Union".

    Putting two meshes together and only keeping the overlap between them is an "Intersection".

    Together, the Intersection, Union, and Subtraction are often called "Boolean" operations.

    I mention that so we are talking apples and apples.  When you mentioned "Fusion" I thought you meant the software app.


    I have found that precisely locating pieces in MS 3D Builder is not easy as the program locates the center point of any shape (the Center of Geometry) rather than an edge.  Paper sketches of a model showing each step in the process from the start to the finish can help you visualize what needs to be done rather than having to "undo" about 500 times to get the model the way you want it.  That's what needs to be done in order to get points to line up correctly.  Computers are stupid but they are also very precise and very literal.  When developing a model you need to "match the precision precisely".

    Any application (Cura, Excel, Word, SketchUp, Blender, Fusion 360, etc.) is going to have a learning curve.  In the end I think learning one of the CAD packages will give you skills that you can use to create models that are precise and that print well.


    I've written macros in Excel and AutoCad that are tools I use to analyze gcode files.  Reading a Gcode into AutoCad and drawing each move has proven very helpful in chasing down reported bugs in Cura.  The Excel macros can determine things like flow rates and actual line width, the number of retractions in a file, and some other things that would be impossibly tedious to verify without the software to do the job.  All of that was another learning curve.

  • Link to post
    Share on other sites

    Posted · Cura 5.2.1 - strange last layer

    Thank you very much for your support.
    Using Excel macros to analyse the gcode is a good idea.
    I use Excel VBA for many applications, as well professional as private and this is a very powerful tool.

    Concerning the famous "gaps", it was indeed just a misunderstanding of mine: the white squares are just there as a "flag" to identify extruder position jumps and do not mean that there will be a tiny hole in the model.

    For sure I need to invest more time in one of these tools, probably blender.
    There are many tutorials, but not so easy to follow: either they rely on some previous knowledge that I have missed, or the screen resolution is too low to properly follow menu actions, or they use an old version of blender or another language.
    For me, the major element hampering my progress is the lack of a simple way to move the view using the mouse, like in Cura, rather than acting on the small XYZ handles. Of course I will eventually get used to it... 

    Merry Christmas and happy new year !

  • Link to post
    Share on other sites

    Posted · Cura 5.2.1 - strange last layer

    AS one VBA guy to another (we have to stick together among all these Python folks!) here is an app I wrote.  This is the full monte with random things I thought would be handy.

    It talks to the printer through the USB port but prints from the SD card in the printer.  There are some instructions (such as they are) and a readme file.  The app isn't signed as that costs money so if you decide to install it you will likely have to fool your anti-virus into allowing the install.  There will be a desktop shortcut to run it and an un-install app.

    You may recognize what I've done as controlling the printer is just short snippets of gcode that are nothing more than macros.


    Merry Christmas and Happy New Year to you and yours.


    Greg's Toolbox

    • Like 1
    Link to post
    Share on other sites

    Posted · Cura 5.2.1 - strange last layer

    Thanks Greg, I will look with interest into your Toolbox.

    Concerning Blender, I had the idea to return to the basic and follow a text tutorial rather than a video.
    This allowed me to find out that the panning/rotating problems that I had (since the start) in Blender were due to sporadic problems with my middle mouse button. Simply ticking "emulate middle mouse button" to use Alt-LMB instead solved the problem. Strangely after I did that, my middle mouse button started to work as well.

    Cf. "VBA vs Python": although I have much more experience with VBA, I started using Python a couple of years ago. It has big advantages for some (non 3D) applications, like using an xml database. I need this to process aeronautic data (updated every 28 days) and the availability of libraries helps a lot to avoid constantly reinventing basic functions.
    But I notice that you also use .py elements in your toolbox... 😉

  • Link to post
    Share on other sites

    Posted · Cura 5.2.1 - strange last layer

    What I don't know about Python fills libraries BUT Cura is highly customizable so I bothered to learn a smattering.  I've made some changes to the Pause at Height post-processor (they may make it into Cura), and I've included my version of that.  The other script was written by another developer.  Because he included a "fudge factor" for the time-to-print I've found it to be very handy because it provides and accurate time estimate.  I did add the M118 line to that so the printer bounces the message back to the Printer Response window in the Toolbox.


    When you come across them, my post-processors are all in VB.  They open a gcode file, read it and analyze it on the fly, and write it into a new file with the changes.

    I'm particularly proud of "Add a Cooling Profile" although I must admit I stole the idea for it from the "IdeaMaker" slicer.  A cooling profile comes in really handy when printing PETG as the fan can be controlled during the print either by-layer, or by line-type (Wall-Outer, Support, Skin,etc.).  Some of the post-processors are more of the "I wonder if I can do that" variety and are actually pretty useless.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • 🎄✨ Thingiverse Tree Ornament Challenge! ✨🎄
        We've been running a Tree Ornament Challenge with a chance to win an UltiMaker S3 or colorFabb filament.
        Design a 3D printable tree ornament and join our festive challenge on Thingiverse. 🎁✨

        📆 Submission Deadline: December 22
        🏷️Tag your designs with Holidays2023

        Click here to join and check out the over 300 other amazing designs

        How to Enter
        Design an Ornament
        Create a 3D printable tree ornament that captures the magic of the winter season. Think snowflakes, sleighs, reindeer, cozy mittens, or anything that embodies the joy of the holidays. Upload to Thingiverse
        Share your masterpiece on Thingiverse and add the tag Holidays2023. Don't forget to include a captivating description and images that showcase your design from different angles. Submit by December 22
        All entries must be submitted by December 22nd to be eligible for consideration.
          Entering a new design
        Entering an existing design
        Winning designs should:
        Be original Creations
        Your designs should be original works, avoiding the use of others' intellectual property without permission. Include STL Files
        Each submission must include at least one STL file for 3D printing. Showcase a Completed Print
        Provide at least one photograph featuring a completed print of your design. Include Documentation
        Share the creative journey! Include documentation of your design process, giving us a peek behind the scenes. For example, show a screenshot of the model in your design program. Use the Tag Holidays2023.
        Use this tag to ensure your entry is counted in the Tree Ornament Challenge. Be submitted after October 1st, 2023
        Ensure your design was uploaded to Thingiverse after October 1st, 2023. Adhere to Submission Guidelines and Terms of Service
        Make sure your submission aligns with our guidelines and Thingiverse's Terms of Service.  
        Good luck 🎉
        • 1 reply
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 13 replies
    • Create New...