Jump to content

S5 doesn't return the printhead to the home-position after loading or unloading material


glx

Recommended Posts

Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

Hello,

I noticed that my S5 isn't returning the printhead to its home-position after loading or unloading materials (on the Material 1, I haven't tested the Material 2). It homes the printhead, then moves to the nozzle-switch and stays there instead of homing again and stay in the home-position in the left corner.

This happened with the 8.1.1 as well with the most recent 8.1.2 firmware, to be honest I'm not sure when exactly that behaviour started, since I haven't used my printer that often recently. 

IMG_2980(1).png

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    Hi @glx,

     

    It is a bit difficult to troubleshoot this without the log files. Could you please share the log files from when this happened? You can find how to export the logs files here.

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    @Josnoww

    Yes of course, I just did an material unload, a load and a material change, it happens every time. The exported log is attached below. I did an export every time but only uploaded the latest one, if you need the other ones too, I can also upload these.

    logs-ultimakersystem-0030d6245741-8.1.2-20230314145548.zip

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    Hi, I have exactly the same problem with an Ultimaker S5 R1. The printhead does not corretly move to home after loading material 1 since firmware 8.1.0 and needs to be returned to home manually by the service menu.

    Moreover the LED of Printcore 2 is not working since the update to version 8.x.x (not blue when cold and not organge when hot, LED2 is always off - it could also be defect, but is exactly the since the update to version 8.1.0 - in the photo from glx this could also be the case, because LED2 seems to be off).

     

    In addition to the removal of really essential features (see other topics), there unfortunately seem to be several bugs in firmware 8. This is very disappointing, since the last firmware 7 (7.1.3) was working fine. I haven't had time to downgrade yet and still hope for an improved firmware 8 without those errors and recalled features.

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    @mscho, yeah one LED is off, but I have only printed with one material loaded since I updated to 8.x.x, so I didn't think much about it. The LED is also solid green after the material is loaded (instead of the usual blue-ish), they did change something on the LEDs tho (I did read it here: What do the different light colors mean on print cores? (makerbot.com) the note below says it can be different, so I guess something was changed here).

     

    I think you cannot downgrade (at least not easily) after upgrading to an 8-version, that was mentioned in a release note of one of the updates.

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    yes, i cannot follow what this new firmware is doing, the lights are now just green, the second extruder has no lights even when its hot from the bed probing. The head parks on the right now after loading material, but on the left overwise.

    Doesn't seem like these are intended changes ??

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material
    On 3/20/2023 at 4:47 AM, Link said:

    yes, i cannot follow what this new firmware is doing, the lights are now just green, the second extruder has no lights even when its hot from the bed probing. The head parks on the right now after loading material, but on the left overwise.

    Doesn't seem like these are intended changes ??

    I have this same problem since the last update. Any fixes?!?

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    Could we get an update -  if this is expected behaviour or a bug ?, If so why does the print head only light up green and the second not light up at all. Also why is she head parked on the right now ??

  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    @Josnoww did you already investigate that issue and can you probably provide any news or timeline?

  • Link to post
    Share on other sites

    Posted (edited) · S5 doesn't return the printhead to the home-position after loading or unloading material

    The end position of the printhead after filament loading has changed as an unintended side effect of another change. Although different, it's completely harmless, so I don't think it will be updated any time soon. 

    Same goes for the leds in the printhead.

    Issues are noted on our backlog.

    Edited by tomnagel
  • Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    I did just downgrade the firmware to the latest version of the 'stable' release channel (8.1.1) and the same issue (minus the LEDs, they seem to work correctly). 

     

    While I can understand your point of view that it is not a functional issue, I cannot understand how an issue like that could be pushed into the 'Stable' release channel which states: 

    Quote
    The Stable channel has a slower release cadence. All features and improvements included in Stable releases will be thoroughly tested not only by Ultimaker, but field-tested on the Latest channel for at least 3 months. 

    Firmware update channels: Stable vs Latest (makerbot.com)

     

    Someone in the testing department must have noticed that (or didn't test it as thoroughly as stated). 

     

    Don't get me wrong, errors can happen, no problem, maybe this can be used to improve the quality testing process. But on the other hand this is not an Ender 3 where I'd expect 'oopsies' like that to happen and no one will fix it anytime soon. The S5 is a quite expensive machine where I don't expect things like that to happen, especially on a tested stable firmware.. 

    • Like 1
    Link to post
    Share on other sites

    Posted · S5 doesn't return the printhead to the home-position after loading or unloading material

    It has been noticed, and it has a very low priority to fix. Because it is not a problem. It is just different. 
     

  • Link to post
    Share on other sites

    Posted (edited) · S5 doesn't return the printhead to the home-position after loading or unloading material

    i will switch to the stable channel to get the LEDs back working

    Edited by Link
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 26 replies
    ×
    ×
    • Create New...