Jump to content

"Pause at height" not resuming at the correct height (on Ultimaker S5)


PizzaTijd

Recommended Posts

Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

Hi all,

 

I have quick question regarding the 'Pause at height' feature.

I want to use this to embed nuts and other hardware in prints- and am having mixed results.

The pausing actually works on the correct layer, and I can successfully embed things in the print- but when I resume the print the print bed does not go back up to the correct height.

Its a couple centimeters short of where it should be - meaning that its dumping material mid-air.


In the past I could fix this by adding the maximum 'disarm' timeout of 1800s and babysitting the print to make sure I embed the parts fast enough. While babysitting a printer is sub-optimal, it was functional.

Somewhere between 5.0.0 and 5.3.0 this feature seemingly got removed (at least on the Griffin method, which is what the S5 uses).

 

Is there any way to make sure that none of the moving printer parts lose their position now?
(Cura 5.3.0 and 5.0.0 / Ultimaker S5 @ 8.1.2.0)

 

Any help/advice would be appreciated!
Thanks.

 

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    I would quickly like to add that even after reinstalling 5.0.0 the printer just seems to lose track of the bed height when using pause at height, rendering it impossible to use this function the way I use it now.

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    I don't know a lot about this issue but it was discussed recently.  I would get rid of the "disarm steppers" timeout.  Or set it to zero.  If it's zero then it should be disabled according to documentation.  I have never tried this.  Even better, just remove that gcode from the "pause at" plugin.  I think this disarm feature was added recently by someone without an Ultimaker printer.

     

    More info here: https://github.com/Ultimaker/Cura/issues/15004#issuecomment-1508792641

     

    I don't know but I suspect the issue for you appeared with an update to the pause at plugin and is unrelated to the version of firmware or the version of Cura.

    • Like 1
    Link to post
    Share on other sites

    Posted (edited) · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    Yes, that does sound like what I am experiencing. With regards to how the issue appeared- I have not manually updated anything, and I only use things that come with Cura itself. If Cura auto-updates these bundled post-processing options without prompting the user then it is possible.

     

    Edit: Since this disarm option was gone in 5.3.0, would you have any advice on how to add a functional pause at height to my prints?

    Edited by PizzaTijd
  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    For an S5 it uses the ufp format.  Rename it to zip and open that - there is a file in one of the folders that ends in "gcode".  Edit that file.  It's pretty easy to read.  You can search by "layer" although in the gcode file it starts with layer 0 I think so you may be off by one.  You can also search for the letter Z which after the first few should only appear once per layer (unless you have z hop enabled).  Even better if you used the plugin search for "M84" to find the inserted code.

     

    Look at the code that was inserted by "pause at".  Get rid of the M84.  I don't think it's needed.  I'd do a test print first.  Check to make sure the servos are enabled by pushing the bed up and down and it shouldn't move.

     

    When done, rename zip back to ufp.

     

    In windows you probably have to extract the gcode file, then edit it on your hard drive, then put it back into the archive.

     

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    I believe the plugin mentions this:

     

    Quote

    Set this to 0 if you don't want to set any duration.

     

    But I believe setting it to zero means the servos never turn off.  Did you try zero?

     

    The max value you can use is probably either 32767 or 16383.  16383 gives you 4.5 hours so you don't have to sit next to the machine the whole time.

     

     

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)
    15 hours ago, gr5 said:

    But I believe setting it to zero means the servos never turn off.  Did you try zero?

     

     

     

    I'll try it out as soon as I can. Personally I interpreted it as "if you fill in 0 they'll disengage immediately", so hopefully I was wrong on that. Thanks.

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    If that doesn't work, please try 5.3.1, we fixed this problem (hopefully for good) in the patch. Disarm-timeout is back too -- it was disabled as it was mutually exclusive with an option to hold steppers on, that was properly hidden for 'griffin' flavour printers, that should not use it -- but then also enabled by default.

     

    You should already be able to download that one from Release UltiMaker Cura 5.3.1 · Ultimaker/Cura (github.com). (We're delaying the pop-up message/announce a bit, to give marketing time to adjust the 'official' website, which has become harder than in the past for some reason.)

    • Like 2
    Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)
    2 hours ago, rburema said:

    If that doesn't work, please try 5.3.1, we fixed this problem (hopefully for good) in the patch. Disarm-timeout is back too -- it was disabled as it was mutually exclusive with an option to hold steppers on, that was properly hidden for 'griffin' flavour printers, that should not use it -- but then also enabled by default.

     

    You should already be able to download that one from Release UltiMaker Cura 5.3.1 · Ultimaker/Cura (github.com). (We're delaying the pop-up message/announce a bit, to give marketing time to adjust the 'official' website, which has become harder than in the past for some reason.)

    Sounds very promising! Thank you for letting me know.

    I'll put a print in the queue and let you know how it goes.

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)
    9 hours ago, PizzaTijd said:

    Personally I interpreted it as "if you fill in 0 they'll disengage immediately",

    Me too!!!  but if you read the actual Marlin reprap documentation for M84 it says that using "0" disables the timeout feature which is what you want.  It's like infinite timeout. 

     

    Ultimaker uses Marlin but it's a fork where they might have messed with M84 but very unlikely since as far as I can tell M84 is never used normally and probably outside the radar of the developers.

  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)
    On 4/20/2023 at 9:12 AM, rburema said:

    If that doesn't work, please try 5.3.1, we fixed this problem (hopefully for good) in the patch. Disarm-timeout is back too -- it was disabled as it was mutually exclusive with an option to hold steppers on, that was properly hidden for 'griffin' flavour printers, that should not use it -- but then also enabled by default.

     

    You should already be able to download that one from Release UltiMaker Cura 5.3.1 · Ultimaker/Cura (github.com). (We're delaying the pop-up message/announce a bit, to give marketing time to adjust the 'official' website, which has become harder than in the past for some reason.)

    Good news; the one print I have completed so far went with 0 issues on 5.3.1.

    Still only a sample size of 1, but I'll keep my eyes on it for the next couple prints that use pause on height.
    Thanks!

    • Like 1
    • Heart 2
    Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    Did you set it to "zero" or was the option gone?

  • Link to post
    Share on other sites

    Posted (edited) · "Pause at height" not resuming at the correct height (on Ultimaker S5)

    The option has returned in 5.3.1, and I kept it at the default (0) on that last print.

    On 5.3.0 the option was gone, so I'm not sure what it was set on by default then.

     

    Edit: I would like to add that the text for the disarm timeout does clearly say the following:
    "After this time steppers are going to disarm (meaning that they can easily lose their positions). Set this to 0 if you don't want to set any duration and disarm immediately"

    Edited by PizzaTijd
  • Link to post
    Share on other sites

    Posted · "Pause at height" not resuming at the correct height (on Ultimaker S5)
    On 5/1/2023 at 3:49 AM, PizzaTijd said:

    and disarm immediately"

    Okay well I think that text is wrong.  Maybe it's old - I looked in the github on April 20 and I think the text was different when I looked.  It might be I was looking at the *next* version that isn't out yet.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
         
          • Like
        • 16 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    ×
    ×
    • Create New...