Jump to content

Pause at layer - problems

Go to solution Solved by GregValiant,

Recommended Posts

Posted (edited) · Pause at layer - problems

Good morning,


I'm doing several tests with filament change, but I have the same problem every time, I'm using the "Pause al layer Height" funcion in Cura, indicating the layer number. Once the print is paused (using M25, as I had several issues with M0), I change the filament, However, when I resume the print, it starts from a much higher Z coordinate (about 20mm above the piece). Can you help me? I'm using Ultimaker Cura 5.3.1 and an Ender 3 V2 NEO printer



Filament change test_pauseV2.gcode

Edited by Bertaz31
  • Link to post
    Share on other sites

    • Solution
    Posted · Pause at layer - problems

    THIS POST has some background on what is going on.  The problem (besides M0 not working) would appear to be that the way M25 is configured in your firmware causes it to blow through the Z moves that should return the nozzle to the working height.  Not a problem when the Pause is above 15mm, but a problem when the Pause occurs at a low layer.

    You can try this in the PauseAtHeight settings:

    In the "Gcode Before Pause" box enter:  M400

    In the "Gcode After Pause" box enter:  M117,M117,M117,M117,M117,M117,M117

    The commas in the M117 line should split up the commands so they each end up on their own lines in the gcode.  The M117 commands don't do anything but take up space BUT they push the Z move lines down in the gcode so they get acted on instead of stepped over.

    It's worth a test anyway.


    • Like 1
    Link to post
    Share on other sites

    Posted · Pause at layer - problems

    Still the same problem. At about 10mm I inser a magnet in the piece and resume, but it resumes about 40mm higher

    The Gcode seems correct, with the last mod we added


    M25 ; Do the actual pause


    Maybe i should try the workaround with "search and replace" as you suggested in the post you linked above..

    Tomorrow i will try and see what happens! thanks!!



    Search and Replace

    - Search = M25

    - Replace = M25\nG91\nG1 Z5\nG90\nG1 X0 Y0 F6000\nM117\nM117\nM117\nM117\nM117\nM117


    The "G1 X0 Y0 Z15" portion should be the same X and Y that you park the print head at.  The "\n" (backslash + n) is the newline character.  The M117's will pad the printer/planner buffer with commands that don't do anything.  Six of them should be sufficient but you might need a couple more as it is dependent on your mainboard buffer memory.



  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.4 stable released
        The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
          • Like
        • 58 replies
    • Create New...