Jump to content

I'm incredibly frustrated with Cura. Can someone please help?

Recommended Posts

Posted (edited) · I'm incredibly frustrated with Cura. Can someone please help?

Cura on my PC straight up freezes and becomes unresponsive upon clicking Save to Disk. Doesn't matter how simple the model, the settings etc. Same result. Have uninstalled and reinstalled, but it appears to have kept all the config info. Can someone tell me how to wipe EVERYTHING from Cura off my PC?

In the mean time, I tried using my laptop, so I freshly installed Cura and logged in, however, I'm getting "plugins failed to download". I have blazing fast internet, so what's the issue. How can I manually add a Z Offset without the plugin?

Why did all of this start this morning? I didnt update ANYTHING, and Cura was working fine for weeks all the way up to last night!

Edited by calebdollar
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.4 stable released
        The full stable release of UltiMaker Cura 5.4 is here and it makes it easier than ever to remove brims and supports from your finished prints. UltiMaker S series users can also look forward to print profiles for our newest UltiMaker PET CF composite material!
          • Like
        • 58 replies
    • Create New...