Jump to content

Ultimaker 2+ randomly restart mid print


Recommended Posts

Posted · Ultimaker 2+ randomly restart mid print

Hello to you all,


I have an Ultimaker 2+ that I bought in 2017 brand new. During all this time it has worked perfectly, considering the intensive printing sessions it has been subjected to. A year ago, I started to print less with it, with some breaks of a few weeks in between, but I always tried to print regularly, even if it was just a few small things, so that it wouldn't stand still for too long.


The problem started this summer. I started to print some small warpaints racks and the prints started to stop randomly at different points of the print, usually always at the end of the first layer or the 2nd layer.


Since then I have tried everything. Obviously, my first thought was that it was a problem with the power supply or plug. So I got a new power supply that I borrowed for testing and changed the printer's plug and electrical phase. It was still shutting down.


After that I factory reset the printer, updated Cura and tried several files made with different versions of Cura that had previously been printed several times and correctly. Same, shutting down.


I then tried several SD cards in case it was the one I was using that was going wrong. Nothing, all exactly the same with the same failures.


I still think it's a matter of the power supply connection to the main board. Sometimes, depending on how the cable is positioned, it seems to work and print perfectly, but I still don't know the correct position so it never fails.


I have also tried printing with the heated bed off, in case there was not enough power for some reason, although the printer has been in the same place, under the same environmental and electrical conditions for 2 years.


I'm not going to deceive you, I'm getting a bit desperate because I can't think of any more ideas. I've come to the conclusion that it's the main board that is failing, but I'm not 100% sure because I don't know how to do more tests.


Has anyone had something similar happen to them or can you think of what might be going on?


Kind regards,



  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ randomly restart mid print

    @Torgeir hasn't dropped in lately but he's pretty good with the 2's.  Maybe he'll respond and have a thought on this.


    The title says the printer "randomly restarts".  After reading your description it sounds more like it "randomly stops".  Would that be correct(?) or is it restarting the print from the beginning and double printing those first couple of layers?

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ randomly restart mid print

    Basically, it switches off and on again, but it doesn't keep printing again, no. That's why I put in the title that it restarts.


    I was testing between yesterday and today. Apparently, after the factory reset, I had set the heated bed to 25ºC for printing. Reading other posts on the forum, I saw people saying that turning it off worked for them. So I did that, turned it off and so far the two pieces I have printed (10h each) have printed fine. But of course, that works for me now that it's not too cold and I don't have adhesion problems to the bed, but what do I do when I have to put it on or the piece won't adhere?

  • Link to post
    Share on other sites

    Posted · Ultimaker 2+ randomly restart mid print

    Hi @annana,


    @GregValiant put up a good question for you and all off this additional info makes sense to me..


    As the printer turn on again after shutting down, mean the printer had a power drop down of some sort and after this drop the power supply now have lo load so voltage go up making the printer to do a new restart.

    Further, after you selected the bed off your printer work as normal, -meaning that the additional load of power to the bed would lead to voltage drop and make the processor stop working.

    Ofc. this could be caused by a reduced feeding capacities on the main board, however such problem is very rare and should be easily spotted by inspecting the PCB in this area around the connector input of 24 VDC and the other power consumers as bed connector, nozzle heater connector plus all the stepper drivers.


    All this "normally" point to power supply problem we've seen many times in here.

    As you have a relative new UM2, this printer was probably delivered with the Olson block (maybe 50W?), right?


    A test you could do, is just do a print using the bed at 60 deg. C. using a voltmeter (multi meter) and monitoring the 24 volt during printing to see if the voltage is dropping. It should be quite stable and have no "big" drop of voltage during printing.

    As this tend to happen during the two or so first layers, it should not take that long to verify. 


    Hope this helps somehow and if you need some schematics, drawing etc. just yell.






  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
          • Like
        • 26 replies
    • Create New...