Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
jonyo

fill density seems too dense?

Recommended Posts

When I use fill density of about 35% or more, instead of a grid it will just do diagonal lines that alternate in direction for every layer. The weird part, it looks like it is almost solid! At about 50% and above it seems like the infill is 100%. I've tested this on a simple 20x20x5 cube, I would upload the stl and resulting gcode and profile settings but I think I'm too new or something, don't see an upload button...

Is this normal or a bug? And if normal, any info on "how it works" so I can get a better understanding of why it works like this?

 

Share this post


Link to post
Share on other sites

I'm pretty sure it's both normal and correct. 50% means there is just as much plastic as air - that's pretty dense. When you hit infill 25% it changes the algorithm. I recommend you stick at 24% or lower for most parts. In fact most things don't need any infill but could use a thick shell. The shell is the most important region for strength.

 

Share this post


Link to post
Share on other sites

I'm pretty sure it's both normal and correct. 50% means there is just as much plastic as air - that's pretty dense. When you hit infill 25% it changes the algorithm. I recommend you stick at 24% or lower for most parts. In fact most things don't need any infill but could use a thick shell. The shell is the most important region for strength.

 

Ah, thanks for the explaination, that was another thing I was going to experiment with to figure out when it switches to use the alternating lines.

But that's the thing, I don't see any air between the gaps. I load it up in http://gcode.ws/ - to me the view of "just" the lines looks about right. But if you check the option to "Emulate extrusion width" it shows no gaps, it's pretty much solid.

Now that I think about it though, the gcode viewer is just looking at a "slice" of the slice, so you can't see the full "bead" of plastic. Is that part of the calculation, that even though each bead may be touching at the edges, there is still some gap/air around the corners? Wish I could upload a quick graphic to show what I mean in my speculation, hard to describe...

It just seems like such a huge change when switching from the grid to the lines. I would read up about it myself but my "google-fu" is failing me this morning, not sure what to call it when I search... I would totally accept that it's supposed to be that way, I'm curious about how it works though, love learning about how things work!

And thanks again for the really quick response and info! :)

 

Share this post


Link to post
Share on other sites

There is an option in gcode.ws with which you can make the viewer estimating the line thickness. With this option switched off (default setting), gcode.ws uses a standard line with which does not represent the printed line width. However, I would not trust the line with of a viewer anyway.

If 50% infill closes the gaps in the real print, you may have a mis-setting in the filament thickness and, as a result of this, an overextrusion. In this case, check the exact filament diameter and set it accordingly.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!