Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
ika1234

z-plugin: Performance issues with cura

Recommended Posts

Hi all,

I want to print "mass-production like", because a need about 80 parts.

As many parts on the plate as possible is the efficient way to go.

The model has 352 layers. When printing 12 parts I get >4000 layers in total.

(using the "print one at a time" feature)

The first 10 layers of each part should be printed with speed 20,

the rest with speed 50.

For the first layers, the bottom layer speed function should do its work.

But for the coming layers I am using the z-plugin.

Having calculated the performance reduction and increase layers I really stuck with z-plugin performance.

The further I come - let say I want the command

at layer no "2210" with

New speed % "40"

the more I wait for cura's response.

It takes a few minutes till I can fill in the next number.

The whole procedure has cost me more than an hour.

Is there any way to speed things up?

It would be helpful to stop cura from recalculation till all data are put in.

 

Share this post


Link to post
Share on other sites

I assume you refer to the TweakAtZ plugin when you write 'z-plugin'.

I recommend you fill in everything you need BEFORE you load the first object. As long as no object is loaded, Cura doesn't slice.

When everything is filled in as you want it, load the object and Cura will slice it ONCE.

The TweakAtZ plugin needs some time as it is a Python script which needs to be interpreted and not a compiled software. The plugin has been extended during the last few months. If you want to try an older version with less features you find the old versions at the http://wiki.ultimaker.com/CuraPlugin:_TweaktAtZ. For the present version 3.2 I recommend not to use more than five instances of the TweakAtZ plugin.

 

Share this post


Link to post
Share on other sites

Doesnt tweak at z support layer number AND height in mm? If you mass produce you shoukd be able to have one setting the height 0 setting speed at 40% and one setting at height 1.0mm (10x 0.1mm) to set speed at 100%.

Wouldnt that work?

PS: dont forget to remove the setting for your next unrelated print since they stay saved in cura.

PSS: I share your pain in the slow slicing...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!