Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
swarley

level issues

Recommended Posts

Hi im hoping someone can help me i recently bought a Ultimaker Original from a friend of mine who wasn't using it as much as he liked, i've had it running fine for a few days but now suddenly when i try printing anything out it either scratches the tape off or grinds against the layered plastic it's already put down, I've followed the directions on making the bed level and to make sure the nozzle is just about paper width away from the bed it's self but it seems when it starts printing the table either goes higher then the original setting or the nozzle goes lower when it's printing, it's making printing anything almost impossible any help would be amazing.

 

Share this post


Link to post
Share on other sites

swarly - please follow your own topic - click "follow this topic" in the top right of this post.

Well something seems to be wrong - not sure what. Either the Z homing switch is not working possibly. Or the Z axis isn't moving the right amount possibly. To diagnose a little further, get pronterface here:

http://koti.kapsi.fi/~kliment/printrun/

Hook a USB cable up to the printer and connect using pronterface. Then play with the Z axis - try homing it a few times. It shouldn't slam or make horrible sounds. You should be able to hear the Z limit switch click when it hits the switch. This is the Z=0 position.

If that seems to be moving, then try moving with G0 commands. For example:

G0 Z5.1

That moves the Z to position 5.1mm. That means 5.1mm below the nozzle. Try moving back to z=0. It should be repeatable - perfectly. Unless something is loose or defective. Also try measureing the distance the bed moves - maybe over in the corner with a ruler against the frame.

If you can narrow down your problem to something more specific that might be helpful in diagnosing.

 

Share this post


Link to post
Share on other sites

Let's keep it simple then - lets assume something jammed your z switch. Turn off power on the UM2 and if the bed is down low then raise it by grabbing it towards the rear and lift firmly so that it goes most of the way up.

Then look under the bed and you should see this long screw sticking down below the bed. Very long. Then imagine the bed in the "down" position and look at the hole that screw would normally stick into. Examine that hole carefully. You might want to tilt the UM2 on it's side and look at it from the bottom. Take something pointy and stick it into that hole and you should hear the click of the Z limit switch. Did anything fall into the hole and jam it up? Or was it already working?

This is the first test. If this doesn't fix the problem then maybe post a video of what is happeneing please. Make it very short. youtube is ideal for posting videos so please use that if possible.

 

Share this post


Link to post
Share on other sites

Hey, i have the exact same problem since today.

The bed is leveled correctly.

The print starts with a good layer but then the bed moves in the wrong direction (up instead of down).

So its scratching the old layer and finally my bed!

It seems to be a error in the G-Code generation because when i control the z-Axis manually it works fine.

It started today after i made a firmware update.

How can i check it in the G-Code file?

Can i upload a old firmware version?

 

Share this post


Link to post
Share on other sites

I checked the G-Code (see below), Z goes in positive direction, guess thats fine.

Could it be that the firmware turns it while reading?

M109 T0 S210.000000

T0

;Sliced at: Thu 21-08-2014 23:50:29

;Basic settings: Layer height: 0.15 Walls: 0.8 Fill: 0

;Print time: #P_TIME#

;Filament used: #F_AMNT#m #F_WGHT#g

;Filament cost: #F_COST#

;M190 S70 ;Uncomment to add your own bed temperature line

;M109 S210 ;Uncomment to add your own temperature line

G21 ;metric values

G90 ;absolute positioning

M82 ;set extruder to absolute mode

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

G1 Z15.0 F9000 ;move the platform down 15mm

G92 E0 ;zero the extruded length

G1 F200 E3 ;extrude 3mm of feed stock

G92 E0 ;zero the extruded length again

G1 F9000

;Put printing message on LCD screen

M117 Printing...

 

;Layer count: 66

;LAYER:0

M107

G0 F9000 X44.53 Y124.27 Z0.30

;TYPE:SKIRT

G1 F1200 X73.56

 

Share this post


Link to post
Share on other sites

Did you check the z limit switch? Read my 2 posts above. If that is working perfectly then next install pronterface as described above and do more testing.

 

Share this post


Link to post
Share on other sites

Thanks, the Z limit switch is on the right position, alsways stops perfectly. No weird sounds too.

 

I downloaded and used Pronterface.

The controlls are fine like in the Cura controll.

Also the G0 are working perfect.

It seems that the error just occurs when interpreting a G-Code File.

 

Everytime a print starts fine and instead of printing the next layer over the first layer, he wants to print under and goes lower and lower with every layer.

 

From Pointerface:

Connecting...

start

Printer is now online.

echo:Marlin Ultimaker: 13.12 (250000_single)

echo: Last Updated: Dec 16 2013 15:34:02 | Author: (David Braam)

Compiled: Dec 16 2013

echo: Free Memory: 4036 PlannerBufferBytes: 1232

echo:Hardcoded Default Settings Loaded

echo:Steps per unit:

echo: M92 X78.74 Y78.74 Z533.33 E836.00

echo:Maximum feedrates (mm/s):

echo: M203 X500.00 Y500.00 Z5.00 E25.00

echo:Maximum Acceleration (mm/s2):

echo: M201 X9000 Y9000 Z100 E10000

echo:Acceleration: S=acceleration, T=retract acceleration

echo: M204 S4000.00 T3000.00

echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)

echo: M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00

echo:Home offset (mm):

echo: M206 X0.00 Y0.00 Z0.00

echo:PID settings:

echo: M301 P22.20 I1.08 D114.00

echo:SD init fail

echo:endstops hit: Z:0.00

echo:endstops hit: Z:0.00

echo:endstops hit: Z:0.00

>>>G0 Z5.1

SENDING:G0 Z5.1

>>>G0 Z5.1

SENDING:G0 Z5.1

>>>G0 Z5.1

SENDING:G0 Z5.1

>>>G0 Z2.1

SENDING:G0 Z2.1

>>>G0 Z0.1

SENDING:G0 Z0.1

>>>G0 Z10

SENDING:G0 Z10

>>>G0 Z9

SENDING:G0 Z9

>>>G0 Z8

SENDING:G0 Z8

>>>G0 Z15

SENDING:G0 Z15

>>>G0 Z0

SENDING:G0 Z0

>>>G0 Z0

SENDING:G0 Z0

 

Share this post


Link to post
Share on other sites

I tried some more prints. It doesnt really look like the bed moves up layerwise, but more slowly automatically or randomly during a layer.

Starts a bit too high, second layer just great and on the third or during the second layer it starts to scratch and get deeper in the plate.

My plate looks like a swiss cheese soon :-(

 

Share this post


Link to post
Share on other sites

Sorry, another update.

Made a new Firmware update and then let it scratch my bed (ned a new one anyway) to see if it goes even deeper.

 

But after the third layer it goes in right direction again, stays a bit on the height of layer 3 and then tries to catch up making some layers too high. After Layer 6 or 7 the z-axis works like it should.

The print still looks weird. Many small jumps in the x and y axis on some layers.

Also the print way is not as it should be. Too many rapids and new positioning.

 

I have uploaded some pictures of the print. (should be a Fairphone case)

And the G-Code File and slicer log. (I don't understand it so well...)

https://drive.google.com/folderview?id=0B5Pax3F9EeJWb1g1ZDRjbXMzTDA&usp=sharing

 

Does someone see a solution?

 

Share this post


Link to post
Share on other sites

I tried some more prints to check.

After setting the initial layer thickness to 0, it doesn't scratch in the bed anymore.

And it does not seem like the z axis is really going backwards now, but ignoring some z-positions (especially layer 2-5) and catching up later again.

So the printer prints in some layers double and pushes the print down, causing a shift in x or y on the print.

By catching up in z direction, some layers have a space between each other.

There seems to be no fault in x-y, just in the Z-Axis goes weird.

I have cleaned and greased all axes just before. They are going very smooth.

 

Or is the stepper motor bad and not doing it steps correctly (if thats even possible)

**UPDATE:

I tried another print with another file. (see below)

Here its only the first few layers as described. (ignoring the height after the second or third layer and printing some layers on one heigth)

The rest goes fine again.

 

Share this post


Link to post
Share on other sites

Please update your "profile settings" and set your printer to be an "ultimaker original".

The pattern of error repeats. I think this is a mechanical problem with your Z screw. If you hold the Z screw at the bottom while it prints - does it rotate in the same direction for every layer change or does it change direction?

I think your Z screw or Z nut is causing this problem. The screw might be badly warped or something. Is it sitting completely inside the coupler? The coupler is the part at the bottom of the screw that connects it to the motor.

Maybe the Z nut is loose inside the wooden Z bed. This happens sometimes.

I would go back to pronterface and play with the Z movement some more. Look very carefully at the bed while it moves large distances. The error is small - one layer may be twice the thickness of paper and your error is about that much. About .2mm. But it repeats.

The thread spacing on the Z screw is 3mm. What is the spacing on the error pattern on the fairphone case?

Do a large movement with pronterface and see if you see the screw is warped at all. Look for any kind of repeating pattern in the screw and also in the bed movement. I think you are going to have to take apart that bed and rebuild it so that the z nut is held a little more tightly and the spacing is good on the 2 vertical rods.

Also consider cutting power and turning the Z screw by hand - there is supposed to be a green packet of grease meant for the Z screw. I don't know if this is related though.

 

Share this post


Link to post
Share on other sites

Thanks for the help and good tips!

SOLVED!

I checked all mechanical things about the Z-Axis for hours, cleaned, disassembled and tested.

After many print attempts of diffrent models i realized, that it is not the layer that matters, but that it is after a specific time that it starts to grind in the bed.

But the bed was working perfect, the motor going in the right direction and the G-Code files correct too.

It was the printhead! :oops:

There are four long screws holding together the print head.

The two on the extruder side were a bit loose.

So in the beginning the heigth was fine, but after a bit pressure build up from the filament extruding, the extruder head moved down a bit! This was irregular depending on the pressure, starting after a few seconds, getting better, starting again...

After i tightened the screws correctly all prints are suddenly fine!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy