Jump to content
Ultimaker Community of 3D Printing Experts
jweaver

Anyone printing multi-colour with a Printrbot?

Recommended Posts

After discovering 'plugins', I figured I would be able to print 2 colour models on my Printrbot Simple Metal.

But the plugins dont work as there is no way to 'resume' a print.

DOes anyone have a Printrbot and know of a way to do 2 colour prints? Other than changing the filamnet mid print, I don't have a clue.

I am pretty sure that its possible using RepetierHost/Slic3r, but I LOVE CURA and want to stick with it.

Jon

 

Share this post


Link to post
Share on other sites

There is hope.. I found this

http://meow.noopkat.com/3d-printing-in-multiple-colours-with-one-extruder/

Cleary she has a Printrbot and is using CURA, so there MUST be a way to do this.. She provides a modified Plugin whihc might help.. But it still comes back to the question.. "How to resume". There is no button to do this in the Pronterface UI...

 

Share this post


Link to post
Share on other sites

I have been talking to Suz (the author of the Blog) and there is a surprisingly simply solution to this.

Basically use CURA and the Plugin to create teh G-Gode and then "print" it using Repetier or other software.

She suggested that Pronterface would work.. And I will test this tonight..

But I am intreagued.. Would it be possible to integrate the latest version of Pronterface into CURA? Which has the Pause button?

http://koti.kapsi.fi/~kliment/printrun/

I was thinking that it could be set in the Preferences.. So you have the option of the current Pronterface UI, and also the 'full' one.. Even if it was done as an experimental unsupported feature? I just don't understand why the "full" version of Pronterface isn't an option... (That said, I am not a developer so don't have a clue what I am talking about really)..

 

Share this post


Link to post
Share on other sites

I have a Printrbot Simple with the add on board for two additional extruders, an all metal hotend as my second extruder, with a half-watt laser powered by the third extruder hotend connector. In Repetier, you can specify that your printer has multiple heads. Then in Cura, you can specify details about each of the hotends and what use it will have (printing a certain color or type of material, Printing fill, or printing support material. In the generated g-code, the active head is specified with the T0, T1, & T2 commands. I use M104 S0 T2 to turn my laser off and M104 S50 T2 to turn it on again. I have found than I have to put G4 P0050 commands before the M104 commands to keep the laser from turning on/off before the prior move has completed. The G10 command allows the setting of all the initial details for each tool (retract,temp setbacks, operating temps, and head offsets.

I am looking for a way to have this special code be inserted by cura for each non-print move.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!