Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
daveg

Problem sliceing thin walls

Recommended Posts

Here is an issue I've been having with thin walled parts sliced with Cura versus the same parts sliced with Slic3r.

IMG_2275_zpstak19ner.jpg

As you can see the part sliced with Cura is all kinds of ugly! It seems to be caused by too many extrusion paths in thin wall sections causing extra material to be squished out around the tip which then deposits around the exterior of the part. As far as possible, the settings being used in Cura and Slic3r are the same.

When I look closely at the slicing preview here's what I find:

Comparison%20%20Layer%2075_zpsis2ltunr.jpg

Comparison%20%20Layer%20175_zpszalz5i8a.jpg

For the same wall thickness Cura is creating extra extrusion paths. At layer 75 (wall thickness 0.30") Slic3r runs two paths, Cura runs 2 plus a bunch of swiggly fill in between. At layer 175 (wall thickness 0.59") Slic3r is running a perimeter path and a single path laid down in between, Cura is laying down two interior paths, almost on top of each other. This excess infill is being forced out around the nozzle and deposited around the outside of the part.

Changing the Infill setting has no effect in these areas, so neither slicer is considering them infill but rather part of the perimeter. I can't find any setting that controls this, does anyone know of any? The flat area at the base of the part also has a lot more passes being laid down by Cura but there it is not having the same effect. I am not getting the same globs happening with thicker section parts.

 

Are there any settings that would control this? Other than trying to trick Cura by specifying a different nozzle diameter than the one I'm using.

 

Share this post


Link to post
Share on other sites

I think he's using repetier host for viewing gcode. Not certain. It's free - try it. Pretty easy to use and you can look at 3d image in left pane and actual gcode in right pane and highlight just one command in gcode and see it in the left pane.

 

Share this post


Link to post
Share on other sites

What happens at layer 175 in Cura should certainly not be allowed to happen. The thing is that in order to prevent the double inner perimeter, a lot of computation time will be sacrificed. I will add an option which prevents it. It will probably be in a release over a month or so, however.

 

Share this post


Link to post
Share on other sites

Yes, I am using Repetier Host for viewing and running the printer (these are printed on a Printrbot Metal Simple, not an Ultimaker).

I was using a .4mm nozzle, .8mm shell thickness, 100% infill. Retraction was enabled, set to 3mm.

Changing the infill has no effect on this. Even setting infill to 0% results in the same path generation in the thin wall areas. So it appears that the paths are being generated as part of the perimeter, not infill, calculations.

As a note, the Cura print specified using about 10 percent more filament than the Slic3r.

I'm fine with using which ever slicing program will yield the better results on ant given part, so Slic3r works out better for this one with thin walls, but Cura generates better support structures than Slic3r so there are times I'll want to use it instead, and maybe have thin walls. So I'm trying to figure out if there is a solution to this.

Thanks for the help!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy