Jump to content
Ultimaker Community of 3D Printing Experts

Stuck on plug-ins


Recommended Posts

Posted · Stuck on plug-ins

Need to insert some nuts into a print. This is the first time for using plug-ins!

Thought it would be simple like pause at height, but there is no pause at layer number only height in mm, Is that right?

How would you do it?

Secondly Tweak at z isn't really suitable for this, now after playing around, I have several plug-ins duplicated and can' find a way to remove them, any help?



  • Link to post
    Share on other sites

    Posted · Stuck on plug-ins

    The other alternative is to use brass inserts for plastic. They can be pushed in cold or hot; and indeed screwed in although not sure how "brittle" PLA would cope with that. Quite a few suppliers in the UK


  • Link to post
    Share on other sites

    Posted · Stuck on plug-ins

    It is indeed in height (mm.) rather than layer, which I found extremely annoying as welll However, there are ways to do it:

    - First, set up your slicer settings (layer height, speed, temp, etc.)

    - Check in your layer view, at which layer you would like to pause and note down the number

    - Multiply the layer number with your layer height setting, to get the pause height in mm. (eg. layer 100 x 0.2 layer height = 20 mm.)... Punch this value into the "pause at height" plugin

    - Set a parking spot for the plugin as well (a coordinate for the head to move to during the pause), this will prevent the head from oozing on your print and being in the way of your work)

    - The parking move shows in the layer view (its just a long line from your print object to the parking coordinate), so look for it in your layer view, and check that its at the right height.

    Remember, you can string several plugings together, incl. the same one multiple times (to eg. oause 3 times during a print)

    Hope that helps you :)

  • Link to post
    Share on other sites

    Posted · Stuck on plug-ins

    Thanks very much for the comments!

    Tommy, I think I will go with your suggestion!

    I tried last night, a couple of tests, where the nozzle had reached pause-at-height position and parked.

    Oozing but no problem but when resuming printing, the extrusion went ballistic, then wouldn't extrude at all!

    Temp was 197c (small test part). Rebooted the UM2 a few times, unblocked the nozzle (it wasn't really blocked but went through the motions) Even extracted the filament, cut and started fresh, still no good, no extrusion. Will have another look later today!


  • Link to post
    Share on other sites

    Posted · Stuck on plug-ins

    Update: Everything working again!

    Good nozzle clean out and pass a decent amount of filament done the trick!

    Pause at height working fine now!


  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    • Create New...