Jump to content
Ultimaker Community of 3D Printing Experts
shadowfiend

Large print nightmare! Print needed by Monday for customer.

Recommended Posts

Hi Makers,

I have a customer that needs two copies of a part that is 150mm tall. I have already contacted tech support but have had no reply since Thursday.

I have had three failed prints and it seems that pythonw.exe is crashing every time and the print just stops. I have been looking at this method:-

2 ways to resume print from last layer

But because the print is still sitting on the bed, the only place I can home the nozzle is the back left corner, otherwise the x axis rod would hit the half printed work.

I don't have much experience with Gcode and the like but I have tried changing the start.gcode settings to change the homing position, but it keeps trying to home to the front left.

Also if anyone knows a workaround to prevent python crashing on a large print I would be most grateful. I have ordered the UltiController but that won't save my bacon this time.

I'm running Cura 15.02.1 on Windows 7 Ultimate.

Sorry if I missed anything out but I'm really stressing over this, the prints take about 38 hours each!

Many thanks and kind regards.

Share this post


Link to post
Share on other sites

Quite uncomfortable situation.

So you know exactly where the print stopped (layer no. or z height), maybe even where in the layer?

You don't have a heated bed or you managed to keep the heated bed warm? Then you have everything what's needed to continue the print. @gr5 has once written detailed instructions how to continue a failed print but I cannot find it here on the new forum. Maybe he can point out where it is/was.

If Cura turns out to be not reliable enough for USB printing in your case you should give Printrun/Pronterface a try for now. As you realised, printing from an Ulticontroller is the best thing you can do.

edit: Did you loose any of the three coordinates? Is re-homing necessary?

Edited by Guest

Share this post


Link to post
Share on other sites

Hi dim3nsioneer,

Uncomfortable yes, but with helpful folk like yourself, I think I can get it all sorted :c)

I have worked out that the print stopped at 75.6mm or 378th layer. I'm printing at .2mm layers. I don't have a heated bed, but a light bulb powered heated chamber and the print is stuck down really well, so no problems there.

The main issue is understanding how to set the homing position to the back left in the gcode, is there an override that is in firmware? Can't seem to figure this out.

Printrun/Pronterface looks great, but I think I just need to fix the homing thing and I'll be away.

Thanks bud :c)

Share this post


Link to post
Share on other sites

I suggest the following:

1) Drive to a z height where you can savely home the x and the y axis (e.g. by 'G0 Z80')

2) Home x/y by 'G28 X0 Y0'

3) Drive to a x-y-position where you can safely home the z axis (e.g. by 'G0 X0 Y180')

4) Home z by 'G28 Z0'

Let me know if you need more help with the travelling or homing commands.

Edited by Guest

Share this post


Link to post
Share on other sites

Sorry, my mistake... :O

I guess you first have to execute these steps with Printrun/Pronterface one by one (in the terminal window of Pronterface) to make sure you use x, y and z coordinates for the special homing process which do not destroy your print.

Once you are sure they work, drive to the safe z position.

Then I think it's best to safe the gcode you used so far and to edit it. Part of the start.gcode has to be kept in maybe; it depends on the current status of your hotend. Is it still warm? If yes, then I guess the material has been carbonized in the meantime and you need to purge the hotend (taken into account below).

In the start.gcode everything starting from 'G28 X0 Y0' has to be modified until 'M117 printing...'.

 

G0 Z80.0G28 X0 Y0  ;move X/Y to min endstopsG0 X0 Y180; make sure this position is safe for z homingG28 Z0     ;move Z to min endstopsG1 Z75.8 F?whateverstandshere?G92 E0                  ;zero the extruded lengthG1 F200 E20              ;extrude 20mm of feed stockG92 Exxx                  ;adjust the extruded length;Put printing message on LCD screenM117 Printing...

 

You then have to delete everything BUT THE VERY LAST G1 COMMAND between this M117 command and the comment ';LAYER:378'. Enter the E coordinate of this last G1 command into the G92 command (where the 'xxx' are). Then replace the G1 of this command with a G0 and delete the E-coordinate of the command.

You should now have a file which will continue at the beginning of the layer where it stopped. This will lead to overextrusion for the part of the layer which was already printed.

I recommend someone else looks over the things I've written here and checks it. I might have made a mistake somewhere and four eyes usually see more than two.

Edited by Guest

Share this post


Link to post
Share on other sites

Whatever I put in the gcode file for the G28 X0 Y200 just gets ignored and the printer just goes to the front left position so I have to power it off to avoid a collision. Also I would assume that the layer view would show the change in the blue line for the toolpath, but it is not. There must be an override that is taking precedence and I've no idea where to find it :c(

Share this post


Link to post
Share on other sites

I’m PRINTING :c)))

I am really happy thanks to your help dim3nsioneer :c)))

This is the code that I eventually ended up using:-

M109 S200.000000 ;heat the nozzle to 200C

G0 Z80.0 ;Move high enough to clear the print

G28 X0 Y0 ;move X/Y to min endstops

G0 X0 Y200 F9000 ;make sure this position is safe for z homing

G28 Z0 ;move Z to min endstops

G1 Z75.7 F?whateverstandshere?

G92 E0 ;zero the extruded length

G1 F200 E20 ;extrude 20mm of feed stock

;G92 E494.38289 ;adjust the extruded length

;Put printing message on LCD screen

M117 Printing...

I followed your instructions and tried each line of code with my finger on the power button just in case :c)

After all the startup code was working I pasted it into the big gcode file and deleted the code that had already been printed. To make sure everything was lined up and there was no chance of a collision I used the print speed adjustment and took it down to 10%, I disengaged the extruder but heated the nozzle up and set it going. This was good because it helped to smooth out the plastic at and prepare it for good layer bonding .

It’s done a few layers now and things are not lined up too badly. I’m amazed it worked at all to be honest because I had not saved the gcode before I started the print and had to ‘trust’ that the rotation and scale had been applied exactly as I had done the first time. I’m gradually increasing the speed and all is going well.

Many thanks dim3nsioneer, I really am grateful for your skilful help.

Very best regards.

Ian.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy