Jump to content
Ultimaker Community of 3D Printing Experts
lassesp2142

Ultimaker Original + Blank Display

Recommended Posts

Morning everyone!

So, I seem to have run into a slight problem with my UM O+.

It appears that my display is not showing anything. I've managed to accidently start a print, so I know the software is working.

I've followed the instructions as well as I could, but I'm hoping I did a mistake instead of having to get a replacement.

DSC_0030.thumb.jpg.8d1fd47539569ed59dade1854a934bce.jpg

DSC_0032.thumb.jpg.8d90fc7fe9e14c13c223bb3f16fca3c2.jpg

DSC_0035.thumb.jpg.a725e545464804d585efa313b45d9720.jpg

DSC_0034.thumb.jpg.bab912164aa29d793589e9a779e52064.jpg

DSC_0030.thumb.jpg.8d1fd47539569ed59dade1854a934bce.jpg

DSC_0032.thumb.jpg.8d90fc7fe9e14c13c223bb3f16fca3c2.jpg

DSC_0035.thumb.jpg.a725e545464804d585efa313b45d9720.jpg

DSC_0034.thumb.jpg.bab912164aa29d793589e9a779e52064.jpg

Share this post


Link to post
Share on other sites

Your symptoms are what I would expect if one of the ribbon cables was backwards. Unfortunately I don't know where the red stripe is supposed to go. And how do you know which cable is which?

I have a UMO and a UM2 but the UMO+ has a mixture of equipment from those 2 machines so I'm not sure how the ribbon cable is supposed to go.

also it looks like those 2 cables each have a backwards crimped ribbon - which shouldn't matter as long as you are consistent with the red stripe - but still - strange.

Where in the manual (I have it open) does it say which ribbon connector goes where?

Share this post


Link to post
Share on other sites

Hi, I know this thread is sort of old, but I just finished putting my umo+ together and I'm having the same issue. Was there a solution to this?

 

hi,

make sur you have the good firmware (re-upload it with Cura)

the pictures of lassesp2142 look good

Edited by Guest

Share this post


Link to post
Share on other sites

A bit off topic. It's so great to see 2.1.4 boards with the new UMO+ :O

Great news for better future um2 hotend use =)

Also yea, reupload the firmware, that what's looks like when a board has um2 firmware on the umo+ display.

Also since you are installing your machine. You can get a um2 led strip from any ultimaker distributor, it sticks and fits perfect and works like a charm when you use the Amedee firmware builder https://bultimaker.bulles.eu

And how it looks the leds on umo+ when installing it:

https://ultimaker.com/en/community/9607-leds-on-umo-out-of-the-box?page=3#reply-115149

Share this post


Link to post
Share on other sites

Hi, I know this thread is sort of old, but I just finished putting my umo+ together and I'm having the same issue. Was there a solution to this?

 

Did you read the post right above yours?  Please supply more information about your problem.  I can't tell you how many times people say "I have the same issue" but they have a completely different issue.

Edited by Guest

Share this post


Link to post
Share on other sites

 

Hi, I know this thread is sort of old, but I just finished putting my umo+ together and I'm having the same issue. Was there a solution to this?

 

Did you read the post right above yours?  Please supply more information about your problem.  I can't tell you how many times people say "I have the same issue" but they have a completely different issue.

 

Sorry about that. I'll try to be more thorough in the future. I just updated the firmware and it worked like a charm.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Design Contest | Vehicles.
      We're open for entries! - Design and submit your 3D designs of architectural entourage - vehicles - for a chance to win a large filament pack. Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled model can really help to get your idea across.
        • Like
      • 24 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 23 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!