Jump to content
Ultimaker Community of 3D Printing Experts
bbureau

Scaling issues when exporting from Inventor 2016

Recommended Posts

Greetings,

I am having some trouble maintaining scale when exporting a completed file from Autodesk Inventor 2016. When browsing the forum I came across a possible error resulting from the transfer from inches to the Cura's standard mm. So I recreated the file in Inventor utilizing milimeters as the standard and it still imported the file w/ a very messed up scale. I had to increase the imported file by a little over a factor of 10 to be able to print the file in the correct size.

Obviously this is a very frustrating error as I shouldnt have to print the same file multiple times so established a specific size, when it was already coded that way in Inventor. Does anyone have a fix for this? Am I doing something wrong? Any & all help would be greatly appreciated moving forward.

Respectfully,

Bret

Share this post


Link to post
Share on other sites

Hi @bbureau, I cannot help specifically but a couple of points. We design in Solidworks and some of the work is dimensionally critical and comes out fine in Cura. So I do not believe that Curas has a bug per se in this area. I know you will have done it already but you need to check your export settings and system settings in Inventor. As arch enemies I am sure Inventor and Solidworks are as good as each other in the area of .stl file creation so I cannot but help think that the problem is with your Inventor end.

Share this post


Link to post
Share on other sites

Does anyone else have this problem or any suggestions for me moving forward? I really need some help to be able to move forward.

 

Hi Bret

I use  Inventor also

In Inventor for stl files do not use "export"

After drawing in inch

Try these steps :

Go to " tools " _ " document settings "_" units "  change inch to mm.

then open

"3D Model"_" 3D Print"

then choose " ultimaker2 "

set orientation if necessary

valid by clicking on STL button, that will save it in the direction of your choice

( if you modify your drawing in " 3D model" tab do not forget to "delete" your old 3D print setting before doing again the new one.)

Cura will open your stl file with the good dimensions in mm.

Hope that will help you

Regards

Share this post


Link to post
Share on other sites

 

Does anyone else have this problem or any suggestions for me moving forward? I really need some help to be able to move forward.

 

Hi Bret

I use  Inventor also

In Inventor for stl files do not use "export"

After drawing in inch

Try these steps :

Go to " tools " _ " document settings "_" units "  change inch to mm.

then open

"3D Model"_" 3D Print"

then choose " ultimaker2 "

set orientation if necessary

valid by clicking on STL button, that will save it in the direction of your choice

( if you modify your drawing in " 3D model" tab do not forget to "delete" your old 3D print setting before doing again the new one.)

Cura will open your stl file with the good dimensions in mm.

Hope that will help you

Regards

 

Ill have to try this when I get home. It has been frustrating trying to get it to work. Im trying to prototype something and having all the dimensions different doesnt make for a great finished product !. So I utilize this method AFTER I have created the model to retroactively change the units of measurement? As well, how would I "delete" the old 3d print settings before making a new one in 3d model?

Share this post


Link to post
Share on other sites

I never used the 3Dprint option in Inventor. I always use CAD export as bbureau probably does.

I remember hat I had to change a setting when exporting STL for the first time. Check Options in the CAD export dialog. There is a unit switch there. Maybe that fixes it.

 

Which Inventor version are you using? I have created my piece both in metric & imperial units. Both of which seem to skew when importing into cura. If you dont mind could you give me a step by step of how you initially configured your system? I would be most appreciative if you could find the time.

Respectfully,

Bret

Share this post


Link to post
Share on other sites

 

I never used the 3Dprint option in Inventor. I always use CAD export as bbureau probably does.

I remember hat I had to change a setting when exporting STL for the first time. Check Options in the CAD export dialog. There is a unit switch there. Maybe that fixes it.

 

Which Inventor version are you using? I have created my piece both in metric & imperial units. Both of which seem to skew when importing into cura. If you dont mind could you give me a step by step of how you initially configured your system? I would be most appreciative if you could find the time.

Respectfully,

Bret

 

Same as you 2016.

1. Make a model in the system you like mm or inch.

2. Go to  menu -> export -> CAD Format.

3. Choose STL as file extension

4. Click the Option button

5. change the units to mm

6. Export

You need to do Step 4+5 only once as inventor saves your selection.

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy