Jump to content
Ultimaker Community of 3D Printing Experts
peetersm

CURA 2.1.2 gcode file naming behavior

Recommended Posts

Two things I'm not sure if these are fixable or not.

1. the "machine name_" is appended to the beginning of the gcode file name.

so your file is called "mark cool file for 8nozzle.stl" and the gcode is saved as "UM2+_mark cool file for 8nozzle.stl" This is annoying since naming gcode so that you can read it on the tiny controller screen is important and especially the beginning of the file name which is often all you get to read. Can this be turned off in preferences? or IF YOU MUST add clutter to the gCode file name could you add this to the end where it will not interfere with our naming systems?

2. file names are truncated after the last period in the file name.

so your file is called "2.8.10n8-Flat Stimga5 Long.stl" and the gcode is saves is called "UM2+_2.8.gcode".

OR

your file is called "2.8.1.0.n.8-Flat Stimga5 Long.stl" and the gcode is saves is called"UM2+_2.8.1.0.n.gcode"

this is strange behavior, the old CURA would have named the 1sty examples as gcode "2.8.10n8-Flat Stimga5 Long.gcode"

is this something that can be changed in the preferences or fixed in the code?

Share this post


Link to post
Share on other sites

Many of the settings are saved at the end of the gcode.

Also, you can edit the file name in Cura 2.1.x, just click on it.

 

sure you can, but the point of having it configurable is you set it up once to your liking and forget about it..... I fe want the nozzle size in the filename, but you might have a different need...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy