Jump to content
Ultimaker Community of 3D Printing Experts
peteruithoven

[Solved] Heated bed issue Ultimaker 2

Recommended Posts

Hi folks,

We're having an issue with our Ultimaker2's heated bed.

When we attempt to print we get the flowing error pretty quickly:

 

Error - Stopped Temp Sensor BED

When we just heat the bed from for example 60 to 90 degrees we get the same error. When I tried this again (heat it to 90 degrees) I saw the temperature suddenly jump from 75 to 120 degrees.

We checked the following page:

https://ultimaker.com/en/resources/19485-error-stopped-temp-sensor-bed

A few observations:

- We of course checked if the cables where properly connected, seemed so.

- Visually there seems to be nothing wrong with the sensor or the connections going to it. (I'm assuming the sensor is the white SMD component)

- We disconnected the cables and checked the cables them with a multimeter, even when moving them, they seemed fine.

- We checked (with a multimeter) the connection between both sides of the sensor and the screw terminal on the bed, seemed fine.

- Cooled down the resistance over the sensor was 112.4 ohm.

- After switching around the bed (TEMP3) and nozzle (TEMP1) connectors in the main board:

 - When we just heat up the nozzle the temperature sticks to 30 degrees and we get an "Error - stopped heater error" pretty quickly.

 - When we just heat up the bed it shows a lowering temperature from 45 to 29 degrees (the nozzle was cooling down from the previous test). In the end it shows: "Error - Stopped temp sensor".

Is there anything else we could check? What could be the problem?

Thanks in advance!

Edited by Guest

Share this post


Link to post
Share on other sites

All PT100 sensors have the same temperature versus resistance curve so any manufacturer will work although it's rare for them to die. I forget if it's 0603 or 0804 or other SMD size.

More likely the wiring somewhere between the circuit board and the bed is faulty. Most likely on the bed PCB. Start with reflowing the solder at the terminal block. The etches on the bed can also fail. If so consider bypassing that with a wire.

PT100 should be around 108 ohms at room temperature.

Share this post


Link to post
Share on other sites

I looked at the connections on the bed through a microscope (awesome to have a electronics colleague) and they seemed fine, but I re-soldered them anyway.

After heating the bed to 85 degrees (and seeing the temperature suddenly jump to 100 and back again) I noticed that the resistance directly over the sensor was 4,6 MOhm, which seems like a crazy amount. I re-checked my multimeter with a basic 220 ohm resistor.

I think I'll try to get my hands on a new PT100 B sensor. Comparing it to the Adafruit Ruler it seems to be the 805 form factor. If someone has a Farnell / ... link ready that would be really awesome.

Share this post


Link to post
Share on other sites

If you measure the resistor while it's connected to the UM and the UM is powered up you will get crazy readings like this. The way the UM and the way your meter measures resistance is it puts a small voltage across the two wires and measures the current flowing through. Unfortunately the UM and the meter use different voltages. The UM uses around a volt and your meter sends out only probably a few mv. So the meter is getting all confused. I would heat until it fails then quickly cut power and measure with voltmeter then to see if it's actually the PT100. Things expand when heated at different rates. The problem is almost certainly in an area that gets hot - in other words on the bed somewhere. It could be a hairline fracture in the conductive trace but more likely a solder joint but you reflowed them all. So maybe it's time to change the PT100 - I don't know.

I would also connect the meter up to the screw terminals to free up my hands and push around on the PCB while watching the meter to see if the resistance jumps suddenly. Sometimes you can find the bad spot that way.

Share this post


Link to post
Share on other sites

You are totally right, I totally forgot about disconnecting the power. I should have known that by now. Measuring this again with the power cut off I got a normal looking value.

I now re-soldered all connections of the screw connector and the sensor, while adding some more soldering (without moving the components) and now it seems to work. I tried heating the bed to a few temperatures and saw no strange fast fluctuations.

I'm starting a bigger print to test it over a longer period.

Thanks for all the help!

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Terms of Use Privacy Policy