Jump to content
zizon

Pourquoi je perd toutes mes affaires !

Recommended Posts

Posted · Pourquoi je perd toutes mes affaires !

Bonjour a tous,

Je poste cette question car je ne doit pas être le seul dans ce cas.

Pourquoi je dois recharger mon fichier Material.txt que j'ai importé de ma carte SD a chaque fois que j’allume mon UM2 alors que je le sauve bien a chaque fois.

Zizon

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Il craque même doublement ahah !

J'ai pas ce problème... T'en as beaucoup de profils ?

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Ben oui pour chaque filaments que j'utilise.

Je rentre juste la température de base buse/plateau pour faciliter les changements de filament sur l'UM2

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Salut,

Essai d'envoyer une commande M500 à l'imprimante après avoir fait l'import

Ça force l'enregistrement des paramètres dans la mémoire EEprom.

Share this post


Link to post
Share on other sites
Posted (edited) · Pourquoi je perd toutes mes affaires !

Non @electromu ça ne marche pas.

Je ne comprend pas pourquoi, je dois pas être le seul a avoir ce problème si ?

Edited by Guest

Share this post


Link to post
Share on other sites
Posted (edited) · Pourquoi je perd toutes mes affaires !

Merci @DidierKlein ma bécane tourne en ce moment, je vérifie ça après.

Je sais que je tourne avec le "Tinker-MarlinUltimaker2-16.08.2" (ça semble être la dernière version)

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

J'ai fait des test hier avec le fichier de Zizon.

J'ai le même pb que lui.

Je fait encore d'autres tests ce soir. Je pense avoir mis la main sur le pb.

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

J'ai fait des test hier avec le fichier de Zizon.  

J'ai le même pb que lui.

Je fait encore d'autres tests ce soir. Je pense avoir mis la main sur le pb.

Est-ce qu'il va survivre docteur Mu ?

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Non ben j'abandonne... Je comprends plus rien et je commence à chopper une ampoule à l'index a force d'enlever et de remettre la carte SD.

Je suis reparti de zéro.

J'ai créer 12 profils custom sur la bécane et j'ai exporté le fichier.

Ensuite je remet en forme avec wordpad (comprenez j'ajoute des retour à la ligne pour que la lecture soit plus digeste)

je ré-importe le fichier et ça fonctionne même après redemarrage. ( en laissant des noms custom1, custom2...)

Je reprend la carte, je change les noms et je ré-importe et ça fonctionne sauf qu'il me rajoute un profil CPE à la fin de la liste.... profil que je n'ai pas mis dans mon fichier material.txt

je crée un profil CPE en 1ere position je réimporte et je n'ai plus qu'un profil cpe dans le début de liste. Celui de fin de liste à disparu. Je redeémarre et ça me remet les profils pla abs cpe comme si j'vais fait un factory reset...

Je change le nom du MATERIAL.TXT en remettant le TXT en minuscule et ça enregistre à nouveau correctement mais toujours avec un profil CPE à la fin de la liste....

Je redémarre une fois tout va bien je redémarre une seconde fois et rebelotte je suis en mode pla abs cpe only ;/

J'ajoute alors dans mon fichier MATERIAL.txt des saut de ligne entre chaque information et ça à l'air de bien fonctionner malgré un profil CPE toujours à la fin de liste...

S'il m'en restait je m'arracherais bien les cheveux tiens...

@Zizon je t'envoi le fichier qui fonctionne le mieux chez moi. Essaye de l'importer dans ta bécane. attention de n'avoir qu'un seul fichier MATERIAL sur ta carte SD. Il ne faut pas avoir deux fichiers avec les 8 premiers caractère pareil à ce que j'ai compris de la gestion 8.3.

Ainsi si tu as un MATERIALCOPY.txt et un MATERIAL.txt la bécane est susceptible de prendre le MATERIALCOPY car elle ne se base que sur les 8 premiers caractère du nom de fichiers.

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Et si tu importes celui qui semble bon, redémarre une fois (puisque ça tient toujours) puis ensuite tu exportes le tout ?

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Merci beaucoup @electromu de t’être penché sur ce problème.

J'avais également essayé en changeant les attributs du fichier mais non, rien n'y fait.

Comme toi, je me retrouve avec les 3 profils Abs,Pla,CPE !

Je regarde le fichier que tu m'as envoyer demain matin et te tiens au jus.

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Et si tu importes celui qui semble bon, redémarre une fois (puisque ça tient toujours) puis ensuite tu exportes le tout ?

 

Eh bien ça me fout en l'air les tabulations et ça ne change pas le pb si je fait une modif...

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Les tabulations n'ont d'intérêt que pour nous pour y voir, en soit la machine s'en fout.

Peut-être faudrait-il voir pour intégrer ça dans le firmware directement pour réinjecter le tout...

Les symptômes ressemblent à une EEPROM qui se fait effacer comme si ça correspondait simplement à de la data volatile et je pense que le fait de ne pas avoir le firmware d'origine génère aussi un phénomène de corrélation. En gros une fonction du fw UM veut prendre le dessus (genre celle de l'import et le stockage sur EEPROM des profils) mais le tinker qui veut essayer de faire "bien" et pas tout casser il prend en compte un démarrage machine mais soit il va taper dans une autre rangée de données dans la mémoire, soit il ne tape pas du tout dedans et ce sont les profils inscrits en dur dans le fw qui prend la relève.

La question c'est pourquoi ça n'arrive pas au premier redémarrage. Justement parce que la pile de la mémoire ne s'est pas encore déchargée (comprenez stack quand je parle de la pile)

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Zizon  je t'envoi le fichier qui fonctionne le mieux chez moi.  Essaye de l'importer dans ta bécane.  attention de n'avoir qu'un seul fichier MATERIAL sur ta carte SD.  Il ne faut pas avoir deux fichiers avec les 8 premiers caractère pareil à ce que j'ai compris de la gestion 8.3.

Ainsi si tu as un MATERIALCOPY.txt et un MATERIAL.txt  la bécane est susceptible de prendre le MATERIALCOPY car elle ne se base que sur les 8 premiers caractère du nom de fichiers.

 

Ça marche !

Mais je ne comprends pas pourquoi !

J'ai donc effacé les données que tu avais mis mais j'ai gardé ton fichier.

A part le faite que tu avais une ligne vide entre chaque ligne je ne vois pas de différence avec mon fichier...

Merci a toi, je pense qu'il y a un bug qui sera surement corrigé un de ses 4.

Sylvain.

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Bonsoir,

Je viens de tomber sur ce bug de la mort, ce soir :angry:

Firmware Tinker_16.01 sur UM2 de 24 mois bientôt <3

2 heures pour comprendre, je vous la fais courte.

Pour mon cas, c'est un probleme de nombre de matière. Jusqu’à 16 types, tout va bien. A partir de 17 enregistrements lus/importés de la carte, il apparait en fin de liste une matière qui se nomme ÿÿÿÿÿÿÿÿ . A partir de là, rien ne va plus et au prochain redémarrage de la machine, il ne reste plus que PLA,ABS et CPE. Si j’efface un enregistrement du fichier MATERIAL.TXT et que je passe a 16, donc, tout rentre dans l'ordre après une nouvelle importation.

20161128_211216.thumb.jpg.8736a6925241ce7ac609f3b1e8779d12.jpg

20161128_211142.thumb.jpg.e434c0c08035289d7afdbbc8b8923033.jpg

20161128_211335.thumb.jpg.32dbec1b04b961ef314d5430afccdeee.jpg

Fred.

20161128_211216.thumb.jpg.8736a6925241ce7ac609f3b1e8779d12.jpg

20161128_211142.thumb.jpg.e434c0c08035289d7afdbbc8b8923033.jpg

20161128_211335.thumb.jpg.32dbec1b04b961ef314d5430afccdeee.jpg

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Je le sais, mais il ne parle pas la même langue que moi la-bas :)

Si un gentil membre peut, veut s'en charger ?

Je ferai une mise a jour ce soir pour voir si je reproduis ce bug avec la dernière version de Tinker.

Fred.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Pourquoi je perd toutes mes affaires !

Bonsoir,

Bon, j'ai fais un passage éclair en Tinker 16.08.2 puis très vite redescendu en 16.01 car trop catastrophique la dernière version et la gestion des matières. Du grand n'importe quoi. Impossible de modifier quelque chose sans que cela revienne aux trois matières basiques lors de la remise en route de mon UM2 (PLA, ABS et CPE).

En plus, il a été visiblement implanter de quoi différencier la température de la buse en fonction de son diamètre. C'est ridicule et bien inutile. Personnellement, je joue sur le FLOW et la vitesse, cela donne un meilleur résulta et évite de cramer le Teflon sur l'ABS.

Mais ce n'est que mon avis :)

Bref, avec la 16.01, on gère 16 paramètres de matière comme l'on veut, on s'en contentera.

Fred.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!