Jump to content
xperiment

Z-Achse fällt ab/ Z-Switch broken

Recommended Posts

Posted · Z-Achse fällt ab/ Z-Switch broken

Hallo, mein Problem hat damit angefangen das die Z-Achse während des Drucks einfach mal so 2-3cm abgefallen ist. Verbunden damit waren dann laute Klopfgeräusche aus dem Motorbereich zu hören.

Fehlermeldung "z-switch broken" kam dann natürlich auch.

Z-Switch ist aber vollständig in Ordnung und sauber. Hab dann versucht die Spannung des Z-Achsenmotors etwas zu justieren - auch ohne Erfolg.

Nun reagiert die Z-Achse überhaupt nicht mehr auf irgendwelche Eingaben aus dem Menü. Wenn ich einen Druck starten will, kommt nur noch die Fehlermeldung "z-switch broken".

Was meint ihr? Mainboard kaputt? Oder vielleicht einfach nur der Motor?

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Hi,

um welchen Drucker geht es? UM2 oder UMO? Und konntest du nachvollziehen warum/wo die Achse um 2-3cm abgesackt ist?

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Den "alten" UM2. Nein, warum die absackte konnt ich nicht rausfinden. Hab in einem engl. Forum gelesen das die Spannung evtl. zu wenig sein könnte. Aber daran lag es wohl auch nicht.

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Das Absacken ist normal wenn am Ende eines Druckes dein Heizbett nicht nach unten fährt (wenn du z.B. OctoPrint benutzt mit RepRap gcode Variante und deine eigenen start/end Skripte hast).

Die Fehlermeldung deutet aber darauf hin dass die Verbindung vom Switch zum Board unterbrochen ist. Du könntest die Board-Abdeckung abnehmen und das Kabel zurückverfolgen. Der z-switch ist ja ganz in der Nähe vom Board.

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Ne, das war während des Druckens. Normal ist das nicht ;-)

Firmware ist die originale von UM.

Abdeckung ist schon weg, Kabel auch schon kontrolliert. Müsste nochmal mit nem Voltmeter nachmessen ob auch Spannung drauf ist.

Was aber definitiv nicht vom Switch kam, sind diese lauten Klopfgeräusche von der Z-Achse. Hatte das Gefühl das mir die ganze Achse rausbricht, das war schon äußerst seltsam. Deutet aber auch wieder auf einen kaputten Motor hin.

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Was aber definitiv nicht vom Switch kam, sind diese lauten Klopfgeräusche von der Z-Achse. Hatte das Gefühl das mir die ganze Achse rausbricht, das war schon äußerst seltsam. Deutet aber auch wieder auf einen kaputten Motor hin.

 

Ich würde sagen das ist skipping für die Z-Achse. Kahm das auch mitten im Druck???

Klickt den der endstop noch wenn die Platte unten ist, bei mir hatte sich mal das Metallplättchen verbogen sodass die Plattform erst auf den Boden aufschlug, da kam auch das unschöne Geräusch :D

Ich würde wahrscheinlich dann so vorgehen (ohne Gewähr):

 

  1. Z-Endstop Anschluss mit X oder Y tauschen (am Board)

  2. Plattform von Hand hoch schieben

  3. Über Menü "Lower Buildplate" bestätigen, so jetzt wird es gefährlich, ca. in der Mitte den jeweiligen angeschlossen Endstop (X,Y) von Hand bestätigen (eigentlich 2 mal etwas versetzt drücken, da die Platte ja noch mal kurz angehoben wird und sich dann noch mal senkt)

    Wenn was unerwartetes passiert an besten mit der 3 Hand ;) den Drucker ausschalten

 

Wenn das erfolgreich ausgeführt wird, wird wahrscheinlich dein Z-Endstop kaputt sein!

Gruß Gerd

Share this post


Link to post
Share on other sites
Posted (edited) · Z-Achse fällt ab/ Z-Switch broken

Hallo Gerd, danke für die Antwort.

nachdem ich die Kabel für Y/X Stop getauscht hatte, passierte gar nix. Die Fehlermeldung bzgl. des Z-Switches kam sofort.

Bei einem korrekten Anschluss der Kabel dauert es allerdings erst so 3-4 Sekunden bis die Fehlermeldung erscheint.

...ich denk das ich mir auf gut Glück einen neuen Z-Switch kaufe. Wäre noch die preiswertere Variante gegenüber einem neuen Board.

Frage mich nur wie so ein Schalter kaputtgehen kann. Das ist nen Stecker, Kabel und ein Kontakt (der mechanisch noch einwandfrei funktioniert).

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Frage mich nur wie so ein Schalter kaputtgehen kann. Das ist nen Stecker, Kabel und ein Kontakt (der mechanisch noch einwandfrei funktioniert).

 

Den Schalter kann man auseinander ziehen, einfach mit einen messer zwischen den 2 Hälften gehen, dan sollte man bei solch einen Bauteil sehen ob was kaputt ist.

Was passiert wenn du den von Z in X oder Y steckst (nur stecken, ohne verfahren)??

Nach meiner Verständnis sollten alle 3 Schalter gleich sein!

Gruß Gerd

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Dann baue ich den mal auseinander. Stecker hab ich schon vertauscht - passiert nix, außer das die Fehlermeldung wieder sofort angezeigt wird.

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Ok, der Switch selber ist in Ordnung. Da sind ja nur Kontakte verbaut, die Mechanik ist einwandfrei. Kabel ist auch okay.

Habe jetzt mal den Motor der Y-Achse an die Z-Achse geklemmt - da reagiert die Z-Achse eiwandfrei. Also der Motor ist es auch nicht.

Bleibt ja nur noch das Board, oder?

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Hallo xperiment,

ich würde mal einen Factory-Reset machen. :)

Grüsse aus Bayern

Harry

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Ich hätte dir jetzt auch vorgeschlagen ein Factory-Reset zu machen.

Denn wenn ja ein defekter Endstop/Motor in der X oder Y Achse gesteckt wird, muss ja der Fehler auch mit wandern zu "X or Y Switch Broken" oder hattest du denn auch??

Aber, bei einen Factory-Reset muss auch wieder dieses "erst Inbetriebnahme" -Schritte ausgeführt werden und bei einen angeschlagenen Drucker (aus eigener Erfahrung) finde ich dies sehr bescheiden das man dies jedesmal machen muss. Wenn ein Fehler vorliegt wirst du dies nicht abschließen könne und kommst nicht mehr im Drucker Menü rein.

So nebenbei gab es bei meinen vor kurzen ausgeführten Factory-Reset auch gleich einen Crash, den es wurde erst die X, Y Achse Referenziert, dann wurde die Z-Achse hoch gefahren erst jetzt werden die ersten Punkt in X, Y angefahren (da hats gerumpts) für die Bett ausrichtung. Beim normalen Bett ausrichten werden alle Achsen (X, Y, Z) gleichzeitig auf den ersten Punkt gefahren)

Gruß Gerd

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Factory Reset half auch nix. Da ich jetzt nicht mehr in das Menü komme, habe ich Printrun verwendet um die Motoren zu testen. Z-Achse läuft 1a über einen anderen Motor.

...scheint das ich um ein neues Board nicht drum herum komme. :angry:

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Moin experiment,

kontaktiere mal den Markus Müller von "Plastikprint".

Wir hatten vor kurzem auch eines unserer UM2-Boards geschrottet und er konnte es reparieren.

Einen Versuch ist es immer wert. :-)

LG

Der Peter

Happy Printing

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Hallo experiment,

bei mir kam ich auch nicht mehr ins Menü, weil irgendwas nicht stimmt.

Später war sogar mein Display mal schwarz, aber irgendwie klappte es dann eine Firmware zu überspielen, danach Grundgestellt und alles funktionierte wieder.

Grüsse aus Bayern

Harry

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Ich weiß keinen Rat mehr @xperiment.

Ich kann mir noch vorstellen das vielleicht irgendein Pin verbogen ist oder sich raus geschoben hat, das hatte ich einmal bei den Temp Sensor da hat sich ein Pin etwas raus geschoben somit hatte ich ein Wackelkontakt!

Ob da jetzt das Board kaputt??? Sieht man irgendwas, Verfärbungen??

Gruß Gerd

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Ich hatte das Board mal in einer Werkstatt checken lassen, anscheinend ist das Board in Ordnung.

Daraufhin einen neuen Z-Switch bestellt, eingebaut - gleiches Ergebnis.

Da der Motor in Ordnung ist, der Z-Switch einwandfrei funktioniert kann es doch nur noch das Board sein. Scheinbar hat sich die Werkstatt doch getäuscht...oder kennt noch irgendjemand eine andere Fehlerquelle?

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Kannst du dir vorstellen mit der Firmware zu spielen/testen!

mann könnte z.B. die komplette Pin Belegung von X und Z (mit Endanschläge) mal tauschen! also dann wären die X Stecker für die Z-Achse und anders herum!

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Hm, wäre kein Problem. Der UM2 wurde jedoch davor auf Werkseinstellung gesetzt, d.h. ich kann ihn jetzt über die Firmware nicht mehr steuern.

Habe auch nochmal alle Schalter und Anschlüsse/Motoren getauscht...immer das gleiche Ergebnis. Werd mir wohl mal zum testen ein China-Board holen....

Share this post


Link to post
Share on other sites
Posted (edited) · Z-Achse fällt ab/ Z-Switch broken

Hallo @xperiment,

Ich hoffe es ist nicht zu spät, hier die geänderte Firmware (Tinker 16.03.1)

Marlin_Y_Z_PIN_vetauscht.hex

Habe die PIN Belegung von Y und Z getauscht (Motor und Endstop)

Also Stecker mit aufschrift Y ist jetzt Z, und anders herum!

Wenn jetzt die Z-Achse geht dafür deine Y-Achse nicht, ist ein defekt an dein Board vorhanden!

Zum flashen würde ich das alte Cura verwenden

Bin auf das Ergebnis gespannt

Gruß Gerd

Edited by Guest
verschrieben X in Y getauscht

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Wow, danke Gerd! Das hat mir sehr geholfen. Demnach ist das Board defekt. Mit der neuen Firmware und den vertauschten Kabeln, läuft die Z-Achse...aber die Y-Achse nicht (du hattest X-Achse geschrieben...war ein Versehen,oder?)

Share this post


Link to post
Share on other sites
Posted (edited) · Z-Achse fällt ab/ Z-Switch broken
(du hattest X-Achse geschrieben...war ein Versehen,oder?)

stimmt einmal habe ich mich verschrieben, habe es geändert!

 

Wow, danke Gerd! Das hat mir sehr geholfen. Demnach ist das Board defekt. Mit der neuen Firmware und den vertauschten Kabeln, läuft die Z-Achse...aber die Y-Achse nicht

Wir könnten noch ein versuch machen und auf den unbenutzten E2 Anschluss für den Z-Motor auszuweichen, muss es mir nur nochmal anschauen ob das möglich ist!

Wenn nur der Z-Motor Anschluss kaputt ist solltest du wieder drucken können, wenn der Endstop Anschluss kaputt ist gibt es leider keine Ausweichmöglichkeit!

Gruß Gerd

Edited by Guest

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Ok, das wäre ja phantastisch wenn Du die Firmware dahingehend ändern könntest! Vorab schonmal herzlichen Dank für deine Mühe!

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Bin gespannt, ganz sicher bin ich mir nicht!

Marlin_Z_E1_PIN_vetauscht.hex

X, Y Anschlüsse sind alle wieder normal

Z-Endstop auch normal in Z-Anschluss

und der Z-Motor in E2-Motor Anschluss

Gruß Gerd

INFO:

Beim Datei Name mit E1 ist gewollt den in der Firmware gibt es nur E0 und E1,

also E0 = Aufschrift E1; E1 = Aufschrift E2

  • Like 2

Share this post


Link to post
Share on other sites
Posted · Z-Achse fällt ab/ Z-Switch broken

Gerd, was soll ich sagen? Du hast meinen UM2 gerettet, es funktioniert!!

Dank deiner Hilfe hab ich echt ne Menge Geld für´s neue Board gespart!

Vielen, vielen Dank für deine Mühe :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!