Jump to content
Ultimaker Community of 3D Printing Experts
DevWolf

Cura causing skipped X and Y steps - identified specifically to Cura slicer

Recommended Posts

I've been in rapid prototyping on FDM for almost 7 years now and I've noticed something with Cura that none of the other slicers seen to cause.

Same print, same settings, across different slicers - something seems to be going on within Cura that's causing the X and Y skips, seemingly related to accelleration.

Before I start, I want to note that one of the issues identified was when you use a Sailfish machine with it. The fan code for Marlin is the "disable acceleration" (m127), so before going forward, to rule this out, ice changed it in the gcode to m126 (instead of the m127 T0 that cura tried to use), which enables acceleration in Sailfish. So firmware acceleration is turned on, and I have it turned down inside the firmware to settings that I know to work with my machine across any scenario I throw at it.

The problem seems to affect, speciffically, small circles and gap filling. The steppers jerk violently and rapidly in these areas and it causes skips. No other slicer displays this issue. I can even boost the speed in other slicers and still can't reproduce it. In Cura, I have to turn print down by nearly 50% to get any kind of security in leaving a Cura print by itself while it does it's thing.

Id like to bring this to the attention of the development department for in house testing to see if the problem can be tracked down. This has affected both Cura 1 and 2, through all builds so far. I've done some heavy research into the issue on forums and the like, and I see that even the UM2 machines do this. Now, you might be saying things like "lube the axis, fix that pulley, tighten the belts, driver current, z hop, etc, etc.." let me assure you that I know these issues well, and have learned the hard way over the past 7 years. None of the typical problems seem to cause it. I spent nearly a year now dealing with this nightmare and have yet to find a mechanical electrical issue as the culprate. I'm familiar with calipers on filament for the average, volumetric to temperature balancing, etc... And I can find nothing wrong with the settings I use, which have been changed to a wide range of differences and not solved the issue. I've done the same in slic3r, kiss, makerware, repitere host, and even mPrint from mBot. Cura is the only slicer that Can reproduce this issue.

Can someone please take a look at this?

Share this post


Link to post
Share on other sites

Post some pics about what you are on about, if it is the missed step issue causing ringing and weird patterns this has been noticed. I use a UM2 though and can leave my prints after 2 mins of baby sitting. I print small to medium sizes and don't really have any real issues. This stepper issue is my only one at the mo but that didn't even get changed with the UM3, so just curious to see if its the same thing as you? I've only been doing this for 3 years but am a perfectionist so study my prints very closely.

Edited by Guest

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • Our picks

    • Architect Contest | Entourage 01.
      Presenting an idea, an architectural design or something as big as an urban project isn't easy. A scaled models can really help to get your idea across. But besides your main model, there is more needed to get your idea across vividly! An architect regularly uses various entourage sets to help bring these ideas and models to live. 
        • Like
      • 9 replies
    • What The DfAM?
      I'm Steve Cox, an experienced engineer familiar with 3D printing. I wanted to share some DfAM guidelines with this community to help and make stronger parts.
      I'm also an Autodesk Certified Instructor for Fusion 360, so many of the images in ...
        • Thanks
        • Like
      • 17 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!