Jump to content
Ultimaker Community of 3D Printing Experts

New Printer doesnt see its bed size correctly


Recommended Posts

Posted · New Printer doesnt see its bed size correctly

Hi all.

I have just finished assembling a UM2 extended+ the machines inability to bed level is driving me nuts.

when the head moves to level the bed instead of moving to the limits of the bed it treats the bed like its a quarter of its size, when it moves to the second leveling position on the right it moves to the middle of the bed. and prints 25% of the size.

What am i doing wrong? ive set cura machine settings to the correct bed size, but if i cant level when i first switch on correctly what can i do?

ive searched everywhere for an answer i tried all day yesterday, but its findin the correct term to use in google all i can find when i search is people questioning the UM2's printable area!!

Thanks

Simon

  • Like 1
Link to post
Share on other sites
Posted · New Printer doesnt see its bed size correctly

There's a feature called microstepping and another feature called "steps/mm". One of those 2 things is off.

There *might* be a jumper to set the microstepping on the board. It's supposed to be set to 16 microsteps per step. steps/mm can be set either in the configuration.h file before building or alternatively if you have tinkermarlin you can set it on the front panel.

The Z axis *definitely* has a jumper to switch between 8 and 16 steps and it's near the center of the board and sometimes people connect their fan to it by mistake. It should be left open.

  • Link to post
    Share on other sites
    Posted · New Printer doesnt see its bed size correctly

    Hi thanks for the reply

    I tried adjusting the micro stepping via pronterface using gcode m350 command is that right? m350 x16 y16

    nothing changed.

    i still get the head moving to 50mm on xy axis when i hit the red target button in pronterface.

  • Link to post
    Share on other sites
    Posted · New Printer doesnt see its bed size correctly

    I don't know that board so I can't help you but even so I'm 90% sure that jennyPrinter board will only control microstepping with jumpers. Probably near those 5 stepper drivers. Marlin does support M350 but not for all stepper drivers. Definitely not for the stepper drivers that come with UMO, UM2, UM3. I didn't google 8825 though. But if it didn't do anything then it's not supported (but you might need capital letters so try that also M350, not m350).

    It's great that you have pronterface going! Instead/before homing you can move axes. So move one axis at a time.

    for example center all axes and then:

    G92 X0 (tell the printer X axis at now at position 0)

    G0 X10 (tell printer to move X axis to the right by 10mm.

    Then measure to see how far it moved. You can't update microstepping through marlin (I don't think - certainly not the marlin that comes with um2) but you should be able to set steps/mm through gcode M92. (not to be confused with G92 above).

    For example:

    M92 X80.1 sets the X axis to be 80.1 steps per mm.

  • Link to post
    Share on other sites
    Posted · New Printer doesnt see its bed size correctly

    Guys I have the same card, with the same configuration. I find myself with the same problem written above. How did you solve it? Thank you very much and happy 2019

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...