Jump to content

Cura Grayed out area with dual extrusion


NAK3D

Recommended Posts

Posted (edited) · Cura Grayed out area with dual extrusion

Hello,

I have a highly modified Da Vinci 2.0 that has been loaded with Repetier and has an E3D Chimera Extruder.  I liked the striped down version of Cura that comes with Repetier so I decided to download your full version 2.6.2.  Let me just say I had no idea how much better the full version was..  It has made a 200% improvement in my printing results, especially with my dual extrusion.

I have just one problem I can't seem to correct.

When I set up the dual extruders in my custom printer I set Extruder 2's X-offset to -18 (distance Chimera extruders are separated).  Unfortunately when I do this it blocks of 18mm on each side of my print area on the X axis as unprintable space..

My print area setting are as follows

X (width) = 210

Y (depth) = 210

Z (height) = 200

X min = 0

Y min = 0

X max = 240

Y max = 210

I have more than enough X-axis travel to print the full 210mm and am able to using Cura through Repetier but would most definitely prefer to do so with the full version.

Is there any way to keep Cura from blocking off that space?

Thank you for any assistance you can provide

Edited by Guest
  • Link to post
    Share on other sites

    • 2 weeks later...
    Posted · Cura Grayed out area with dual extrusion

    The reason that these areas are grayed out is that not both extruders can reach those areas. Sure, the left extruder can reach all the way to the left, and the right extruder can reach all the way to the right. But if you print a 2 material print, both extruders need to be able to reach the same areas.

    • Like 1
    Link to post
    Share on other sites

    • 3 months later...
    Posted · Cura Grayed out area with dual extrusion

    The reason that these areas are grayed out is that not both extruders can reach those areas. Sure, the left extruder can reach all the way to the left, and the right extruder can reach all the way to the right. But if you print a 2 material print, both extruders need to be able to reach the same areas.

    I understand the purpose of the grayed out areas but my problem is I have travel beyond the sides of the print bed so both nozzels are able to reachthe outer edges at any time.

    I'm still unable to get Cura to see that I have travel beyond the print bed and not blocking off usable space.

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion

    When your head moves to (0,0), does it move to outside the bed? In that case what you could do is tell Cura you have a wider bed than you do.

    The next step would be to tell Cura not to use the extra available width. Then the grey areas will fall within the extra width, and effectively you will have the full available width of your buildplate. But that all depends on where the (0,0) of your buildplate is.

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion

    When your head moves to (0,0), does it move to outside the bed? In that case what you could do is tell Cura you have a wider bed than you do.

    The next step would be to tell Cura not to use the extra available width. Then the grey areas will fall within the extra width, and effectively you will have the full available width of your buildplate. But that all depends on where the (0,0) of your buildplate is.

    Yes, My (0,0) is outside of the build area. I've figured out how to set the print area larger so I can use the entire print bed but how do I set Cura to not use the extra space? It would be nice to get it set so I don't accidentally print off the edge of the bed.

    Thanks

  • Link to post
    Share on other sites

    Posted (edited) · Cura Grayed out area with dual extrusion

    There is no way to edit the non-accessible areas of your bed in the UI, but you can do it by manually editing your configuration files.

    Go to Help -> Show configuration folder. In the folder that pops up, go to the folder named "definition_changes". In that folder there will be multiple *_settings.inst.cfg files, one named after your printer. Open that in a text editor (notepad will do, don't use word(pad)!).

    At the end of that file, add a line like this:

    machine_disallowed_areas = [
               [[-120, -105], [-105, -105], [-105, 105], [-120, 105]],
               [[105, -105], [120, -105], [120, 105], [105, 105]]
           ]
    

    This adds two polygons, one to the left of the bed, one to the right of the bed. In my example, I am assuming your "virtual" bed is 240 x 210 mm, and you want to cut off 15 mm on both sides.

    Update: values needed adjusting

    Edited by Guest
    Adjusted values
    • Thanks 1
    Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion
    On ‎11‎/‎30‎/‎2017 at 5:07 PM, ahoeben said:

    There is no way to edit the non-accessible areas of your bed in the UI, but you can do it by manually editing your configuration files.

    Go to Help -> Show configuration folder. In the folder that pops up, go to the folder named "definition_changes". In that folder there will be multiple *_settings.inst.cfg files, one named after your printer. Open that in a text editor (notepad will do, don't use word(pad)!).

    At the end of that file, add a line like this:

     

    
    machine_disallowed_areas = [
               [[-120, -105], [-105, -105], [-105, 105], [-120, 105]],
               [[105, -105], [120, -105], [120, 105], [105, 105]]
           ]
    
     

     

    This adds two polygons, one to the left of the bed, one to the right of the bed. In my example, I am assuming your "virtual" bed is 240 x 210 mm, and you want to cut off 15 mm on both sides.

    Update: values needed adjusting

    Sorry  it took so long to get back to post back (I've been having other issues with 3.1.0 and had to go back to 2.7.0).  Just had a chance to set this up and it appears to work.  I still want to try a few larger prints to be sure I'm centered good but at first glance it seems to be good.

     

    thanks for the help.

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion
    On ‎11‎/‎30‎/‎2017 at 5:07 PM, ahoeben said:

    There is no way to edit the non-accessible areas of your bed in the UI, but you can do it by manually editing your configuration files.

    Go to Help -> Show configuration folder. In the folder that pops up, go to the folder named "definition_changes". In that folder there will be multiple *_settings.inst.cfg files, one named after your printer. Open that in a text editor (notepad will do, don't use word(pad)!).

    At the end of that file, add a line like this:

     

    
    machine_disallowed_areas = [
               [[-120, -105], [-105, -105], [-105, 105], [-120, 105]],
               [[105, -105], [120, -105], [120, 105], [105, 105]]
           ]
    
     

     

    This adds two polygons, one to the left of the bed, one to the right of the bed. In my example, I am assuming your "virtual" bed is 240 x 210 mm, and you want to cut off 15 mm on both sides.

    Update: values needed adjusting

    ok, so after further testing it appears that I still have the same problem.  As this does block off unused space on each side, Cura still blocks off an additional 18mm for the distance between my two extruders.

     

    Also for future reference the polygons on each side are not equal size.  The left side would need to be just 4mm and the right side would be 26mm.

     

    In Repetier you have the ability to set the print bed size as well and X min/max and Y min/max and somehow those setting transfer to the version of Cura used in Repetier.  Anyone know how Repetier does this and if so can we make it work with Cura 2.7.0 or 3.1.0?

     

    Any other ideas?  

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion

    Hi,

     

    I found this variable: nozzle_offsetting_for_disallowed_areas in printer definitions - so If you want to print in grayed out areas, you have to add this line to printer definition file (C:\Program Files\Ultimaker Cura 3.3\resources\definitions\) under "metadata" section:

    "nozzle_offsetting_for_disallowed_areas" : false

     

    example:

    "metadata": {
            "author": "Ultimaker",
            "manufacturer": "Ultimaker B.V.",
            "quality_definition": "ultimaker2",
            "weight": 3,
            "file_formats": "text/x-gcode",
            "icon": "icon_ultimaker2.png",
            "platform": "ultimaker2go_platform.obj",
            "platform_texture": "Ultimaker2Gobackplate.png",
            "platform_offset": [0, 0, 0],
            "first_start_actions": [],
            "supported_actions":["UpgradeFirmware"],
            "has_materials": true,
            "has_machine_quality": true,
            "has_variants": true,
            "nozzle_offsetting_for_disallowed_areas" : false,
            "machine_extruder_trains":
            {
                "0": "ultimaker_2_go_dual_1",
                "1": "ultimaker_2_go_dual_2"
            }

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion

    Thanks, I'll give this a try..

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion

    Can't get any of these command lines to work as I'm running a Custom Printer.  which apparently works much different from the default models.

  • Link to post
    Share on other sites

    Posted · Cura Grayed out area with dual extrusion

    FOUND IT!

     

    I had the exact same problem you did here. Using a Qidi X Pro dual extruder setup, where either head can reach 100% of the print surface (i.e. the non-printing head is allowed to overhang the edge).

     

    If you go into 

    Program Files\Ultimaker Cura 5.1.0\share\cura\resources\definitions

     

    Then find the "custom.def" file and copy in the code above as so:

     

    {
        "version": 2,
        "name": "Custom FFF printer",
        "inherits": "fdmprinter",
        "metadata": {
            "visible": true,
            "author": "Ultimaker",
            "manufacturer": "Custom",
            "file_formats": "text/x-gcode",
            "has_materials": true,
    "nozzle_offsetting_for_disallowed_areas" : false,
            "machine_extruder_trains":

    ...etc

     

    Then the next time I opened cura the infernal grey-out was gone, despite extruder 2 being offset by -18mm.

     

    Haven't printed yet, but what I see in Cura matches what I see in the semi-custom Qidi slicer.

     

    I have no idea if/when/how this could be overwritten by updates or whatever, so best to store your own copy of that file (or the path back to it). I suspect one could create a whole printer profile in that directory and it'd skip the generic "custom" setup.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
         
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
      • Ultimaker Cura 5.6 stable released
        Cura now supports Method series printers!
         
        A year after the merger of Ultimaker and MakerBotQQ, we have unlocked the ability for users of our Method series printers to slice files using UltiMaker Cura. As of this release, users can find profiles for our Method and Method XL printers, as well as material profiles for ABS-R, ABS-CF, and RapidRinse. Meaning it’s now possible to use either Cura or the existing cloud-slicing software CloudPrint when printing with these printers or materials
        • 48 replies
    ×
    ×
    • Create New...