Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
niek

Print error with cura 13

Recommended Posts

Hi,

I created a stl file with inventor. Dimensions of the part: 40x40x8 mm.

Then I drove to the Fablab in Arnhem to print it.

Unfortunately the part was top heavy, so I tried to put it flat on the bed.

That was nearly impossible, but I suceeded in doing so.

Can you guys make a simple command to turn parts 90deg?

The display of the sliced part looked good (I have no idea about the meaning of the colors).

Anyway, printing was buggy from Cura ver 13 (I think it is the latest).

After a few slices, the ultimaker started to transpose the design.

I tried many different slice options, but printing failed always at the same moment.

Is there a bug involved or is the problem somewhere else?

I hope someone can answer it.

Cheers,

Nick

 

Share this post


Link to post
Share on other sites

>Can you guys make a simple command to turn parts 90deg?

The latest few versions of cura have this. There is a rotate icon, 3 rings appear around your part, pick the one to rotate by, then mouse drag until it says "90" (it prefers 90 over say 89 so it's easy to hit 90 perfectly).

>After a few slices, the ultimaker started to transpose the design.

Common problem. Do you have a picture? There are many causes. For example the part may have shifted on the bed in which case you need to get it to stick better by using isopropyl alcohol (wash the blue tape with ISA).

Or maybe the part did not shift on the bed in which case the "steppers slipped". Usually only in X or only in Y. Sometimes in both at once though - if both at once then there are bugs related to cura settings that you wouldn't think of such as joris - there's discussion about this recently. But finally we hit the most likely culprit:

Not tight enough set screws. You can test this by using a sharpie and put a little dot on all 6 pulleys (and shafts) that are used in the slipping axis (e.g. x pulleys if x axis slipped). Then after the slip the dots shouldn't line up. Tighten the hell out of the set screw for the slipping pulley. Or just tighten the hell out of all 6. Yes 6! Don't skip the 2 on the short belt (to the motor).

 

Share this post


Link to post
Share on other sites

Thanks,

I do not think it was a problem with slipping. The guy before me printed without a problem.

I printed it 5 times. On careful examination of the printed parts the errors are repeated in exactly the same manner - ie reproducible. That's leaves the software to be blamed.

The only difference between me and the previous guy's prints was that I rotated it so that it layed flat on the bottom and that I have a different step file. And no, rotation by clicking on the circles was not easy (I do not know why).

Assuming the step file to be correct (as judged by the views) leaves only the created gcode to be in error. I did not find software to check the gcode for errors. Perhaps you know something that runs in windows or linux?

This was my first experience with the ultimaker and not even a good one!

 

Share this post


Link to post
Share on other sites

Nick -

I think we can say with some certainty that there was nothing wrong with the gcode in and of itself. It's a very simple language, so almost certainly the gcode was a faithful representation of your model. So the fact that it failed means that one of two things happened - either there was something bizarre about the geometry of your model, or more likely, your settings were such that you were asking the printer to do something that was just beyond the bounds of its capabilities. If I had to guess, I'd say you probably had a non-printing x/y/z move that was faster than the printer could execute, resulting in skipped steps, which causes the printer to lose its place on the bed.

If you'd care to upload your gcode (or email it to me at gcode@fbrc8.com) I'd be happy to take a look and see if I see anything that might cause problems.

 

Share this post


Link to post
Share on other sites

And so do you ... :-)

For the benefit of those following along at home... the STL was fine, and it printed pretty well for me at 75mm/s with 0.09mm layer height. Nick didn't have a gcode file he could share, so it's hard to know exactly what was going wrong - but something about the settings he used was evidently pushing the printer out of its comfort zone.

 

Share this post


Link to post
Share on other sites

>I do not think it was a problem with slipping. The guy before me printed without a problem.

Well it's possible the problem is a firmware issue combined with cura but truly I still think it's a hardware issue.

It happens on the same spot every time because that is the spot with the most acceleration. If it skips x and y at the same moment then it's most likely the marlin issue but if only one axis then it's a hardware issue - again it can be a couple of things but the most likely two things are loose (ish) set screw on one of the 12 pulleys or the belt is lightly rubbing the plywood.

Or if both axis slipping same time then it's a known cura/marlin/settings issue but we need the gcode to see for sure.

But usually with a slightly loose setscrew, the slippage always happens the same spot. The spot with highest acceleration. But again, this is normally X axis or Y axis slippage only.

 

Share this post


Link to post
Share on other sites

BTW, sorry your experience with UM was frustrating. It's so much easier when it's in your house and can wait a few hours for a reply to your post about what to try to fix the issue.

 

Share this post


Link to post
Share on other sites

Not sure what you are asking. Cura tells the printer to go to point (10,10,1) and sometimes the printer doesn't do that. Usually it's a hardware problem which by now I'm lowering it to a 50% chance. And the other possibility is a firmware problem (the firmware may have tried an acceleration or speed that the stepppers just can't handle) which I'm raising to a 50% chance.

One workaround is for Cura to work around the Marlin (firmware) bug and only have it never move all 3 axis at the same time. Better would be for someone to find the Marlin bug. I don't think this new bug has been found yet. I've never experienced it. Most people have never experienced it. A few have.

Recently a bug was fixed in Marlin that caused the extruder to move slower than requested. That bug existed for a long time (always?). So now there are all these people out there who were requesting ridiculously fast extrusion speeds that the UM just can't do and were printing fine until they upgraded their Marlin. Now all 4 axis are moving too fast (Marlin keeps all 4 axis moving in such a way that the 4 axis travel in a straight line even through accelerations so any one of the 4 axis can limit the acceleration and speed on the other 3 axes).

So fixing a bug can cause other problems. Anyway in general Marlin is pretty solid and these things only pop up in certain rare situations. Thousands of people are printing thousands of parts every year without any problem. I still think the problem for your UM is very likely a slightly loose setscrew on one of the 6 pulleys on the slipping axis and your part had slightly higher shaking or acceleration at one spot in the gcode.

You still haven't said if it slipped in just X, just Y or both axes at the same moment. If just X or just Y then I would raise probability of hardware issue to 90%. If both at once than Marlin/gcode/cura issue to 90%.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Terms of Use Privacy Policy