Jump to content
Ultimaker Community of 3D Printing Experts
Heinerle

hotend only reads 0

Recommended Posts

hi there

im new to the 3 d printer world.

if i have a gcode file in ultimaker CURA v 3.1, i can see the part ect, all working ok

but wen i want to print the program tells me 

the Hotend is 0 because it is turnt off.

but how du i du that.

the printer is properly connected to the computer , i can move x y x 

if i copy to sd card and insert to printer all is well.

please help.

 

Share this post


Link to post
Share on other sites

Is this an Ultimaker 2?  I guess it must be.

 

Anyway if you want to print over USB (not recommended for tons of reasons but you can do it) then you have to go into cura and add a custom printer and set the gcodes to be in Marlin mode.  The "UM2" machine that comes with cura 3.1 only does um2 mode.  So you have to create a custom printer.

 

Or alternatively and much easier - get Cura 15.*, tell it you have a UM2 but then customize your machine to use reprap style gcodes.

 

The problem is that by default cura creates UM2 style gcodes (aka ultigcode) which works great for the SD card but through USB, your UM2 defaults to normal Marlin gcode mode.

Share this post


Link to post
Share on other sites
7 hours ago, gr5 said:

The "UM2" machine that comes with cura 3.1 only does um2 mode.  So you have to create a custom printer.

This is not true. At all. You can set the gcode flavor of an Ultimaker 2 printer to "Marlin" in Machine Settings, and it will not use Ultigcode. You do not have to create a custom printer.

Also Cura 3.1 tells the user about Ultigcode when they try to print over USB to a Ultimaker 2 printer, and since OP does not mention that, I doubt that he is indeed using an Ultimaker 2.

 

@Heinerle, if you press the "Print over USB" button in the lower right corner, the printer should start heating the bed (does your printer have a heated bed?) and then the extruders.

Edited by ahoeben
  • Thanks 1

Share this post


Link to post
Share on other sites
9 hours ago, ahoeben said:

This is not true. At all. You can set the gcode flavor of an Ultimaker 2 printer to "Marlin" in Machine Settings, and it will not use Ultigcode. You do not have to create a custom printer.

Also Cura 3.1 tells the user about Ultigcode when they try to print over USB to a Ultimaker 2 printer, and since OP does not mention that, I doubt that he is indeed using an Ultimaker 2.

 

@Heinerle, if you press the "Print over USB" button in the lower right corner, the printer should start heating the bed (does your printer have a heated bed?) and then the extruders.

Thank you for the replay, I got a Cocoon Create Modelmaker , No heat bed, single extruder.I press to start print over usb but still 0 Temp. will not heat ub.

ather functions will work, i can contoll manually x y z .

i tried all sorts of setting but all the same .

thanks for you help.

Share this post


Link to post
Share on other sites

Did you configure your printer without a heated build plate in Cura? If not, it may be waiting indefinitely until your non-existing heated bed reports it has heated up.

 

Can you do the following:

* load and slice a model

* start the print using "Print over USB" (Cura now switches to the monitor)

* wait a minute or so

Go to Help -> Show configuration folder

In the folder that opens, zip up everything. Please post that somewhere (dropbox, google drive, whatever floats your boat) and post a link here.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!