Jump to content
Ultimaker Community of 3D Printing Experts

Pause at Height


Alex74
 Share

Recommended Posts

Posted (edited) · Pause at Height

Bonjour à tous,

 

Pour reprendre le sujet "Probleme du plugin Pause at Heigh", avec l'avant dernier Cura (avant 3.4.0) ça ne fonctionne toujours pas ?

J'ai tenté de noyer un écrou dans une pièce pendant l'impression, et au moment où la pause s'effectue le plateau se décale en Z vers le haut ! Du coup la buse est venu écraser la pièce, le plateau qui saute, la tête qui sonne, le chaos...

 

J'ai donc coupé l'imprimante et manipulé le plateau et la tête à la main.

Je dirais que le script se trompe dans sa valeur de décalage, il monte le plateau au lieu de le descendre avant d'envoyer la tête aux coordonnées voulues.

 

Y a t'il un réglage à effectuer pour corriger ce bug ou faut-il modifier le g-code pour corriger la valeur directement ?

IMG_20180627_103003.jpg

Edited by Alex74
  • Link to post
    Share on other sites

    Posted · Pause at Height

    Par rapport à ton lien mon Gcode n'est pas exactement le même (ou alors c'est parce qu'il parle en mm et pas en layer), voilà se que j'ai pour la partie Pause At Height:

     

    ;TYPE:CUSTOM

    ;added code by post processing

    ;script: PauseAtHeight.py

    ;current layer: 45

    M83   Mode Relatif de l'extrudeur E --OK

    G1 F1500 E-6.5   Retract fil de 6.5 --OK

    G1 F300 Z10.04   Z du précédent lvl à 9.04 donc baisse le plateau d'1mm  --Je dirais OK pourtant le bug est là

    G1 F9000 X20 Y20   Park tête en 20;20 --OK

    G1 F300 Z15   Descente du plateau de quasi 5mm pour laisser accès à la pièce --OK

    M104 S205; standby temperature

    M0;Do the actual pause

    M109 S205; resume temperature

    G1 F1500 E6.5   Avance fil de 6.5 --OK mais inutile

    G1 F1500 E-6.5   Retract fil de 6.5 --OK mais inutile

    G1 F300 Z10.04   Retour du plateau à 1mm de la buse --OK

    G1 F9000 X112.273 Y101.938   Retour tête dans la zone de la pièce --OK mais je ne sais pas d'où sortent ces valeurs

    G1 F1500 E6.5   Avance fil de 6.5 --OK

    G1 F9000   Définie vitesse G1 à 9000mm/min ? --OK why not mais redéfinie à 3300 dans les lignes suivantes

    M82   Mode Absolue de l'extrudeur E --OK

    G92 E270.12533   Re-définie la dernière valeur absolue de E --OK

     

    Du coup je suis embêté parce que le Gcode m'a l'air valide, pourtant au Z10.04 le plateau remonte et écrase la pièce alors qu'il devrait descendre et dégager la pièce du coup... Je ne vois pas l'erreur, sauf si le M83 agit sur X,Y,Z et E à cause d'une mise à jour malheureuse.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...