Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  

When printing starts, the bed drops ~1,5cm on the Z-axis

Recommended Posts

Hi all,

I 've encountered a strange problem. Printing goes well, except with one STL. The size is 19.5cm*19.5cm and 5mm high. When Cura 13.06.4 sends the code to the printer and Ultimaker starts to print, the bed drops ~ 1,5cm. After that, the printing starts :mad:

It's confusing me, couldn't find a solution or a fix. What's wrong here?

Screenshot https://dl.dropboxusercontent.com/u/77853008/IMAG0246.jpg

STL-file https://dl.dropboxusercontent.com/u/77853008/2013-07-25-omtrekkopie.stl


Share this post

Link to post
Share on other sites

Can you @fbrc8.com'>email the gcode to me, and I'll take a look. The bed usually drops at the start of a print for the initial priming extrusion. I suspect that what is then happening is that it is failing to rise back up, because the initial move to the start point (which is the only one on the first layer that specifies a z coordinate) wants to take it off the edge of the bed, and so is ignored.


Share this post

Link to post
Share on other sites

19.5cm is fine as long as the brim or skirt or support doesn't go beyond 205 or so mm. Make sure these settings don't go beyond about 2mm on each side. You didn't answer if you have skirt or brim turned on and if so what settings those are at (what's the skirt distance or number of brim passes?)

I would probably use the brim feature to help hold down this part but only 4 passes to keep from hitting the limit switches. When printing the first layer I would put my ear near the limit switches and listen for that quiet "click".


Share this post

Link to post
Share on other sites

I looked at the gcode, and as I suspected, you're trying to print off the bed. While the part fits, the skirt looks to have quite a large offset that takes it off the bed.

The printer does its normal starting process, of dropping the bed 15mm, and pre-extruding a few mm. It then tries to move to the intended starting point for the skirt...



G0 F5400 X-1.25 Y2.41 Z0.30


G1 F1800 X2.41 Y-1.25 E0.12174

G1 X26.24 Y-1.25 E0.68210

G1 X28.54 Y-0.30 E0.74055

G1 X205.30 Y176.46 E6.61824

G1 X206.25 Y178.76 E6.67668

This tries to move to a negative x coordinate, so the whole move is ignored. This is the only line on the layer that sets the z coordinate, however. It will ignore the next few lines too, since they're off the bed as well, but then carry on with the ones it can print. But since the only line that set the height got ignored, all the printing happens with Z still at 15.

The solution is going to be to set a smaller offset for your skirt, so it still fits on the bed, or do without a skirt.

If you wanted the skirt for priming reasons, you could instead increase the extrusion amount in your starting gcode to something like:

G21 ;metric values

G90 ;absolute positioning

M107 ;start with the fan off

G28 X0 Y0 ;move X/Y to min endstops

G28 Z0 ;move Z to min endstops

G1 Z15.0 F{travel_speed} ;move the platform down 15mm

G92 E0 ;zero the extruded length

G1 F60 E6 ;extrude 6mm of feed stock

M1 P2000 ;pause 2s

G92 E0 ;zero the extruded length again

G1 F{travel_speed}

M117 Printing...



This extrudes more plastic at the start, at a slower rate, so as not to overwhelm the head, and then pauses a couple of seconds to give you time to grab some tweezers and clean the head if you want.


Share this post

Link to post
Share on other sites

There is a slight bug it looks like - which is that when you switch from Quickprint to Full Settings, it doesn't re-slice that model until you edit on of the settings. So it's still displaying the quickprint gcode (which includes a single pass skirt), while the displayed settings are whatever you had set up in the full mode.

If you click in any of the fields and change a value, you can prompt a re-slice, and then the skirt will go away (if that's how you have it set up in full settings).

I guess the point with the model coloring is that it's only taking into account the position of the model itself, not any skirt/raft etc.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • How to 3D print with reinforced engineering materials
      Ultimaker is hosting a webinar where we explain how you can achieve and maintain a high print success rate using these new reinforced engineering materials. Learn from Ultimaker's Product Manager of Materials and top chemical engineer Bart van As how you can take your 3D printing to that next level.
      • 2 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!