Jump to content
Ultimaker Community of 3D Printing Experts
Gambit

Cura 3.4.1 will not start

Recommended Posts

I just updated my cura software and now the program will not run. I get the splash screen and then it closes itself. I have tried uninstalling and reinstalling an older version that was working but that is also doing the same thing. What do I do? I need my cura!! 

Edited by Gambit

Share this post


Link to post
Share on other sites

To know what sort of bug this is, we would need to see a log file. See some instructions here: https://github.com/Ultimaker/Cura#logging-issues

The "Cura GUI log file" is the important one for this particular issue.

 

If you need to get Cura started no matter what, a surefire way to do that is to delete the configuration folder that this log file is located in. This resets Cura to factory defaults, so you'll lose all your preferences and profiles and such. But it probably resolves your issue. And it would be nice if you could copy the log file out for us so that we can see what the problem was and fix it for the next time ?

Share this post


Link to post
Share on other sites

Not working for me either.

High Sierra 10.13.5

 

The icon appears but does not open the application..

If open the app via temrinal /Applications/Ultimaker Cura.app/Contents/MacOS/cura can open it.

Share this post


Link to post
Share on other sites
18 hours ago, Gambit said:

I would be happy to post the log file. Can you tell me where to find it or what the name of it would be?

See ghostkeeper's response two posts up for a link with info on the log file.

Share this post


Link to post
Share on other sites

Hi Folks,

Here is the path to cura config files in the c disk.

C://users/"your name"/AppData/Local/

Roll down until you see cura.

Copy all those files and delete those files in this directory.


Thanks


Regards


Torgeir

 

image.thumb.png.1eae8c83312665f65ad504076df3b1c1.png

Edited by Torgeir
Editing wording.

Share this post


Link to post
Share on other sites

Ok, here is the log file and my operating system information. I tried doing what Torgeir suggested and deleted the config files but that did not change anything. I still get the splash screen and then the user agreement then Cura closes.

 

Anything else i can share to help please let me know. 

image.png

cura.log

Share this post


Link to post
Share on other sites

I tried that. I even did a compleat windows recovery erasing all programs and data. I still getting the same thing. I’m pretty sure it’s some incapatability with windows 10 but I have no idea. 

Share this post


Link to post
Share on other sites

Hi Gambit,

 

Did you check that the "other directory", the one provided by @ghostkeeper, the directory under "roaming" containing another cura directory?

This one: C:\Users\\<your username>\AppData\Roaming\cura\<Cura version>\cura.log (?)

 

Thanks

 

Regards

 

Torgeir.

 

 

 

 

Share this post


Link to post
Share on other sites

Looking at the log file again. I fixed a broken colour that I found because of that log, so thanks already ?

 

So in the log it appears to be crashing right after it initializes the shaders and right before or during initialization of the main window. The most likely culprit is these lines:

2018-07-22 05:06:55,824 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Topbar.qml:19: TypeError: Cannot read property 'stageId' of null
2018-07-22 05:06:55,826 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Topbar.qml:104: TypeError: Cannot read property 'stageId' of null
2018-07-22 05:06:55,829 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Topbar.qml:175: TypeError: Cannot read property 'stageId' of null
2018-07-22 05:06:55,831 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Cura.qml:433: TypeError: Cannot read property 'mainComponent' of null
2018-07-22 05:06:55,834 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Cura.qml:427: TypeError: Cannot read property 'mainComponent' of null
2018-07-22 05:06:55,836 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Cura.qml:465: TypeError: Cannot read property 'sidebarComponent' of null
2018-07-22 05:06:55,839 - WARNING - [MainThread] UM.Qt.QtApplication.__onQmlWarning [301]: file:///C:/Program Files/Ultimaker Cura 3.4/resources/qml/Cura.qml:497: TypeError: Cannot read property 'sidebarComponent' of null

From this it appears that `activeStage` is null at that time which is weird to me. Also strange is this line:

2018-07-22 05:06:37,560 - INFO - [MainThread] UM.VersionUpgradeManager._getUpgradeTasks [272]: Config file [.\cura.cfg] is of version [6000000], which is different from the defined version [2000000], no upgrade task for it from type [preferences].

There it looks like someone mixed up two of the version numbers that we have in Cura.

Share this post


Link to post
Share on other sites

I too experience problem starting Cura 3.4.1 on Win 7 pro 64bits. It does start but it takes a few minutes. Once it's up it looks normal. Just takes a long time to load everything I guess. Also I did the installation on a SSD drive, so it should not take so long to load.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Introducing Ultimaker Cura 3.6 | Beta
      Ultimaker Cura 3.6 | Beta is available. It comes with new features, bug fixes, and UX improvements. We would really like to have your feedback on it to make our stable release as good as it can be. As always, you can download the beta for free from our website, for Windows, MacOS, and Linux.
        • Like
      • 91 replies
    • Print Core CC | Red for Ruby
      Q: For some users, abrasive materials may be a new subject matter. Can you explain what it is that makes a material abrasive when you are not sure which print core to use?
      A: Materials which are hard in a solid piece (like metals, ceramics and carbon fibers) will generally also wear down the nozzle. In general one should assume...
        • Like
      • 30 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!