Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Hello,

I'm on ubuntu 18.04. Have got Cura 3.3.1-PPA and the appimage of 3.4.1.

Tried to install the FreeCAD-Plugin, but couldn't get it. The appimage does not provide any plugin menu item, the PPA version has got a "Plugins" menu, item, but this only offers "browse plugins", where I cannot find the FC plugin.

I copied the plugin file (CuraFreeCADPlugin-0.1.1.curaplugin) to ~/.local/share/cura/plugins and made it executable, but still no FC-files are visible.

 

@thopiekar - could you give me a hint?

 

Cheers,

Wolf

 

Share this post


Link to post
Share on other sites

Does the AppImage have a Toolbox menu? In 3.4, the plugin browser was renamed to Toolbox.

 

The curaplugin file should be compatible with Cura 3.3 (the PPA), but you are using it in the wrong way. Remove it from the local/share/cura/plugins folder, and instead drag and drop it in the Cuar window. It will then be extracted to the correct folder. Note that this will not work with Cura 3.4, because that requires a .curapackage file.

 

Finally, realise that freeCAD needs to be installed as well as the plugin.

  • Thanks 1

Share this post


Link to post
Share on other sites

Thank you for your time.

1. FC is installed (0.18)

2. At cura 3.4 I've got a "toolbox" menu. In the window it opens, I find a "menu" entry,but this is grayed out and will not open.

3. At cura 3.3.1, I tried the plugin installation as mentioned above. Cura says "installed properly" - I can now choose FC files  but they are not installed. See error log (from terminal) attached.

 

HTH, Cheers,

Wolf

 

 

 

Bildschirmfoto von 2018-07-26 20-55-36.png

Fehler-cura.log

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 19 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!