Jump to content
Ultimaker Community of 3D Printing Experts

Vase mode artifacts


Recommended Posts

Posted · Vase mode artifacts

I'm having a problem when generating a gcode in vase mode of a model in which multiple planes meet in one point.

Cura 3.4.1 generates artifacts coming out from the vertices where the planes meet.

 

Is there any way to resolve that?

 

Thank you!

vaseMode.png

PART.stl

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    Hi @Samon, thanks for the project. Yes, I can see there's a problem in that region but I don't know what's causing it. If you turn off the spiralize smoothing and make the wall lines really thin you can see that there is a region where the wall doubles back on itself. As far as I can tell that's not in the original model so it's being caused by Cura. I shall try to find out what's happening.

     

    Screenshot_2018-07-31_14-56-33.thumb.png.92757f19642f958a13956fa202235258.png

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

     

    2 minutes ago, smartavionics said:

    As far as I can tell that's not in the original model

     

    You're right, it's parametric design consisting only of surfaces (triangles) built on points, there's no double walls whatsoever.

     

    Thank you for your help ?

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    Hi @Samon, I haven't actually printed the vase but I am fairly sure that the flaws that you see are just in the Cura layer view and not actually in the gcode. The Cura layer view doesn't really understand spiralized prints and the display has some problems and I think that is what you are seeing. I looked at the gcode using a couple of other viewers and couldn't see any problems. If you print it and it really does have any missing or extra line segments, please let me know. Cheers.

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    I can see these weird lines in Cura, S3D and Repetier.

     

    I will print it and send the results ?

    artifacts.png

    CCR10_hex.gcode

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    Now this is crazy.

     

    First of all the mentioned artifacts are present and highly visible on the print.

    Whats more the whole thing is wavy, and for sure that's not the printers fault because I have tried to print it previously with S3D.

     

    (White - sliced with Cura, black - S3D)

     

    Help ? ?

     

    CCR10_hex.curaproject.3mf

    WhatsApp Image 2018-07-31 at 20.36.42.jpeg

    WhatsApp Image 2018-07-31 at 20.43.36.jpeg

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    Oh, you mean, those lines! Turn off the smooth spiralized contours option and they should go away.

     

    With smoothing option enabled:

     

    Screenshot_2018-07-31_20-10-00.thumb.png.eb357a663cee7734f7bd632cda2e4215.png

     

    Without smoothing option enabled:

     

    Screenshot_2018-07-31_20-10-15.thumb.png.8d43ec81d87e154e4478b12f9fb5afa9.png

     

    The smoothing option is intended to be used when the vertical profile does not have sharp edges. It's effective at hiding the z-seam when the object is basically smooth but it can introduce artifacts like you see in this example.

     

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    The problem still occurs but in different places now... ?

     

    Is there any hope?

    artifact.png

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    The only thing that "gets it right" is Surface mode of "Surface".

    But then the extruder then has many backward travels, which to me is against the idea of "vase mode".

    I don't think I understand the differences in Surface mode modes. 

    Could someone explain it to me please?

    I'm desperate to embrace Cura ?

    question.png

  • Link to post
    Share on other sites
    Posted · Vase mode artifacts

    Ignore any glitches you see in the cura layer view, like I said above, it doesn't really work well for spiral mode.

     

    As for the wonky gcode lines in your s3d image, I found that setting the cura slicing tolerance to "exclusive" helped reduce the wonkiness! You might also want to play with the Maximum Resolution setting.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...