Jump to content
pman

CURA auto bed level BEFORE heating extruder MACosx

Recommended Posts

Posted · CURA auto bed level BEFORE heating extruder MACosx

hi! this has been answered before but i cannot seem to find where the input area is for MACOSX. If i enter the code into Machine settings area "start g-code" the machine STILL overrides and start heating the extruder. I dont want it to heat the extruder first, but rather start the AUTO LEVEL BED and then heat up extruder afterward. Could someone please shed some light on this?

 

thank you!

Screen Shot 2018-11-29 at 6.37.10 pm.png

Share this post


Link to post
Share on other sites
Posted · CURA auto bed level BEFORE heating extruder MACosx

The settings page should be the same on Windows and MacOS and I can remember that there was a thread some days ago about this topic. So check the search function if you find the thread.

 

Besides that, I personally don't think it is a good idea to manipulate the start sequence, because there is a reason why Ultimaker heats up the extruder before the auto leveling. I think I have read that the nozzle needs to be heated that the measurement is accurate enough.

Share this post


Link to post
Share on other sites
Posted (edited) · CURA auto bed level BEFORE heating extruder MACosx

If you dont put your own M104 S0  M140 S0 right after the G28, cura will will insert them at 1st layer temps.

You will need to put the M104 M140 later in the start codes else cura will not heat the bed/extruder.

 

Edited by obewan

Share this post


Link to post
Share on other sites
Posted · CURA auto bed level BEFORE heating extruder MACosx

thanks guys,

 

i got it working with this and seems to be working as i need it to.

 

code taken from all over

 

G28 ; home all axes

G29 ; Auto Bed Level

G28 ; home all axes

M104 S{material_print_temperature} ;Start heating extruder

M140 S{material_bed_temp_wait} ;Start heating bed

M109 S{material_print_temperature} ;Wait for extruder to reach temp before proceeding

M190 S{material_bed_temp_wait} ;Wait for bed to reach temp before proceeding

M117 Purge Extruder ; Shows "Purge Extruder" on the screen

G92 E0 ; reset extruder

G1 Z1.0 F3000 ; move z up to prevent scratching of surface

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position

G1 X0.1 Y180.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X0.4 Y180.0 Z0.3 F5000.0 ; move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

G1 E27 F5000 ; retract filament 5mm

G92 E0 ; reset extruder

M117 Done Purging Extruder ; Shows "Done Purging Extruder" on the screen

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

M117 Now Printing... ; Shows "Now Printing" on the screen

Share this post


Link to post
Share on other sites
Posted · CURA auto bed level BEFORE heating extruder MACosx

I can't make this code work on an S5 with 4.3.0, no matter what the start GCODE says, apparently the firmware is inserting the bed and nozzle heating commands as well as the leveling command prior to the start up GCODE.  I want to use Geckotek EZstick hot as a printing surface however, am experiencing the same problems noted in other posts with the hot nozzles boring holes in the materials and the prints failing with nozzle probes.  Is there some way to start cold with an auto bed level and then heat the bed and nozzles?  I tried changing the z offset but the holes still get bored.  Thanks.

Share this post


Link to post
Share on other sites
Posted · CURA auto bed level BEFORE heating extruder MACosx

Seems like the placeholder names have all changed again .

http://files.fieldofview.com/cura/Replacement_Patterns.html

 

try something like

 

M104 S{default_material_print_temperature} ;heat nozzle to default temp set in material settings

 

M140 S{default_material_bed_temperature} ;Start heating bed

 

M190 S{material_bed_temperature_layer_0} ;Wait for bed to reach temp before proceeding

 

M109 S{material_print_temperature_layer_0} ;Wait for extruder to reach temp before proceeding

 

Share this post


Link to post
Share on other sites
Posted · CURA auto bed level BEFORE heating extruder MACosx

Thanks for the thought.  Unfortunately, it doesn't work.  Tried with the G28 and G29 commands inbetween the first two, and preceding the first two.  Printer still brings print head to the front center and begins heating the bed.  Frustrated.  Any other suggestions most welcome.

Share this post


Link to post
Share on other sites
Posted · CURA auto bed level BEFORE heating extruder MACosx
On 10/29/2019 at 12:46 AM, Geep said:

I can't make this code work on an S5 with 4.3.0, no matter what the start GCODE says, apparently the firmware is inserting the bed and nozzle heating commands as well as the leveling command prior to the start up GCODE.

 

There you have your answer...

On the S5 the start procedure is build into the firmware. You can't disable or change it with gcode.

Therefore you can't use those "soft" printing surfaces on the S5. Adhesion sheets from Ultimaker can be used, PEI sheets too, but nothing that can not withstand the nozzle heat.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!