Jump to content
Ultimaker Community of 3D Printing Experts

Speed test vase-mode (ChangeAtZ question)


Zbyszko
 Share

Recommended Posts

Posted · Speed test vase-mode (ChangeAtZ question)

I'm trying to print a "speed tower" in vase mode.  Want to adjust the print speed up every 5mm of the tower.  I used Cura's ChangeAtZ post-processing plug-in to change the print speed.  Unfortunately it has no effect and I suspect this is due to the fact that wall speed is a multiple of print speed.  Any way to work around this so I can print my tower?  Is there a way to change the print speed to wall print speed multiplier from 0.5 to 1 somewhere?  Thanks!

  • Link to post
    Share on other sites

    Posted · Speed test vase-mode (ChangeAtZ question)

    First of all realize that there is a minimum layer time feature.  I think it defaults maybe to 5 seconds per layer so that may be restricting the speed.  You can turn that feature off.  This keeps the quality up because it looks all melty if you don't let the previous layer cool a little.

     

    Cura has gotten complicated.  There are about 8 printing speeds.  I would try a few things:

    1) Try setting most of them to 0.  In the old cura (15.X.X) if you set the speed to 0 it would just not set the speed at all. 

    2) Open the gcode file in a text editor.  It's quite easy to look at.  Look for "F" commands.  Those set the speed in mm/minute (60X larger than mm/sec).  Note that anytime it does a non printing move it has to change the speed.  Note that anytime it does a retraction it has to change the speed (extruder speed is different from XY axis speed).  So you may have to disable all retractions and set the non-printing moves to speed 0 or to the same speed as the printing speed?  Not sure.  Hopefully in vase mode there are none of these.

     

  • Link to post
    Share on other sites

    Posted · Speed test vase-mode (ChangeAtZ question)

    Doesn't ChangeZ alter the feedrate factor instead of the "speed" itself? So it affects all the "speed" with a ratio. 

    Could you look at if the output gcode has M220 in it? 

    If there is, please check if your firmware has M220 support.

     

  • Link to post
    Share on other sites

    Posted (edited) · Speed test vase-mode (ChangeAtZ question)
    On 2/17/2019 at 8:58 AM, alexjx said:
    On 2/16/2019 at 9:19 AM, gr5 said:

    First of all realize that there is a minimum layer time feature.  I think it defaults maybe to 5 seconds per layer so that may be restricting the speed.  You can turn that feature off.  This keeps the quality up because it looks all melty if you don't let the previous layer cool a little.

     

    Cura has gotten complicated.  There are about 8 printing speeds.  I would try a few things:

    1) Try setting most of them to 0.  In the old cura (15.X.X) if you set the speed to 0 it would just not set the speed at all. 

    2) Open the gcode file in a text editor.  It's quite easy to look at.  Look for "F" commands.  Those set the speed in mm/minute (60X larger than mm/sec).  Note that anytime it does a non printing move it has to change the speed.  Note that anytime it does a retraction it has to change the speed (extruder speed is different from XY axis speed).  So you may have to disable all retractions and set the non-printing moves to speed 0 or to the same speed as the printing speed?  Not sure.  Hopefully in vase mode there are none of these.

     

     

    Thanks for taking the time to reply.  I did have min layer time turned to 0.  I did check the F commands and all layers were the same.  No retractions since printing in vase mode.  

     

    Quote
    On 2/17/2019 at 8:58 AM, alexjx said:

    Doesn't ChangeZ alter the feedrate factor instead of the "speed" itself? So it affects all the "speed" with a ratio. 

    Could you look at if the output gcode has M220 in it? 

    If there is, please check if your firmware has M220 support.

     

     

     

     

    You are correct.  Firmware is Repetier 1.0x which I believe does have M220 support.  I did try printing the square tower using manual feedrate control on the printer itself which worked but I learned that the printer doesn't like to take corners at a high speed (they show significant degradation beyond 40mm/s) so for this test I think I need to switch to a cylinder tower.

     

    Still would like to know how to do this automatically if anyone has any other input.  Much thanks!

    Edited by Zbyszko
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...