Jump to content
Ultimaker Community of 3D Printing Experts

Changing G-code flavor not taking effect


smsusi
 Share

Recommended Posts

Posted · Changing G-code flavor not taking effect

Hello,

 

I have been trying to change the G-code flavor from Marlin to Mach3. I tried changing this from the machine settings for a custom sized FFF printer and restarted Cura. However, when I check the output G-code file, the G-code flavour still shows as Marlin! I have checked the Printer machine settings several times and am sure that it is set to Mach 3.

 

Am I missing something, maybe in the print settings? We are doing Wire Arc additive manufacturing using Kuka and it needs the Mach 3 g-code instructions. (There should be no G0's like in Marlin)

 

  • Link to post
    Share on other sites

    Posted · Changing G-code flavor not taking effect

    Hi @smsusi. Until recently, there was a regression in Cura whereby the mach3 option was being ignored (which you have found!) A fix has been submitted to the Cura devs and I should think that it will be in the 4.1 release. In the meantime, if you are using either Linux or Windows (sorry, not OS X), you can try one of my releases that already incorporate the fix. I don't know how well the Mach3 flavour works as I don't think it sees a lot of attention so when you get to try it out, if you find any issues, please report them.

     

    You can find my releases at https://www.dropbox.com/sh/s43vqzmi4d2bqe2/AAADdYdSu9iwcKa0Knqgurm4a?dl=0

     

    They do not conflict with the Ultimaker releases.

  • Link to post
    Share on other sites

    Posted · Changing G-code flavor not taking effect

    Hello,

    Are the G0's the only difference between the two flavors

     

    If it's the case, try to do a PostProcessing Plug in to change all the G0's in G1 ?

     

    In case I can do it if you want

  • Link to post
    Share on other sites

    Posted · Changing G-code flavor not taking effect

    Thanks a lot, @smartavionics, I tried one of the recent release from you and it works! The output is now in Mach 3.

     

    Thanks, @JCD. We are postprocessing the output files...yes, that's the only change needed right now.

     

    Thank you again.

     

     

     

  • Link to post
    Share on other sites

    Posted · Changing G-code flavor not taking effect

    Happy that smartavionics already did the trick 👍

  • Link to post
    Share on other sites

    Posted · Changing G-code flavor not taking effect

    Thanks again, I will try this too.

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...