Jump to content
Ultimaker Community of 3D Printing Experts

Importing useable files


Recommended Posts

Posted · Importing useable files

I have the odd experience of wanting to load an .stl or .obj file into Cura. I download on my PC. I can find the file with the PC file explorer, but when I

use the Cura load file command the imported .stl or obj file is not there. Anybody know what is going on?

  • Link to post
    Share on other sites

    Posted · Importing useable files

    Hi,

     

    If you find the file with the PC file explorer, can you open it in Cura by double-clicking the .stl file?

    If yes, is it inside a .zip-file?

    For opening in Cura (except opening by double-click) you must unzip the file first.

     

    Greetings

  • Link to post
    Share on other sites

    Posted · Importing useable files

    It is unzipped. I can see the files and exactly where they are with the PC explorer. Once I am in the CURA application and use Open file,

    I can navigate to the same location, but the files are not there.

  • Link to post
    Share on other sites

    Posted · Importing useable files

    Unzipped is ok, Cura must find the files then.

    I only can imagine, that the filter (the drop-down-menu right of the filename field, just above the two buttons "open" and "cancel") is set incorrect. It should read "All Supported Types" or "All Files" or the specific file-type you are using (e.g. "STL-File").

    If the files are still not shown, I'm at my wit's end for now. Possibly a scrrenshot could help.

     

     

  • Link to post
    Share on other sites

    Posted (edited) · Importing useable files

    I find it strange. I have been trying to open the files where they are found in the explorer and they don't respond to open or open with new application and as we already know they are not even seen with the CURA open file. I have some idea that something might be wrong with the download itself because when I close everything and return to a window explorer the recently download files, the extracted zip files, etc. are all missing. I have to go back to the online source to download them all over again.

     

    The open file is set to the open all supported files. I even have the option of seeing "all files" and none of what I want to see is ever there.

    Edited by Frontsight
  • Link to post
    Share on other sites

    Posted · Importing useable files

    Most likely this is a case of two directories having the same name, but sitting in a different location? So Windows Explorer sees one directory, and Cura the other? For example a file downloaded to the folder "downloads" of user Jeff, and Cura searching in the "downloads" folder of user John?

     

    Try using old "known-good" files you made yourself. Then try moving the unwilling files to a known-good location, like the desktop, or your own "downloads" or "documents" folder.

     

    But occasionally, Windows relocates files behind your back (without telling you) to another directory if you tried to save them in a protected directory. This could happen if you save them to the "c:\" or to "c:\program files\" directory. Windows explorer remembers that it has done this, so it "finds" these files when you search in the original location where you thought you had saved them in. But other programs might not know this. This has to do with sytem protection I believe, although the exact "reasoning" of Windows is not clear to me. But I have run into it a couple of times on Windows 7 in the beginning. Unfortunately, I don't remember the name of the directory it moved them to (it was very weird), so you will have to google for it.

     

    Then there can also be "redirection policies" active, which also move things around behind your back. This is especially in business environments. But I don't know the details of it.

     

    Also, make sure the files have no "hidden", "system" or "read-only" attributes set. And make sure the filenames only contain standard ASCII-characters: letters, numbers, underscores. No exotic characters. And no dots, dashes or other special characters as first character, because this might make a file invisible or uneditable. If you are not sure, manually rename the files and type a whole new name.

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...