Jump to content
Ultimaker Community of 3D Printing Experts
Sign in to follow this  
jet

New printer wont print

Recommended Posts

So Ive just finished assembling my ultimaker,

attempting my first prints and i cant get anything other than thin wispy bits of plastic everywhere, to me it seems like the extruder is turning nowhere near enough, I have installed the latest marlin firmware and am just using the defaults on SkeinPyPy, whats wrong?

Share this post


Link to post
Share on other sites

Hi Jet, we have similar vintage machines, mine is 4. days old

In Printrun, press the check temperature button. Make sure this is correct before attempting to extrude with the material feeder.

.

Assuming you are using PLA, anything above 220 should be a good point to start.

With the material feeder did-engaged, push the filament into the tube manually. Get a feel for this, you do not go mad! Eventually when the tube is full of filament and it has melted, you will be able to push threads out of the nozzle.

Then try the material feed mechanism by pursing extrude in printrun interface.

Take your time, get it right!

Good luck,

Dave.

Share this post


Link to post
Share on other sites

Thanks Dave

I actually allready had a play with the settings, I just set up exactly the same print in skeinforge just with defaults, and it works perfectly.

When i use SkeinPYPY and printrun, the extruder just turns much much slower, like 1/100th of its speed when using repg, Im thinking it might be an issue

with the microstepping setting?

Also ITS SO COOL TO WATCH

Share this post


Link to post
Share on other sites

Jet-yes I haven't got over the hypnotic stage yet!

I actually used default everything, did not change, parameters or microstepping jumpers. just temperature. So not sure why it is different for you. Maybe Daid will jump in here...

Not at the machine at the moment but will check versions for comparison later.

Share this post


Link to post
Share on other sites

Have you tried printing out my cube? It should start by homing to a corner, then it prints out 2 outlines (to make sure the PLA sticks to the bed and to get the flow going) and after it should start printing. Its optimized for the ultimaker.

http://pastebin.com/76LRgybW

If this will still cause problems, try to manual feed the machine, see if the PLA goes out of the nozzle. If that doesnt work, its certainly something with the heat or feed.

Share this post


Link to post
Share on other sites

Which version of SkeinPyPy did you use?

And where did you install Marlin from? From my builder?

Also, something to test is, open printrun, connect, heat up to 230C, and extrude 5mm of filament. This should give a good amount of extrusion from the printer head, something like 7cm or so.

Share this post


Link to post
Share on other sites

Ok so, ill just clarify my problem

got skein pypy from here

https://github.com/daid/SkeinPyPy/downloads

then updated to the newest version or marlin that appeared in skeinforge (I just followed the tutorial here

http://wiki.ultimaker.com/How_to_upload ... otherboard

)

then just sliced in skeinpypy and printed with printrun, but the extruder extrudrudes FAR too little material

When i then tried slicing using repg and the built in slicer (i assume that the slicer is actually skeinforge?) then printing strait from there, it works fine

Share this post


Link to post
Share on other sites

It could be this issue: viewtopic.php?p=1186#p1186

I ran into that problem yesterday, but inversed. It extruded like a formula GP engine. :)

So try to add M92 E865.888 in the header of the G-code.

Or make a file with only the following inside and load it as a G-code file and hit print:

 

M92 E865.888M500

 

That will store the setting in eeprom so you don't need do add that in every file.

M92 E865.888 with SF40 and newer.

M92 E14 with Netfabb and SF35.

Share this post


Link to post
Share on other sites
It could be this issue: viewtopic.php?p=1186#p1186

I ran into that problem yesterday, but inversed. It extruded like a formula GP engine. :)

So try to add M92 E865.888 in the header of the G-code.

Or make a file with only the following inside and load it as a G-code file and hit print:

 

M92 E865.888M500

 

That will store the setting in eeprom so you don't need do add that in every file.

M92 E865.888 with SF40 and newer.

M92 E14 with Netfabb and SF35.

I doubt this is the same issue because I used everything from Daid's SkeinPyPy build (including Printrun, Marlin and Skeinforge) and it all worked out of the wrapper with stock Ultimaker hardware. Let me re-iterate: I used everything from Daid's build with no modification, no parameter changes, no M code changes. If Jet does the same, it should work just fine.

Share this post


Link to post
Share on other sites
I doubt this is the same issue because I used everything from Daid's SkeinPyPy build (including Printrun, Marlin and Skeinforge)

SkeinPyPy doesn't come with Marlin. So that would be impossible. But SkeinPyPy should work out of the box with the marlin from my build tool.

The Marlin from Ultimaker does not work correctly with SkeinPyPy Beta2. It might work with Alpha4. (You still didn't say which version of SkeinPyPy you used, Alpha4 or Beta2?)

The version from:

http://daid.eu/~daid/marlin_build/

(default settings) works with Beta2 (and Alpha4)

Share this post


Link to post
Share on other sites

Hi Daid, I need to be more precise. Just trying to point Jet in the direction of alpha 4 and Marlin from your builder tool. When the novelty wears off, I will try the Beta; I am really interested in your user interface developments, but don't want to hijack Jet's post. Keep up the great work!

Dave.

Share this post


Link to post
Share on other sites
Hi Daid, I need to be more precise. Just trying to point Jet in the direction of alpha 4 and Marlin from your builder tool. When the novelty wears off, I will try the Beta; I am really interested in your user interface developments, but don't want to hijack Jet's post. Keep up the great work!

Dave.

I have just been through my notes so I can be sure of what I installed. Repeating this should result in a working Ultimaker with Marlin and Skein_PyPy:

I followed instructions from the wiki:

http://wiki.ultimaker.com/SkeinPyPy

i updated the 5D firmware to Marlin from here (the first Marlin link in that wiki):

http://daid.eu/~daid/marlin_build/ ... sE=865.888

Then I installed the alpha4 version of Skein_PyPy from here:

https://github.com/daid/SkeinPyPy/downloads

Anyone with a recent Ultimaker should be able to repeat the above and get the same great results.

Jet, did you get it working now?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • Taking Advantage of DfAM
      This is a statement that’s often made about AM/3DP. I'll focus on the way DfAM can take advantage of some of the unique capabilities that AM and 3DP have to offer. I personally think that the use of AM/3DP for light-weighting is one of it’s most exciting possibilities and one that could play a key part in the sustainability of design and manufacturing in the future.
        • Like
      • 3 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!