Jump to content

Can't install new firmware T2 T3 LED FAN


Recommended Posts

Posted (edited) · Can't install new firmware T2 T3 LED FAN

My Ultimaker 2 has worked perfect ly for  years with exception to the led which had blown the T1 or T2 transistor.

so i replaced them both and also T3 as it was the same the light now work perfectly. however every time i tried to print or move the bed of print head

i  would get a ER06  or ER05 or ER07 i have tested the stop switch and my connection sereral time and all it fine.
after reading a few posts it suggested reinstalling the firmware , unfortunately it now thinks its the first time i've used the machine

and want to calibrate the bed but keep coming up with the errors messages i have tried to connect it the cura via a usb cable but it dose not detect the printer while it stuck in the 

calibration mode Help i understand you cannot install the firm ware via SD card.



Edited by superflyguy1973
  • Link to post
    Share on other sites

    Posted · Can't install new firmware T2 T3 LED FAN

    Did you perhaps install firmware for another printer? You say you have the UM2 and installing firmware for a UM2+ could show this behavior.

    Which Cura version are you using? We are now at Cura 4.3, but I remember about a year ago there was a bug in Cura where firmware versions for the UM2 and UM2+ were mixed up.


    Instructions for re-installing the firmware on a failing UM2 printer

    The newer versions of Cura are being 'nice' to your printer and that's why they fail in programming.


    In order to start the programming process, Cura has to reboot the printer. That's what older versions of Cura did when you connected the USB cable. Disadvantage was that when you were printing and you started Cura, then your multi-day print would reboot as well.... Oops.

    So, now Cura is nice to the ongoing print process but as a consequence fails to program a printer that's stuck.


    Your workaround is to use another program for programming the printer.
    One option is this old version of Cura: https://software.ultimaker.com/cura/Ultimaker_Cura-15.04.06.exe

    There are other programs as well, but I haven't done this since long so are not aware of the current situation. Look for programs that can program an Arduino AtMega 2560 board


    The UM2 firmware is a *.hex file and is included in the Cura program directory.

    For the UM2+ a release candidate for the next official version can be downloaded here: https://github.com/Ultimaker/UM2.1-Firmware/blob/UM2.1_JarJar/releases/beta/MarlinUltimaker2plus_20181007.hex  (right click on link, and then 'save link as').

  • Link to post
    Share on other sites

    Posted · Can't install new firmware T2 T3 LED FAN

    T1 and T2 are BC817 NPN transistors.

    T3 is a BC807 PNP transistor


    So glad Ultimaker provided the schematics so people will study them ....   🙄

    https://github.com/Ultimaker/Ultimaker2/blob/master/1091_Main_board_v2.1.1_(x1)/Main Board V2.1.1.pdf


    T3 indirectly switches on the 24V for the motors and the bed. So with a wrong type of transistor here it explains the wrong behavior in your printer.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
          • Like
        • 16 replies
      • S-Line Firmware 8.3.0 was released Nov. 20th on the "Latest" firmware branch.
        (Sorry, was out of office when this released)

        This update is for...
        All UltiMaker S series  
        New features
        Temperature status. During print preparation, the temperatures of the print cores and build plate will be shown on the display. This gives a better indication of the progress and remaining wait time. Save log files in paused state. It is now possible to save the printer's log files to USB if the currently active print job is paused. Previously, the Dump logs to USB option was only enabled if the printer was in idle state. Confirm print removal via Digital Factory. If the printer is connected to the Digital Factory, it is now possible to confirm the removal of a previous print job via the Digital Factory interface. This is useful in situations where the build plate is clear, but the operator forgot to select Confirm removal on the printer’s display. Visit this page for more information about this feature.
          • Like
        • 0 replies
    • Create New...