Jump to content
Mitchimus

Permanently change the default temperature nozzle/bed values for a particular filament type.

Recommended Posts

Posted · Permanently change the default temperature nozzle/bed values for a particular filament type.

I overrode the temperature values for PETG in the materials section only to get this code.

See inserted image immediately after this line.

 

image.thumb.png.55ac896c051e256472ce15f22b99cef1.png

 

It looks to me like CURA for some reason always defaults back to the template values. Can someone tell me why? Or am I just Barking up the wrong tree?

See inserted G-Code immediately after this line.

 

;FLAVOR:Marlin
;TIME:753
;Filament used: 1.22287m
;Layer height: 0.3
;MINX:132.704
;MINY:132.703
;MINZ:0.3
;MAXX:167.296
;MAXY:167.297
;MAXZ:3.9
;Generated with Cura_SteamEngine 4.3.0
M140 S80                               <this is my override
M105
M190 S80                               <this is my override
M104 S250                             <this is my override
M105
M109 S250                             <this is my override
M82 ;absolute extrusion mode
G28 ;Home
G1 Z15.0 F6000 ;Move the platform down 15mm
;Prime the extruder
G92 E0
G1 F200 E3
G92 E0
G92 E0
G28 ; home
G1 Z15 F100 ; raise the extruder F100 sets the feed rate
M107 ; Turn off fan
G90 ; Set absolute
G92 E0 ; Set position values specified for E X Y Z
M82 ; override G91 put E axis into absolute mode independent of the other axes
M140 S50 ; set bed temperature 50 degrees                                                                           <CURA puts this in and overrides my change
M190 S50 ; wait till bed reaches 50 degrees before continuing                                          <CURA puts this in and overrides my change
M104 T0 S190 ; Set extruder temperature 190 degrees and continue without waiting  <CURA puts this in and overrides my change
M109 T0 S190 ; wait for extruder temperature 190                                                               <CURA puts this in and overrides my change
G92 E0
G1 F1500 E-6.5
;LAYER_COUNT:13
;LAYER:0
M107
G1 F600 Z1.3
;MESH:F B Covers.stl
G0 F3600 X160.992 Y150.025 Z1.3
;TYPE:WALL-INNER
G1 F600 Z0.3
G1 F1500 E0

Share this post


Link to post
Share on other sites
Posted · Permanently change the default temperature nozzle/bed values for a particular filament type.

Not 100% sure but material related settings should go into material profiles. So you should create a new material in the settings and then select this custom material.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!