Jump to content

The GCODE Output File Sets the First Layer Height to +0.3mm


Recommended Posts

Posted · The GCODE Output File Sets the First Layer Height to +0.3mm

I have been wondering why my first layers are not sticking well. I checked my manual leveling using a 0.06mm feeler gauge and it seems fine. I then tried printing a part and turning the printer off at the first layer. I then measured the height (gap) with feeler gauges and measured 0.38mm. I looked at the GCODE file and found that the Z Height was being set to 0.3mm (G1 F600 Z0.3). See the code below:


Why does Cura do this?


;Filament used: 0.595774m
;Layer height: 0.2
;Generated with Cura_SteamEngine 4.3.0
M82 ;absolute extrusion mode
G21 ; metric values
G90 ; absolute positioning
M82 ; set extruder to absolute mode
M107 ; start with the fan off
M140 S105 ; Set bed temperature (no wait)
G28 X Y F6000 ; move X/Y to min endstops
G28 Z F1200 ; move Z to min endstops ; raise the nozzle
M190 S105 ; wait for bed temperature to reach target
M104 S220 T0 ; set extruder temperature (no wait)
G29 ; auto-leveling
M420 S1 ; enable bed leveling compensation
M109 S220 T0 ; set extruder temperature and wait
M300 P200 ; beep to indicate that the temp is reached
G0 F5000 X10 Y10 Z0.3 ; move to start
G1 F500 X60.0 E9 ; start purge line
G1 X150.0 E18.5 ; finish purge line
G92 E0 ; set extruder to zero
M117 Printing from Cura...; message
G92 E0
G92 E0
G1 F1200 E-0.5
G1 F600 Z1.3
;MESH:Nozzle Fan Spacer.stl
G0 F2400 X81.795 Y83.534 Z1.3
G1 F600 Z0.3
G1 F1200 E0
G1 F600 X81.749 Y84.028 E0.02475
G1 X81.804 Y84.495 E0.04821


  • Link to post
    Share on other sites

    Posted · The GCODE Output File Sets the First Layer Height to +0.3mm

    Yes that explains why your first layer has a height of 0.3mm.

    It is a default behavior in Cura that the first layer height is a little bit more than the configured layer height. It also depends on the layer height you configure, so it is not always 0.3.


    Opinions as to what is better are different. A higher Layer Height should ensure that an uneven print bed is better compensated. 


    But if you don't like it, just set the First Layer Height manually to the value you want or to the general Layer Height.

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Introducing the UltiMaker Factor 4
        We are happy to announce the next evolution in the UltiMaker 3D printer lineup: the UltiMaker Factor 4 industrial-grade 3D printer, designed to take manufacturing to new levels of efficiency and reliability. Factor 4 is an end-to-end 3D printing solution for light industrial applications
          • Thanks
          • Like
        • 3 replies
      • UltiMaker Cura 5.7 stable released
        Cura 5.7 is here and it brings a handy new workflow improvement when using Thingiverse and Cura together, as well as additional capabilities for Method series printers, and a powerful way of sharing print settings using new printer-agnostic project files! Read on to find out about all of these improvements and more. 
          • Like
        • 26 replies
    • Create New...